This looks all Firefoxed up
July 20, 2011 6:49 PM   Subscribe

Why is my Firefox not rendering styles correctly? I'm at my troubleshooting wit's end.

I noticed a while back that Wikipedia started to look like this, instead of this. Today, I opened up facebook and found it looking like this. There was a different, equally messed up version of my FB page that didn't have the endlessly uploading notifications window. It still had everything indented past the left side of the window, with no horizontal scroll bar. I've seen this same type of problem, today, on other sites, Glassdoor e.g.

I'm running FF 5 on Windows 7.

I have run through the entire Firefox troubleshooting list, including reinstalling. All of my add-ons are disabled. I find it hard to believe that this is a problem with FF 5 because no one else seems to be complaining about this. (Or my google-fu is horrendous - I tried countless iterations of keywords and scoured their forums)

What gives?
posted by HE Amb. T. S. L. DuVal to Computers & Internet (8 answers total) 1 user marked this as a favorite
 
View -> page style -> basic style instead of no style?

Failing that, try using a new profile and see if that solves the problem.
posted by mhoye at 7:21 PM on July 20, 2011


Both Wikipedia and Glassdoor are pulling css from external sites, so that is probably the source of the problem.

Do the pages render correctly using other browsers on the same system? If not, it could be a problem with querying the DNS for the external domains. Are you using a proxy in Firefox, by chance?

If you view the source on the pages, you could try loading the css directly to see if the file gets returned, or if it comes up as Page Not Found. For example, on GlassDoor, the CSS file I get is:

http://css.glassdoor.com/static/css/gd-core.css?rev=36795

Sorry, not a huge help, but hopefully someone else will see this and be able to figure out the reason.
posted by backwards guitar at 7:25 PM on July 20, 2011


I friken hate firefox 5, same issue here. Solution is to clear your cache. Options -> Advanced -> network -> clear now.

Repeat as often as necessary.
posted by Pink Fuzzy Bunny at 7:45 PM on July 20, 2011


Sorry that should be workaround not solution.
posted by Pink Fuzzy Bunny at 7:45 PM on July 20, 2011


You can also try doing a ctrl-F5 when this occurs. That forces the browser to completely reload the page and all associated content. A normal F5 refresh will reload the page but may include cached content. If the cached content (e.g., CSS files) was incomplete or corrupt, it could cause the behavior you're seeing.
posted by Blue Jello Elf at 8:08 PM on July 20, 2011


The poster said they followed Firefox's Troubleshooting tips, which include clearing your cache.
posted by backwards guitar at 8:12 PM on July 20, 2011


Seconding a hard refresh. Ctrl+f5. Use it whenever this happens
posted by Patbon at 9:15 PM on July 20, 2011


Backwards guitar, it does work on the system with other browsers. But, I'm embarrassed to say that the one tip I didn't follow was to clear the cache. I figured after entering safe mode and then the re-installation, the cache would be cleared as well.

In between noticing the first of these problems, with Wikipedia, and the latter ones, I installed Tor and Portable FF on a USB stick. I was using this from my computer, so I thought perhaps the proxy settings were somehow cross-pollinating.

Thanks, PFB and BJE. The hard refresh worked.
posted by HE Amb. T. S. L. DuVal at 11:43 PM on July 20, 2011


« Older I'm a dude going to marry a du...   |  How can I cool my house withou... Newer »
This thread is closed to new comments.