Join 3,516 readers in helping fund MetaFilter (Hide)


ÉÉÉÉÉÉÉ
May 27, 2011 2:33 PM   Subscribe

Why, oh why, does Chrome do thisÉ

See the É at the end of that sentence (and this one)É

Thatès supposed to be a question mark. Some of the other punctuation in this paragraph is bound to turn out wrong, too, like the apostrophe in Thatès.

It seems to be some kind of language or keyboard setting issue. It only happens in Chrome, and while itès happening in Chrome, anywhere else I type in another application is perfectly fine. Restarting Chrome doesnèt seem to help, though restarting my entire computer does.

I canèt find this mystery setting. I donèt know how it gets changed in the first place, nor how to change it back. It happens apparently randomly every few weeks.

Here are some other examples of punctuation thatès suddenly gone wrong in case it helps:
é - is a forward slash
" - is a greater than sign
' - is a less than sign
è - is an apostrophe
È - is a set of quotes
à - is a backslash
À - is a vertical bar
Ç and ¨- are curly braces
ç and ^- are square ones
posted by jacquilynne to Computers & Internet (15 answers total) 8 users marked this as a favorite
 
Linux? Windows? OS X? What version of Chrome are you running?
posted by Blazecock Pileon at 2:42 PM on May 27, 2011


Maybe related, maybe not -- do you have a key stuck on your keyboard? I mention this because that was a friend's problem for about a month. I can't recall if it was the CTRL or ALT or whatever key, but once he cleaned out his keyboard and discovered the (formerly) sticky key, it stopped. (He also stopped drinking soda at the keyboard.)
posted by Heretical at 2:43 PM on May 27, 2011


Check Wrench icon > Tools > Encoding. Try setting it to Auto detect.
posted by davcoo at 2:53 PM on May 27, 2011


Are you by chance using a Mac? OS X (Tiger, at least, and I assume later versions) can use different keyboards in different applications, and cmd-space is the common shortcut to switch. I've accidentally switched keyboards in a program more than once (for example, when copy-and-paste-ing) due to flubbing a keystroke, and not noticed until much later... Check for a flag logo in your menubar, near the clock.

I assume something similar is also possible in other OSes, but I'm not familiar with the specifics.
posted by FlyingMonkey at 2:53 PM on May 27, 2011


Windows Vista Home, and whatever one they upgraded to 20 minutes ago. Looking it up, 11.0.696.71

I donèt have a key stuck that Ièm aware of, but my right CTRL key doesnèt work in Chrome when this is happening, if thatès relevant.
posted by jacquilynne at 2:54 PM on May 27, 2011 [2 favorites]


If you're on windows and only chrome does this, you might have to make sure that your current keyboard layout is the only one that's configured on your pc; from what you say it sounds like windows is using a separate key layout for chrome only.
posted by 3mendo at 2:55 PM on May 27, 2011


Sounds like you've somehow changed your keyboard layout to the Canadian Multilingual Standard. In Windows, if you have another keyboard installed, "Switch Keyboards" is often bound to Ctrl+Shift. This can be customized (or turned off) in: Control Panel, Region and Language, Keyboards and Languages, Change Keyboards, Advanced Key Settings, Change Key Sequence.
posted by The Tensor at 2:56 PM on May 27, 2011 [3 favorites]


Definitely seems like a keyboard layout change happening when you activate Chrome. Happens to me sometimes with French and various random programs.
posted by SMPA at 3:00 PM on May 27, 2011


I removed all the other keyboard options from that Keyboards and Languages / Change Keyboards dialogue, and restarted. Cross my fingers that this won't come up again.
posted by jacquilynne at 3:05 PM on May 27, 2011


When it's happening check the "language bar", which is the little keyboardy lookin button next to the system tray that everyone immediately tells to go away when they set up Windows. You might need to re-enable it.

If you click on it, it should display your installed keyboard layouts and which is currently active. Just click on the one called "US" and you should be good.
posted by utsutsu at 3:18 PM on May 27, 2011 [1 favorite]



Sounds like you've somehow changed your keyboard layout to the Canadian Multilingual Standard.


yeah, this sounds like the problem.
posted by KokuRyu at 3:37 PM on May 27, 2011


Hit ctrl shift simultaneously and see how that goes for you.
posted by Decani at 5:40 PM on May 27, 2011 [2 favorites]


This happens to me sometimes also with Vista, and only when I am playing WoW... some key combination I hit while playing triggers it. Now I keep the keyboard language layout thing in my taskbar so I can just switch it back with a click.
posted by L'Estrange Fruit at 8:13 PM on May 27, 2011


I've been there.
posted by Alvy Ampersand at 9:20 PM on May 27, 2011


Removing all of the other keyboard layouts from the control panel seems to have made the problem go away. Of course, it was intermittent in the first place, so maybe it didn't?

(I was going to replace that last question mark with an É just for the LULZ, but then I realized it wasn't actually funny enough to be worth finding the character map in order to enter it. And then, I realized I could just copy and paste an É from somewhere else in this thread, but by that time I was no longer LULZING about it, so now you get this paragraph instead.)
posted by jacquilynne at 12:39 PM on June 27, 2011


« Older My best friend and I (living i...   |  How can I play .f4v (Flash Vid... Newer »
This thread is closed to new comments.