Skip

Netflix Playback
May 25, 2011 10:11 AM   Subscribe

Why is Netflix playback on my computer choppy?

I have a dell latitude D630 running Windows XP. Recently, I've been having this issue where when I'm watching movies on Netflix streaming, the video will suddenly become choppy. This usually happens after watching without incident for about 20 minutes. After it happens the first time, it will go away if I reload or scan to a different part of whatever I'm watching, but usually re-occurs after about 1-5 minutes.

Data Points:

-I have tried turning off a lot of non-essential services that come on at startup.
-The choppiness issue doesn't appear to correlate with an increased use of CPU, at least not according to task manager.
-I have run windows update to make sure I have all the latest garbage, and I have even run the optional updates.
-The same problem doesn't occur if I'm watching other streaming services (Hulu, Youtube). It also doesn't happen if I'm watching a DVD.
-It's specific to this machine. Playing back using the same account on another computer or my phone does not produce the same problems.

Does anyone have any suggestions that might help?

Thanks.
posted by to sir with millipedes to Computers & Internet (19 answers total) 1 user marked this as a favorite
 
Someone smarter than me will answer the core question, but I can tell you that you are not alone since I get a query from Netflix after every viewing, asking me to rate the viewing quality of the movie I just saw.
posted by thinkpiece at 10:14 AM on May 25, 2011


I've had this trouble lately too. I try to refresh the browser, but that doesn't always work. Then I do get queries from netflix like thinkpiece said and I click "unacceptable."
posted by anniecat at 10:23 AM on May 25, 2011


Does it matter which browser you use?
posted by utsutsu at 10:35 AM on May 25, 2011


No, it happens regardless of the browser I'm using. (typically chrome - have also tried Firefox and IE)
posted by to sir with millipedes at 10:38 AM on May 25, 2011


Did you update Flash? Windows Update will not do that for you.
posted by dhalgren at 10:39 AM on May 25, 2011


Sorry, my mistake. I guess they use Silverlight now.
posted by dhalgren at 10:41 AM on May 25, 2011


Also, that may be why you have problems with this but not Hulu or YouTube. AFAIK, those two are using Flash, not Silverlight.
posted by dhalgren at 10:43 AM on May 25, 2011


See if your video card has a newer driver. support.dell.com. Site really blows, but should let you put in you service tag # and search for drivers for your laptop.

There are a lot of Internet Speed Tests. See what kind of network speed you're getting.

If you start the movie, then pause it, does a netflix flick continue to load? If so, maybe you could launch it, pause it, let it get a good head start, then watch it.

Let Netflix know, and give them lots of info, esp. the network speed. They seem pretty responsive.
posted by theora55 at 10:48 AM on May 25, 2011


When you say choppy, do you mean a low framerate or frequent rebuffering? I would not expect the former to be the result of a slow Internet connection, unless you also experience other picture quality problems (lower resolution, terrible color, etc.
posted by mkb at 10:56 AM on May 25, 2011


I mean maybe 1 frame a second, while the audio continues generally unimpeded. It's not a bandwidth issue. I've seen it happen on multiple networks, including networks where a number of other computers are playing netflix videos without issue.
posted by to sir with millipedes at 11:00 AM on May 25, 2011


Happens to us all the time, too where the frame slows down to every second or so and the audio continues on. Sometimes the video then skips forward to match the audio, sometimes it stops entirely and requires re-starting. I always figured it was our internet connection.
posted by otherwordlyglow at 11:07 AM on May 25, 2011


I started to use Netflix in one browser, and do all my web surfing in another (Firefox and Safari, respectively), and this problem went away.
posted by kimota at 11:15 AM on May 25, 2011


I have the same problem. It's definitely not your internet connection though. As far as I can tell, one of two things happened:

1.) Netflix updated something on their end that's driving up RAM usage on the Silverlight plugin to spike.

OR

2.) The silverlight plugin was recently updated (withing the past 2 months or so), and that's causing RAM usage to spike.

I don't think it has too much to do with CPU load, but I could definitely be wrong; I haven't been annoyed enough yet to really investigate the problem.
posted by thsmchnekllsfascists at 11:16 AM on May 25, 2011


Tried updating video drivers to no avail.
posted by to sir with millipedes at 1:39 PM on May 25, 2011


How much RAM? Try turning the HD checkbox off if it's not already.
posted by thsmchnekllsfascists at 1:50 PM on May 25, 2011 [1 favorite]


Yes, turn off HD if it's not already turned off. I was having choppy video problems while watching Netflix, and that fixed the problem for me.
posted by aabbbiee at 2:22 PM on May 25, 2011


I watch Netflix on a Dell Latitude D830, and had the exact same problem with Netflix but never Hulu or Youtube. It wasn't bandwidth. I updated Silverlight. I checked RAM. I increased the refresh rate. I wasn't watching in high definition. I tried different browsers. I increased the cache. I even changed the Energy Savings settings, due to something I'd read. I tracked down different web articles and the few brief mentions on the Netflix blog. My CPU was through the roof and I toyed with shutting everything possible down.

I found the solution at this response on the Silverlight forum. Change your monitor settings to 800 x 600 pixels. (On the Control Panel, click Adjust Screen Resolution. On the Display Settings window, drag the Resolution from High to Low.)
posted by Houstonian at 4:22 PM on May 25, 2011 [1 favorite]


That's pretty fucking janky. I guess upscaling low-res to hi-res in silverlight eats a lot of resources.
posted by thsmchnekllsfascists at 4:26 PM on May 25, 2011


Update - It looks like shutting off HD resolved the issue. I'll follow up here if the problem crops up again. If it does, I will also try changing the screen resolution.

Thanks everyone for your help!
posted by to sir with millipedes at 6:16 PM on May 25, 2011


« Older I am reading "The call of...   |  Where can I find software that... Newer »
This thread is closed to new comments.


Post