Join 3,561 readers in helping fund MetaFilter (Hide)

Tags:

HDMI Yi YI!
March 31, 2011 4:09 PM   Subscribe

How can I connect my laptop to my tv, such that the sound comes through the tv and the screen is framed properly?

Here are my laptop specs (and graphics/audio specs). I am running an HDMI from my laptop to my Panasonic Viera 42" Plasma tv. The picture works, but the sound only comes through the laptop speakers. The picture is also cropped on the bottom and sides when displayed on the tv.

I'd like to fix both those issues, but have thus far been unable to find a solution. Can someone help?
posted by joelhunt to Computers & Internet (8 answers total) 4 users marked this as a favorite
 
If I were at home, this would be easier. IIRC, in Win 7, Control Panel, Sound, Playback (?), HDMI Sound, Enable/Set Default. It definitely should be possible as you have the HDMI Audio Driver per your audio specs.

It sounds like the TV is a 720p due to the chopping of the sides and bottom. Try changing your computer's resolution to 1280x720 so that the laptop and TV match.
posted by Mister Fabulous at 4:22 PM on March 31, 2011


My specs are totally different (MacBook Pro, Sharp TV) and I needed one of these $2.50 cables, but there was also a specific setting I had to adjust in the TV's menu (which is grayed out unless I've got the TV on the laptop's output). It will be different on yours, of course, but on the Sharp it's labeled PC Audio Select.

If you haven't tried the TV settings I'd check that, too.
posted by Room 641-A at 4:29 PM on March 31, 2011


Seconding Mr. Fabulous re: the sound. You can also access this using these steps: right-click on the volume control icon next to your clock, then go down to Playback Devices (should be the last item on the list of options that comes up). You should see HDMI as an option. Click Enable/Set Default. If that doesn't work right away, set it as default, leave everything plugged in, and restart your computer-- it should work then.
posted by samthemander at 4:56 PM on March 31, 2011


HDMI is not coming up as an option when I go into Playback. There is only one choice, and that is the laptop speakers.

As for the display, it is already set at 1280 x 720. And the tv is 720p.
posted by joelhunt at 6:12 PM on March 31, 2011


I used one of those cables mentioned by Room 641-A. I got a splitter (short cable - like a Y). It is the same cable that you would run to your speakers from your sound card. I put another cable from the other side of the Y and plugged it into the back of the TV. I get sound and video on the computer perfectly from vids I run on the PC. I hope it is clear what I did. Of course I used the HDMI cable from the PC to the HDMI input on the TV as well.

As to resolution - when I went to Control Panel / Display and selected the TV as the monitor and used the recommended resolution and it works great. If you have a resolution problem you should try another. Or check the TV to see what resolution is recommended.
posted by JayRwv at 7:50 PM on March 31, 2011


You'll have to go with the 3.5mm jack for sound. As for the TV still chopping off the edges: make sure the TV is set to "Native" mode. If that doesn't fix it, try setting the video to 1366x768 (some 720p's actually run this resolution). If that doesn't fix it, check for an overscan/underscan option in your video settings. You want 0%.
posted by Mister Fabulous at 9:12 PM on March 31, 2011


Does your audio driver have its own entry in the Control Panel or in the taskbar area, separate from Windows' native Sound? When I hooked my laptop up to my HDTV this one time, the settings to send the audio through HDMI were located in the control panel for my audio driver.
posted by puritycontrol at 10:13 PM on March 31, 2011


Well, for interested parties, here is how I fixed both problems:

HDMI audio was restored by going to the Intel website to get the latest driver for my graphics card. Following a reboot, my HDMI audio settings were active and accessible after hooking the laptop up to my tv.

As for picture resolution, so far the best solution I've found is to use the 1360 x 768 resolution, then change my tv aspect to ZOOM. Perfectly formatted, but I am likely losing sharpness by zooming.

Thanks for the help!
posted by joelhunt at 4:49 AM on April 2, 2011


« Older What interesting questions wou...   |  On NPR in Los Angeles yesterd... Newer »
This thread is closed to new comments.