Skip

My Wi-Fi keeps kicking me offline, and I don't know why.
March 28, 2011 10:11 AM   Subscribe

My wireless (Wi-Fi) network has started kicking me and my roommates off intermittently. My guess is there's interference but I can't figure out what to do about it, and nothing I've tried seems to work. Help!

Yesterday, my Wi-Fi started disconnecting me and my roommates for five or ten minutes at a time. But the rest of the time, it works fine (say, for a half hour or so between disconnections). It is definitely a problem with the wireless part of the equation: I can plug in to the router via Ethernet and use the Internet just fine, even when other devices cannot access the Wi-Fi. Weirdly, devices usually show a good connection (e.g., the Windows taskbar "connected to the Internet" icon--two computers with a globe) even while refusing to connect to any sites (including an inability to ping 192.168.0.1, the router's local IP).

Given that, and some Googling, I suspected interference, so I first switched channels from the default auto-scan to Channel 9 (looked clearest using inSSIDer) and then to Channel 11 (suggested by Wifi Analyzer for Android, and by some random site that said you should always be on 1, 6, or 11 because doing so enables nearby routers to split the spectrum most effectively). The spectrum is crowded with Wi-Fi networks in my neighborhood; my neighbors (with whom our townhouse shares a wall) are using Channel 2, which makes me think Channel 1 would be a bad move. I've switched back to auto-scan, which has settled on Channel 8 and still has issues.

Power cycling the router immediately fixes the problem, though waiting passively for some length of time usually does, too. Disconnecting from the network leads to one of two very different outcomes: Either the SSID is no longer visible, or if it is, I can usually reconnect on first or second try and get right back on the Internet.

Other potentially revelant info:
* Gmail chat seems to persist a little longer than websites; that is, I was still receiving chats even when webpage loading had started to turn sluggish and indicate that a drop was about to happen. (All in Google Chrome on a Vista laptop.)
* Using the Time Graph on Wifi Analyzer, at least once it looked like my signal strength, as well as my neighbor's, dropped suddenly right about the time my Internet cut out. This seemed especially odd since I'm on 11 and she's on 2. But I haven't seen this repeat.
* A few weeks ago, our router spontaneously (I think) reset itself. I got back from spring break and found it was in factory default mode. Nobody admits resetting it, so I don't know what happened. If it was a lightning strike or something, everything has been working basically fine since then.
* Router logs have not seemed helpful, though at least some of the time when I get disconnected, I get a message like "Wireless system with MAC address {whatever} disconnected for reason: Received Deauthentication."

Router is a D-Link DIR-615 (firmware upgraded to 2.25 yesterday, first response after the outages started), which I've had for almost three years with no problems. I'm on Vista but that likely doesn't matter--same issues on Android and iOS devices as well.

Any ideas?
posted by SuperNova to Computers & Internet (8 answers total) 4 users marked this as a favorite
 
1, 6, and 11 can co-exist without overlap, so most people use one of those three. If you use 8, you can be interefered with by people on 6 and people on 11.

If you are using 802.11n gear, you could consider going to 5GHz. it's usually clearer spectrum. 2.4GHz is where any number of other devices are also using (or destroying) the bandwidth, including microwave ovens and many wireless landline phones (less frequently, blow driers and shredders, or remote controlled toy cars). Unlicensed spectrum can be used by anything, so going to the least used frequency is the best bet.
posted by Mad_Carew at 10:20 AM on March 28, 2011


The 2.4ghz space can be very crowded, with microwave ovens and bluetooth and CFL lights running interference.

If the neighbor's wifi is also dropping at the same time as yours, it is probably due to interference. The best thing you could do is to get an AP with a 5ghz radio as well.
posted by Threeway Handshake at 10:22 AM on March 28, 2011


Disclaimer: I'm not all that knowledgeable about computers.

But this kind of thing happened to me and my roommate recently, and after talking to my ISP we ascertained that something had gone screwy in my router itself, insofar as it had decided it was going to periodically lock me out of the network (for some reason it wasn't recognizing my password to the network). I called the manufacturer of my router and they walked me through re-setting it to the factory defaults, and that fixed it. According to the tech office at my ISP and at the router manufacturer, sometimes this "just happens".

It's something to consider, anyway.
posted by EmpressCallipygos at 11:45 AM on March 28, 2011


I agree with the previous comments about considering interference and moving to 5 ghz, although perhaps you have some devices like iPods, iPhones that preclude that option.

Some additional off the wall thoughts are: do you have the router and DSL or cable modem plugged into a UPS? Or can you at least try a different circuit? I am wondering what else you have on that circuit. Have you checked the lease time for the assigned IP addresses? Any correspondence? You might also consider a static IP address. I know that probably seems odd but I was having difficulty with my iPad and wifi. The recommended solution was to use a static IP and it worked for me.
Good luck.
posted by PickeringPete at 12:40 PM on March 28, 2011


I had the same problem with different hardware - very annoying. I turned off WPA security and added MAC address filtering and the problem was gone. I can't explain why that worked, but it did.
posted by exogenous at 1:18 PM on March 28, 2011


Is anyone in your house torrenting? If you don't limit the # of connections, it can overwhelm the router.
posted by BobbyVan at 2:18 PM on March 28, 2011


My roommates and I had this problem for a while, and the fix that ended up working for us was going into the router's setup page and having the router reserve IP addresses for each of the our computers - as in it would only assign 192.168.1.2 to my Macbook, 192.168.1.3 to my roommates notebook, 192.168.1.4 to our HTPC, etc.
posted by patnasty at 8:15 PM on March 28, 2011


Thanks for the answers, everybody. Ultimately, I ended up seeing mention on another site that turning off the Quality of Service engine can help, because (they say) doing that processing on top of dealing with a lot of devices can overwhelm the router. I did that and things seemed to work. BUT, then one of my roommates inexplicably did a hard reset on the router (maybe that's what happened before, too) and after the reset, turning off QOS alone didn't resolve the issue.

So then I also reserved static IP addresses for everyone. I didn't think MAC filtering would work for our purposes, because of friends coming over and me not always being around to let them in the network. But static IPs seem to have us working normally again. I don't want to speak too soon, but after a couple days of being OK, I felt like I should update the thread.

Thanks again for all the help.
posted by SuperNova at 3:25 PM on April 2, 2011


« Older Is three hours enough time to ...   |  Trip to Europe. Need a day ba... Newer »
This thread is closed to new comments.


Post