Join 3,557 readers in helping fund MetaFilter (Hide)


Can you help me get set up with Photoshop CS5 and a new non-Apple cinema display?
March 22, 2011 12:39 PM   Subscribe

Can you help me get set up with Photoshop CS5 and a new non-Apple cinema display?

I've switched from CS4 to CS5 and noticed a few things are different. Still unsure how to fix them, such as:

1) I used to be able to Fill a layer with Shift+F5. My shortcuts menu claims that's still the case, but nothing happens when I click.

2) I use Option+Zoom/Scroll a lot to zoom in and out of files. With CS5 the zoom is really wobbly and doesn't actually zoom into where you've placed your cursor. Is there a setting to make it more precise and centered?

3) I've realized I kind of hate the glossy 15" screen and want to try a cinema display. But Apple's selection these days is limited to a gigantic glossy screen with eye-strainingly high resolution. What's the nicest non-Apple display that works well in conjunction with a Macbook, is less than 23" wide, intended for 1440 resolution and has a matte screen?

4) Is there any reason to think the trackpad on this latest MBP is a different material than a MBP of, say, 2008? I feel like my fingers are slipping all over it. Wondering if it's super slippery because it's new or if there is more friction after I've used it awhile.

Thanks!
posted by critzer to Computers & Internet (11 answers total) 1 user marked this as a favorite
 
1: Shift-F5 now brings up a dialog with various fill options, instead of just filling with the background color. Are you not seeing the dialog? What happens when you select the Edit > Fill menu option? (Should be the same dialog.) Maybe it's just tucked in a corner somewhere and you're not noticing it? Or, it's not available in all circumstances, so make sure you're in a writable, visible layer for example. Or possibly you have other keymappings outside of photoshop that are interfering; try assigning a different key under Edit:Keyboard Shortcuts.

2: Zooming in CS5 works very differently from in CS3, which used to always zoom to center of the screen (I skipped CS4, so don't know if this was the case there as well); now the zoom is centered on your cursor position, and that center will move around if you're moving the mouse while zooming. This drove me nuts for a while but now that I'm used to it I really prefer it to the previous behavior. Give it some time before you decide it's something you need to "fix". (I can imagine this would feel a little clumsy on a trackpad, since your finger is going to slide around while you zoom -- but I can't imagine using photoshop with a trackpad in any case...)

3: No idea. FWIW I love my gigantic glossy screen with eye-strainingly high resolution.

4: Not sure, but I wouldn't be surprised if this was deliberate; less friction for something you spend all day sliding a finger around on sounds like a good thing all in all. In a couple of days you'll be used to it and your old trackpad will feel weirdly draggy and sticky.

I can relate, for what it's worth; I'm typing this on a new keyboard and it's really weirding me out. Upgrades always feel wrong for a while until you get used to them.
posted by ook at 1:19 PM on March 22, 2011


Thanks ook.

Shift-F5 now brings up a dialog with various fill options, instead of just filling with the background color. Are you not seeing the dialog?

Shift-F5 brings up the icon for the display brightness of OSX. Definitely does not open anything related to Fill in Photoshop. How to decouple this command so that it treats the command differently for OSX and Photoshop?
posted by critzer at 1:26 PM on March 22, 2011


There is a fn key at the right of the keyboard (I have the fullsize Apple keyboard, and its in the group of six keys to the left of the numeric keypad part). You have to hold the "fn" key to use the function keys as, well, function keys. There may be a way to toggle this, but I've never looked.
posted by Admiral Haddock at 1:29 PM on March 22, 2011


You can bypass Apple's hijacking of the Function keys by going to System Preferences -> Keyboard & Mouse-> Keyboard and checking the box at the bottom that says "Use all F1, F2, etc. keys as standard function keys." That will give you your shift+F5 back. Then, to use Apple's keyboard function, press the "fn" key next to "home."
posted by lekvar at 1:40 PM on March 22, 2011 [1 favorite]


You just made my day, lekvar. I wuv my new MacBook Pro, but that was the one thing that was driving me absolutely crazy.
posted by xedrik at 1:58 PM on March 22, 2011


Glad I could help. I could go on all day about Apple taking away my F-keys straight out of the box, but I will leave it at "GRAR" and continue to help others who feel the same.
posted by lekvar at 2:02 PM on March 22, 2011


Thanks guys. Would love any display recommendations you have as well.

Just realized one more thing: with CS4, you could CTRL+CMD+Click a layer and it would display all layers in a menu and immediately highlight the layer you clicked. With CS5, it still shows lists the layers, but doesn't tell you which one you clicked. Did this shortcut change too?
posted by critzer at 2:24 PM on March 22, 2011


Just discovered: Preferences->General->"Zoom Clicked Point to Center"

Woohoo!
posted by critzer at 2:56 PM on March 22, 2011


In terms of monitors, it really depends on your budget.

The absolute best is probably an Eizo ColourEdge or an NEC SpectraView. If you're doing colour-critical work and need something you can rely on 100% then that's your best bet. However, you do pay for that level of quality.

For a lower priced option, I've seen the HP ZR24W and the Dell U2410 recommended consistently around the web. I know these are 24" monitors, but maybe you could find a 22" version of one of them? FWIW, a friend of mine has the 24" HP and says it's very good.
posted by Magnakai at 4:36 AM on March 23, 2011


I have a particular fondness for Samsung monitors. Colors are great, nice matte finish as you specify, and nice in 22". The display resolution is 1680 x 1050, though. Don't know what you'll find for 1440.
posted by clone boulevard at 10:01 AM on March 23, 2011


Very late follow-up: I'm dual-booting my MBP between Snow Leopard and Win7 for some proprietary software. The same behavior was driving me nuts in Windows; the F-keys were controlling backlight, volume, etc. and I'd have to press the Fn key to access the function keys. This was driving me nuts, trying to breeze through screens on our custom software, and I'd wind up turning the backlight off or some such.

In the taskbar, right-click on the Boot Camp icon, choose Boot Camp Control Panel. On the Keyboard tab, there is a checkbox to make the F1-F12 keys behave normally, though you can still use the special functions by pressing the Fn key along with a Function key. So there is a toggle in Windows, just like in MacOS.

Now... Now I am finally totally in love with my widdle Mac! *swoon*
posted by xedrik at 11:43 AM on April 19, 2011


« Older Bipolar filter: Righteous indi...   |  Can someone tell me what is ha... Newer »
This thread is closed to new comments.