Join 3,497 readers in helping fund MetaFilter (Hide)


Why doesn't my netbook want to use its entire screen anymore?
January 28, 2011 8:01 AM   Subscribe

My netbook seems to think its monitor is 3/4 its actual size. Wha?

I awoke my netbook (a Compaq Mini 110-1100CA running Windows XP) from hibernation yesterday and discovered that it no longer wanted to use all of its modest monitor. Instead, it is outputting to the upper-left 3/4 of the monitor (as if that were the whole thing -- toolbar at the bottom, etc.). The righthand 1/4 of the screen is black (not dead, just black output); the bottom 1/4 is... the same as the top 1/4, tiled, with maybe 1/4 inch of black buffer space.

This has been a difficult problem to google for, and the one or two relevant hits I've found didn't offer advice that worked. I've done the obvious: restarted, shut down, uninstalled and reinstalled drivers, changed screen resolution (which ended up using the same amount of monitor space, forcing me to scroll along the edges), plugged in an external monitor (which worked fine, but didn't solve my built-in monitor woes), restored to a previous state, etc.

I think the display screen's description of the monitor might have changed since back when it was working, but I admit I haven't paid too close attention to that.

Any suggestions? Many thanks in advance...
posted by Casuistry to Computers & Internet (8 answers total)
 
I have no idea what kind of video drivers the Compaq will be using, but this happens all of the time with AMD video cards. The feature might be listed as "scaling" or "underscan/overscan."
posted by Mister Fabulous at 8:58 AM on January 28, 2011


Right click on your desktop, select your video card settings, and poke around looking for a setting called scaling. Set this to zero.

That's what solved an ASUS+HDMI+external monitor=weird black bars issue for us, at least.
posted by deludingmyself at 9:13 AM on January 28, 2011


I don't see anything like that.

I do notice that the Device Manager, under "Monitors", lists three "Digital Flat Panel (800x600)"s, when in fact my monitor should be 1024x600.
posted by Casuistry at 10:15 AM on January 28, 2011


Perhaps you could delete the bogus monitors in Device Manager, restart, and see if the correct monitor is detected.
posted by exphysicist345 at 12:10 PM on January 28, 2011


I tried that again, and now I have no monitor drivers at all, and can't get out of 600x480 (or whatever it is) mode. It can't seem to find the drivers to update it with. Sigh.
posted by Casuistry at 3:40 PM on January 28, 2011


This may or may not work:
  1. Download this file from from ibm.com and run it to extract the INF and ICM files to a folder.
  2. Right-click on desktop, select Properties
  3. Click Settings Tab
  4. Click Advanced
  5. Click Monitor tab
  6. Click Properties
  7. Click Driver tab
  8. Click the Update Driver button
  9. Select "No, not this time" and click Next
  10. Select "Install from a list or specific location (Advanced)" and click Next
  11. Select "Don't Search, I will choose the driver to install" and click Next
  12. Click the Have Disk button
  13. Browse to the location of INF file (the default for the self-extracting archive is C:\DRIVERS\WIN\MONITOR) and click OK
  14. Select ThinkPad Display 1024x600 (the first entry in the list)
  15. Click Finish
Close everything out, then right-click on desktop, Properties, Settings...see if 1024x600 shows up.

You might need to reboot to see the 1024x600 mode.

Good luck!

Is it under warranty? My next move if this adventure doesn't work would be to contact HP tech support.
posted by ostranenie at 10:07 PM on January 28, 2011


You will be shocked, shocked!, to hear that the warranty expired two weeks ago.

That doesn't seem to have helped, so far (but thanks for the attempt!). Under "Display Properties" > "Advanced" > "Adapter" > "List All Modes", it lists 800x600 as the largest mode. I am wondering if this is a clue.
posted by Casuistry at 9:23 AM on January 29, 2011


Maybe fiddle around with PowerStrip?
posted by ostranenie at 10:12 AM on February 1, 2011


« Older I need to get out of Manhattan...   |  I'm looking for free birdcall ... Newer »
This thread is closed to new comments.