How to connect PC to a Mac?
January 4, 2011 1:59 PM   Subscribe

Need to connect a Windows 7 PC to a Mac. Am stuck at certain point, where there is probably a simple answer. Help me through the embarrassment before I toss both in the trash and become a hermit.

The Mac is running 10.4.11 and is set up for Windows sharing. The Windows 7 PC sees it. I double click on the Mac computer's icon while on the PC. The PC throws up a window asking for for name and password. I enter the user name and password of an administrator on the Mac. The PC says it's a logon failure, pops up a dialog box which already has the username entered as LAPTOP\foo then has a box for me to type in the password. Typing in the password doesn't' work, same dialog box comes back.


What am I doing wrong and what do I need to do?
posted by Brandon Blatcher to Computers & Internet (8 answers total) 1 user marked this as a favorite
 
The LAPTOP\foo is LAPTOP the Mac or the PC? If it's the PC, switch it to the Mac name

MAC\[mac administrator]
[password for that admin]
posted by defcom1 at 2:11 PM on January 4, 2011


A slightly modified take here:

Click “Start > Run” and enter “\\192.168.1.2\edesignuk”, replacing the IP address with the IP address of your Mac, and “edesignuk” with the short user name of your account in OS X. When asked to authenticate enter your Mac accounts short user name and password. All being well you should now be able to see you entire home folder on your OS X system. You can also map this share like you would any other Windows network share so that it is accessible from a drive letter.
Source: http://guides.macrumors.com/Networking_Windows_with_Mac_OS_X
posted by defcom1 at 2:13 PM on January 4, 2011


The LAPTOP\foo is LAPTOP the Mac or the PC? If it's the PC, switch it to the Mac name

I can not switch it. After trying it with Mac user name and password, Windows puts up the LAPTOP\foo as the user name

When asked to authenticate enter your Mac accounts short user name and password.

This did not work either, same error, Windows says "login error" puts the username / password dialog back up, but has "LAPTOP\foo" as the username.
posted by Brandon Blatcher at 2:23 PM on January 4, 2011


In addition to enabling Windows File Sharing generally, did you also enable it for the specific account you're trying to log in as? I recall OS X's Sharing preferences having a list of users allowed to log in specifically for Windows sharing. (For unspecified "security reasons" that sounded like a jab at MS.)

I do not recall having to qualify the username in any way, but it's been a while since I've done this.
posted by serathen at 2:30 PM on January 4, 2011


Perhaps try these file sharing setup instructions.
posted by Blazecock Pileon at 2:56 PM on January 4, 2011


Thanks serathen, that did it!
posted by Brandon Blatcher at 6:40 PM on January 4, 2011


as serathen says, you'll need to enable SMB sharing for the specific account(s) you want to use as well as for the system as a whole - when you do this you'll need to reset the account passwords, though you can set them to the same as they were before. If you don't do this then you'll get a password incorrect or similar error (like the login box just reappearing) since the Samba server doesn't know your password.

(OSX and SMB use different password hashes, so there's no way to get from what OSX already knows to what's required for the PC client, hence you need to set the password again to correctly configure Samba. They don't do this for all accounts by default since the LM hash, used by obsolete versions of windows, is trivial to break. They should probably just drop support for file sharing to Win98/ME clients.)
posted by russm at 6:56 PM on January 4, 2011


on non-preview, never mind...
posted by russm at 6:56 PM on January 4, 2011


« Older Snippet/Note tracking system requested.   |   Myanmar Travel Newer »
This thread is closed to new comments.