Join 3,425 readers in helping fund MetaFilter (Hide)


I Phone work with WI FI
December 13, 2010 12:06 PM   Subscribe

Is there any way to use the wifi connection on my i phone 3 G with out a data package.I have a Go phone sim card in the phone. When i hit Safari on my phone it tells me can't access " you don't have a data package"
posted by martynkd to Computers & Internet (3 answers total)
 
Have you turned off cellular data in settings? I think it's settings/general/network.
posted by spikeleemajortomdickandharryconnickjrmints at 12:10 PM on December 13, 2010


I have a similar phone setup (dataless gophone sim in an unlocked iPhone) and while it will whine about the missing data plan I always get wifi when available. You should double-check your wifi settings.
posted by O9scar at 12:24 PM on December 13, 2010


standard wifi connection troubleshooting:

1) is there a wireless network around? if not, then you're not going to get wifi.
2) does it have a password? if so, you'll have to tell the iPhone what it is to get on the network. whether or not it does depends on the network itself - lots of coffee shops, etc. provide Wi-Fi but they put a password on the network to keep people from mooching off of it. you may need to ask someone what the password is.
3) does your iPhone know to connect to it? to check, go into Settings, then Wi-Fi. a list of networks will pop up. a little blue check mark will appear next to the network name if it's connected to one already. if you don't see one, or if it's on the wrong network, tap on the one you want to connect to. if that network needs a password, type it in when it asks.
4) if you've gotten this far and you're still not connected, try a different network. or, click the blue > arrow on the right side of the network name - this will bring up network info - and click Forget this Network. this will make the iPhone forget the network, and you can try again. (some wireless networks will still let you on if you flub the password but won't actually work.)

you can explicitly turn off the cell data by going to Settings, then General, then Network. slide the slider for Cellular Data to Off.

I don't typically see the data package message on my old 3G (I've since upgraded to the 4, so the old SIM is deactivated) - but, then, it never leaves my house now and it knows how to talk to my network already. plus, the SIM is deactivated so I don't have cell service on it at all anyway.
posted by mrg at 12:45 PM on December 13, 2010


« Older Would the SO moving into "...   |  My sister took her car to a me... Newer »
This thread is closed to new comments.