Skip

Ipad + Bluetooth keyboard = no wifi?
November 20, 2010 8:09 AM   Subscribe

I have a wifi iPad. It works well with my Bluetooth keyboard. It works well getting wifi. But using the Bluetooth keyboard disables the wifi. In fact, it eliminates the wifi from even being listed in the list of available networks? What gives? Will I ever be able to use my Bluetooth keyboard and wifi at the same time on my iPad?
posted by vitabellosi to Computers & Internet (6 answers total)
 
Rumors have it there are a whole bunch of WiFi issues that holding up the imminent release of a new version of the iPad software, iOS version 4.2.1

What's true about all the rumors remain to be seen, of course, but it appears the answer to your question might well be "wait a week or so".
posted by DreamerFi at 8:34 AM on November 20, 2010


This doesn't sound right. I use my Wi-Fi iPad with a bluetooth keyboard at the same time frequently, and never run into any problems. Your iPad may need a trip back to Apple.
posted by mariokrat at 8:35 AM on November 20, 2010


at the same time as Wi-Fi...
posted by mariokrat at 8:35 AM on November 20, 2010


It's weird. I'm using both right now. But every time I come to this coffee shop and set up to get to work, a few minutes in using my Bluetooth keyboard, the wifi turns off and doesn't show up in the available list. I have to turn off the Bluetooth in order for the coffee shop wifi to show up in the list.

I go through this a few times.

Yet here I sit, using both right now.

I wonder if it matters which order I go in? Maybe if I turn the keyboard on first, and then the wifi, it will work.

I'll keep experimenting and I'll be on the look out for software updates!
posted by vitabellosi at 8:41 AM on November 20, 2010


I think interference may actually be the most likely issue, rather than an iPad-specific issue (particularly one associated with unreleased software).

See this Apple article: http://support.apple.com/kb/HT1365

I had a similar issue when I use my Bluetooth keyboard with my Macbook too close to my Wifi router.

For me, adjusting the strength of the Wifi signal (it didn't need to be at 100%) and changing its position solved this problem. (I put it up high in a corner that had line of sight across my apartment, rather than having it right behind my couch and sitting right by it).

I think there are more sophisticated options that I can't expound on that might help if the most likely source of interference seems to be your wifi router itself. The router might be automatically picking certain settings (to avoid conflict with other wifi networks it detects, for example) or default settings just not be appropriate.

The Apple support article points out there are other kinds of interference you need to consider.
posted by mjb at 9:09 AM on November 20, 2010


is it jailbroken??
posted by knockoutking at 10:23 PM on November 20, 2010


« Older Should I meet with my former f...   |  Successful in life, but feelin... Newer »
This thread is closed to new comments.


Post