Tags:

Make AAPL and MSFT play nice together
October 10, 2010 2:53 PM   Subscribe

I'm trying to set up home sharing on Apple TV/iTunes so that I can access the library on my computer via Apple TV.

I have a Windows laptop. Windows 7, latest version of iTunes.

The wifi connection between the Apple TV and my wifi router works fine (I can rent movies from itunes/netflix with no problem.

I can't get my Apple TV to recognize my iTunes library on my laptop.

I've reviewed all the instructions here. I think there is a problem with my firewall settings. The instructions say "Home Sharing uses TCP port 3689 and UDP port 5353 to communicate with other copies of iTunes."

What does this mean and how do I change these settings? My firewall software is Kaspersky 2010.

Thanks!
posted by dfriedman to Computers & Internet (5 answers total)
 
Are you sure you have iTunes 10.1? I was, until I spent a frustrating hour trying to get Home Sharing working before checking my version of iTunes, juuust to make sure. I was on 10.0.
posted by Rock Steady at 3:25 PM on October 10, 2010


I have 10.0.1, which is the most recent version.
posted by dfriedman at 3:32 PM on October 10, 2010


I'm not a networking expert, but the first thing I'd do would be to turn off the Kaspersky firewall temporarily to see if streaming works with it gone and that there are no other setup issues.

Once it works, you need to tell the firewall that the Apple TV is safe. I'm familiar with Zonealarm firewall and not Kaspersky, but the idea is the same in that you tell everything from the Apple TV's IP address is safe (or everything on those ports from that IP address is safe).

To do this, you need to find out the Apple TV's assigned IP address from your router. You might be able to do this on the Apple TV itself or there might be an application that can do this, but usually I log into the router and look at the list of connected devices. Sometimes you have to compare the MAC address (usually printed on a sticker on the bottom of the device) to the listed devices to make sure you have the right one.

With that IP address you can tell Kasperky it's safe. Here's how to create firewall rules for Kaspersky. Again, I'm not familiar with Kaspersky, but you either add the IP to "safe networks" or create a firewall rule that traffic from that IP is safe.
posted by sharkfu at 3:44 PM on October 10, 2010


It is most likely an issue with the firewall, but you may also want to check to be sure you have the Bonjour service installed
posted by Venadium at 3:58 PM on October 10, 2010


To be honest, just leave the firewall off if your internet connection is going through a NAT'd router and you have secure wireless. A PC firewall is only really necessary when you're going to be directly connected to the internet or you're on a network you don't have control over (like an open wireless network or a big corporate network). Just keep windows up to date.
posted by empath at 8:04 PM on October 10, 2010


« Older Looking for software which wil...   |  Can you recommend me a decent ... Newer »
This thread is closed to new comments.