Join 3,552 readers in helping fund MetaFilter (Hide)


Ambien for my computer?
September 12, 2010 8:21 AM   Subscribe

After a move, our computer (an older aOpen desktop) can't sleep through the night. It's fine if we leave it powered on, but if we put it to sleep, it seems to lose power sometime in the night and does not wake up properly in the morning. Will a cheap UPS (this one, for example) solve the problem? Any other ideas?
posted by Xalf to Computers & Internet (19 answers total)
 
Just make sure the UPS you get doesn't beep like a mofo when it's providing backup power or you'll be woken up every night. I made this mistake.
posted by thorny at 8:32 AM on September 12, 2010


If you're not using it (I assume so since it's hard to use a sleeping computer), why not just shut it down? I mean, this sounds a bit like one of them "I want to surf the net, but here's the catch, I want to surf the net on a banana." questions. I mean, what actually is the problem?
posted by Biru at 8:46 AM on September 12, 2010 [1 favorite]


The UPS would only help if there's some interruption in the mains power going to the PC. Since it will stay on through the night, it sounds like this isn't the problem so a UPS won't help.
posted by sanko at 8:52 AM on September 12, 2010


Is it actually losing power or just not waking up? The Windows "sleep" function is not at all infallible, and with some combinations of software/settings it just doesn't work right. (It's a stone bitch to diagnose and fix, too.)
posted by restless_nomad at 9:01 AM on September 12, 2010


Sorry, I should have included the following details to begin with.

Before we moved from Chicago things worked properly: we would put the computer to sleep in the evening and the light on the front would go from solid blue to flashing blue. In the morning we would click the mouse and it would wake up and things would be as they were the night before.

Now that we live in D.C., the light flashes blue as if it's asleep, but after clicking the mouse to wake it up, we get the Windows is having trouble booting screen asking whether we want to boot normally or in safe mode. We tell it to boot normally and it eventually starts up without returning to the programs left open the night before. (The length of time to boot is why we prefer sleep to shutdown. Switching to shutdown and waiting that time every morning may be easier and cheaper than buying an UPS.)

Because this never happened before we moved from Chicago to D.C. and because the computer can stay on all night, my guess is that it's losing power during the night in some way that affects sleep mode but not regular on mode. Now that I've articulated that more carefully, I suspect it makes no sense. But nothing has changed inside the computer that would affect the operation of the Windows sleep function. We're using Vista if that makes a difference.

Any further advice or questions are most welcome.
posted by Xalf at 9:22 AM on September 12, 2010


You should use "hibernate" rather than "sleep". It takes a bit longer, but it doesn't require that the computer be powered during the down time.
posted by Chocolate Pickle at 9:30 AM on September 12, 2010


Hibernate is not an option on the start menu on my setup. Can I access it from somewhere else?
posted by Xalf at 9:48 AM on September 12, 2010


To answer your question about accessing Hibernate somewhere else, folks will likely need to know the version of, I assume, Windows that you have.
posted by kalessin at 10:10 AM on September 12, 2010


This page over at Microsoft's Support site describes how to turn Hibernation on in XP:
http://support.microsoft.com/kb/920730

Hibernate is great.
posted by JHarris at 11:47 AM on September 12, 2010


Thanks JHarris. I guess I will switch to hibernate, but I wish I knew why sleep doesn't work.
posted by Xalf at 11:57 AM on September 12, 2010


In the control panel, access the "power options" applet.

The far right tab is labeled "Hibernate" and there's a checkbox to "enable hibernation". You have to be logged in as administrator to change this.

Once you check that box, it will allocate a section of your HD equal in size to your RAM. "Hibernate" will appear as a choice in the Start menu. When you choose it, the system writes out an image of your RAM to the HD and then shuts down. Unlike sleep, the computer doesn't require power when it isn't operating.

When you turn the computer back on again, it will reload your memory from the image on the HD.

Under the "Advanced" tab, you can choose whether you will have to enter your password when you resume.

Somewhere there's a place where you can control what happens when you hit the power button, but I don't remember where it is. It allows you to make it so that the power button will cause hibernation, so you don't have to bother with the start menu.
posted by Chocolate Pickle at 12:01 PM on September 12, 2010


The first four answers are good ones. It is doubtful that a UPS will make a difference. Probably has nothing to do with the power, but with something that changed in the computer. Different software for the internet connection, or a different kind of internet connection?
posted by gjc at 1:16 PM on September 12, 2010


gjc - The internet connection DID change. Before it was an ethernet cable coming out of a router connected to a cable modem. Now it's a wi-fi usb adapter picking up a wireless connection from a Clear Spot wi-fi hotspot. How would the internet connection affect the operation of sleep?
posted by Xalf at 2:19 PM on September 12, 2010


Did part of the Clear install process require installing software?
posted by kalessin at 3:11 PM on September 12, 2010


No new software. The Clear hotspot acts just like a wireless router and I didn't have to install anything new to connect to it with the wi-fi usb adapter. I've used the adapter in the past to connect to a wireless router, and I don't remember having similar problems.
posted by Xalf at 3:26 PM on September 12, 2010


System settings changes are almost always accompanied by either manual intervention, software installations or, somewhat more rarely, operating system updates.

Computers rarely just decide to change up some settings on their own.
posted by kalessin at 5:28 PM on September 12, 2010


"Sleep" never really worked well. I don't think it's anything specific that made this happen, it's just that you were lucky for a while, and then you weren't.

That's why "hibernate" is the right choice.
posted by Chocolate Pickle at 11:47 PM on September 12, 2010


perhaps you never left the usb wifi adapter in place when sleeping before? lots of USB devices don't "sleep" correctly and the driver might not reload when waking up. try unplugging the USB wifi adapter before putting the laptop to sleep. Not a really great solution, but might explain why the problem started.
posted by jrishel at 10:50 AM on September 13, 2010


I marked a few best answers, but jrishel has the bestest answer. Now that we have a DSL connection working and we're not using the usb wifi adapter, the computer has returned to sleeping like it did before. Thanks everyone!
posted by Xalf at 6:01 AM on September 18, 2010


« Older What sorts of incentives can w...   |  How can I "do the right t... Newer »
This thread is closed to new comments.