Skip

0 ST:0 IF:0 in virtualdub?
September 8, 2010 7:03 PM   Subscribe

After compressing a video with virtual dub, in the top left hand corner it displays information about the video like what frame its on. How do I get rid of it??

I just finished a video for school and vegas was being a duche about excepting Xvid codecs to render the video. So I just used the YUV codec or whatever to get the video out of vegas so I can re-render it in virtualdub where Xvid makes sense. Got the right size and everything but when I finished rendering, the video has information in the top left hand corner. Its hard to explain but it looks like this:

0 ST:0 IF:0

IVOP

The 0s get larger when the video starts playing. The first 0 has to be what frame the video is on but the rest I have no clue. I tried opening the file in VLC and media player, its still there, so its rendered into the video and not just layered on top.

I I have no clue how to describe this to google so I come to Metafilter for the answer.

Thanks! :D
posted by NotSoSiniSter to Computers & Internet (12 answers total)
 
When you preview the file in some other software (if it's YV12-in-AVI, WMP with an added YV12 decoder will work), do you still see the text?

Virtualdub is built around the Video for Windows (VFW framework), so it doesn't use Directshow or Media Foundation like Windows Media Player/ Center. If the text is not embedded in the video itself, and it's not the product of a Virtualdub option or some sort of Xvid debug setting, then whatever VFW object is decoding YV12 for you in Virtualdub is printing the info onto the decoded video.

These days, because VFW is old and deprecated, many people use xvid_encraw fed with Avisynth or do decoding and re-encoding in one step using ffmpeg or mencoder with libxvid or with Avidemux.
posted by Inspector.Gadget at 7:16 PM on September 8, 2010


@inspector.Gadget

Woah alot of that talk was over my head. I opened the file in Virtual Dub, VLC, and media player. all showed the same thing. Are you saying that it could be the Xvid codec thats overlaying the crap?
posted by NotSoSiniSter at 7:24 PM on September 8, 2010


So I solved the problem...I reinstalled Xvid and it went away. I hate it when that stuff works. I like knowing what is actually wrong...
posted by NotSoSiniSter at 7:29 PM on September 8, 2010


Ah. Since VLC uses its own internal codecs, and you still saw the problem - which was fixed by re-installing Xvid - my guess is that on the prior Xvid install you must have inadvertently enabled some sort of "print debug information" in Xvid's encoder settings. In other words, the evidence rules out Virtualdub and VFW or Directshow (or other) decoder problems.
posted by Inspector.Gadget at 7:45 PM on September 8, 2010


AHHHHH ITS BACK!!!! I accidentally messed with the aspect ratio in VLC and it came back...ugh. I then transferred the file to another computer and played it there...same shit! Wtf is this stupid thing?
posted by NotSoSiniSter at 7:48 PM on September 8, 2010


Huh. With this new evidence it sounds like it must be a problem with the encoder (or possibly you have some sort of debug function enabled in VDub or Vegas. Make sure to double-check all settings relevant to timecodes, frame numbers, OSD, etc.

Any idea what decoder Virtualdub is calling?
posted by Inspector.Gadget at 7:51 PM on September 8, 2010


this is so wierd. It magically disappeared again...it plays without the stupid shit. I tried messing with the aspect ratio, but it didn't come back. Why must it be so inconsistent?
posted by NotSoSiniSter at 7:56 PM on September 8, 2010


Can you post a sample to Mediafire and put the link here? I can test various decoders on my end and see what's up.
posted by Inspector.Gadget at 7:57 PM on September 8, 2010


Your awesome :D thanks for doing this

I took a small portion of the video in vegas and rendered it with the YUV codec. I then re rendered it with virtualdub with xvid at 6544kbs. Exactly how I did the whole video.

If your wondering what the video is, its my robotics team. We do a competition called FRC or First Robotics Competition. Is a lot of fun. :D

Sample file:
http://www.mediafire.com/?tj6naoro30vpg7f
posted by NotSoSiniSter at 9:07 PM on September 8, 2010


I don't see any time codes on that sample clip, so it's not being burned in to the video. Check the decoder property panel. For example if you're using ffdshow there are tons of debug options that you can enable, many of which cause debug information to be overlaid on the video frame. Note that you can have both the xvid decoder filter and the ffdshow decoder filter installed at the same time, and which one gets used is determined by the Dshow priority settings, so check the filter graph to see which one is being used.
posted by Rhomboid at 11:33 PM on September 8, 2010


Yeah, I don't see any text here either, and there's nothing besides one video stream and one audio stream muxed into that file. I don't understand why that would show up in VLC; does it still show up after you use the link installed in the start menu that allows you to reset VLC's preferences and cache? On the Directshow side, it sounds like you are also set up to print debug info somehow.
posted by Inspector.Gadget at 5:03 AM on September 9, 2010


I took the video to where I was presenting it and it played fine without the stupid overlay. Its really wierd. Idk for right now, since its not coming back, its the least of my worries. I will have to re-render it again bc i have to change some parts (ugh). If it comes back, my first stop is here :D
posted by NotSoSiniSter at 5:50 PM on September 9, 2010


« Older What are the best steakhouses ...   |  How do I deal with a close fri... Newer »
This thread is closed to new comments.


Post