Join 3,411 readers in helping fund MetaFilter (Hide)


In OS X, How do I disable the Cmd-F1 display mirroring keyboard shortcut?
September 3, 2010 10:39 AM   Subscribe

In Mac OS X, how can I disable the Cmd-F1 keyboard shortcut?

I use a Macbook Pro, with an external monitor hooked up, and set to extend my display.

I keep accidentally hitting Cmd-F1 when I mean to hit Cmd-1. Cmd-F1 toggles display mirroring. All my windows are then moved into one desktop. When I toggle display mirroring again, everything is mostly fine, except all the windows that were on the other monitor are now all in one, so I have to reorganize everything.

This isn't really that big of a deal, it doesn't take long to organize everything again, but I am really surprised that there isn't an easy way to disable this. Googling has failed me. It seems like every other shortcut is editable/disable-able, except for this one.

Here are few caveats:

1) Please, don't recommend anything related to Spaces. I've tried it, and I can't stand it.

2) This only seems to happen when I am using Fireworks (which is a job requirement.) I've tried remapping the Cmd-1 key, but it never seems to take. I would also consider this problem solved if you can tell me how to successfully remap keyboard shortcuts in fireworks.

3) Is it possible to disable display-mirroring system wide? I can only imagine using it give a presentation, and I don't think that's something I'll ever do.
posted by kpmcguire to Computers & Internet (8 answers total)
 
Turn off the F keys as as "shortcut keys" -- it makes it so you have to press the function key to turn up the volume and stuff, but that never really bothered me.
posted by Brent Parker at 10:50 AM on September 3, 2010


In your keyboard preferences, select "Use F1, F2, etc. as regular function keys." Now, you need to fat-finger Cmd-Fn-1 to mess up.
posted by mkb at 10:50 AM on September 3, 2010


Preferences -> Keyboard Shortcuts -> Application Shortcuts -> [ + ].

Application: [ All Applications ] (or Fireworks)
Menu Title: [ "Do Nothing" ]
Keyboard shortcut: (type command-f1)

I think this ought to work.

Thanks for asking this -- it made me get around to disabling command-escape to toggle Front Row which I never, ever, ever want.
posted by xueexueg at 10:50 AM on September 3, 2010 [1 favorite]


That setting would be under Apple | Preferences | Keyboard | Use F1, F2 etc. keys as standard function keys.
posted by Brent Parker at 10:51 AM on September 3, 2010


xueexueg - unfortunately, this doesn't work. When I get to the "keyboard shortcut" part and press cmd-f1, it toggles the mirror display again. I turned off function keys, did it again, and turned them back on, but it still didn't work.

Using "standard function keys" solves the problem, but I don't really want to have to hit fn to access the volume, etc. buttons. I guess I'll have to evaluate which is the lesser of two evils, here.
posted by kpmcguire at 12:19 PM on September 3, 2010


Rats. For the rearranging portion of the problem, there is also Stay ($15), which Daring Fireball mentioned the other day:
Stay ensures that your windows are always where you want them to be, even as you connect and disconnect displays.
posted by xueexueg at 1:23 PM on September 3, 2010


If you don't mind hitting fn to toggle mirror display, FunctionFlip lets you toggle the "use as standard function keys" setting individually for each of the fn keys.
posted by JiBB at 4:10 PM on September 3, 2010 [2 favorites]


FunctionFlip works. Yay!

However, before I installed it and checked it out, I changed the shortcut key for "zoom 100%" to cmd-0 in Fireworks (which is more like photoshop anyway,) and it seems to be sticking.

For now. I don't trust fireworks at all.
posted by kpmcguire at 3:53 PM on September 7, 2010


« Older Help me find a specific essay/...   |  Crisis situation: You're at a ... Newer »
This thread is closed to new comments.