Join 3,512 readers in helping fund MetaFilter (Hide)


How do I keep my speakers from muting when using headphones?
March 16, 2005 12:24 AM   Subscribe

How in the world can I keep Windows XP from automatically muting the speakers when headphones are plugged in?

This has been bugging me for quite some time but I can't seem to find a way to alter this. I did quite a bit of searching on it tonight to help out a friend; she wants to use a headet for her PC but it's too difficult to get to the back of the computer whenever she uses it, but she can't leave it plugged in without killing her sound.

There has to be some way to do this, right? I figured the must be some sort of registry hack to do it, but I've had no luck searching for one. I'm astonished that I've never come across an answer to this; surely a wiser mefite at least have wondered the same things and might be able to assist.
posted by Stunt to Computers & Internet (9 answers total)
 
I assume you've ruled this out, but you don't specify - many devices run speakers through the switch in the headphone socket, such that the speakers are disconnected or muted in hardware by the physical action of pluging in headphones. Is it possible that there are no settings to find because it's not controlled by the OS?
posted by -harlequin- at 12:32 AM on March 16, 2005


What two outputs are you plugging the main speakers and the headset into? In my experience with having both regular rear audio and front panel audio, connecting something to the front panel audio out disconnects the rear output at a very fundamental level - it's not Windows at all.

Look for something like this (just not so HIDEOUSLY overpriced.)
posted by TheOnlyCoolTim at 12:33 AM on March 16, 2005


Chances are this is not a function being performed by Windows XP, but by the hardware itself. It is the normal and customary behavior for headphone jacks on just about all consumer grade products, and is likely to be implemented by the sound card itself, not the drivers or the operating system.

In short: You don't fix this, you work around it. Try getting a set of speakers with a headphone jack -- Yamaha makes several good models of desktop speaker with this feature -- and plugging in as needed to that. Or get a stereo receiver of some kind, which usually allows you to choose which speakers are on at any given time, while leaving headphones plugged in.
posted by majick at 12:36 AM on March 16, 2005


One option that solves the problem, but involves buying stuff, is to buy a USB headset. This is kinda like a headset with it's own integrated soundcard, and you can switch between it and your normal soundcard at any time using the "Sounds and Audio Devices" menu in the control panel.

The only downside I've found is that if you launch a game (HL2 for example), then mid-game want to switch to the other device, you seem to have to close and re-launch the game for the change to take effect - while swapping to the other device takes effect immediately for most things, for something like a game that is doing it's own thing, it will keep using whatever you told it use when you started it.
posted by -harlequin- at 12:40 AM on March 16, 2005


Or you could just get a simple headphone adapter. Plug it into the speaker jack. Plug in the headphones and the speakers. Viola. Sometimes the simple solutions are the best.
posted by fixedgear at 2:35 AM on March 16, 2005


Just make sure you get a stereo -> dual stereo adapter. Dont want left going to phones and right to speakers, as has happened to me.
posted by sophist at 4:01 AM on March 16, 2005


This is a desktop machine, not a laptop? I am unaware of XP having a setting for this (but there could be), so I'd first suggest looking in the BIOS for any options that could be related to muting one output or the other.

Who makes the sound card? If it's onboard audio, who makes the motherboard?

If this is a laptop, it may be controlled by the hardware, in which case the workarounds suggested above are your only option. You could test it with a Knoppix bootable CD. If the problem still occurs with Knoppix running, your problem is the hardware.
posted by odinsdream at 7:54 AM on March 16, 2005


Soundblaster cards have an option called 'mute when headphones are present'.

If it's a Soundblaster card she has, just go to Control Panel>Audio HQ>Device Controls>Headphones and there should be a tick box there to deselect.

Without knowing more about the computer and the soundcard it's hard to tell you how to fix your problem.
posted by Navek Rednam at 8:14 AM on March 16, 2005


Thanks everyone, quite a few useful suggestions all around. I think that a few of those simple hardware solutions will work best a good deal of the time.

Especially thank you to Navek. That is *exactly* what I need for both my computer and hers. It's not so annoying for mine since I have front ports to easily unplug the headphones part of the headset (Audigy 2 ZS Platinum) but this way I can leave them plugged in and not have to worry about the odd lag as it switches things around every time; it will be a godsend for her computer though.

Thanks again everyone! I knew that other people would certainly pick up on what I was missing.
posted by Stunt at 3:01 PM on March 16, 2005


« Older Is there a macro program that ...   |  Phonetic Swedish: How do I pro... Newer »
This thread is closed to new comments.