Skip

Help! My internet connection sucks!
August 18, 2010 8:25 PM   Subscribe

My internet connection has slowed to a crawl. Please help!

Let me get the basics out of the way:

- I am running Snow Leopard on a Mac Pro, using a Airport Extreme wireless router

- Even when I directly connect the Mac to the cable modem, the connection is still slow

About a week my internet connection slowed to the point I can't watch video, it only loads fast enough to read text...sometimes it refuses to do that.

Coincidently when this started happening I updated OpenDNS to 3.0 for Mac, and the updater has been warning me that I have a "DNS IP address and HTTP IP address mismatch", and that it's possible my connection is being sent through a proxy, but I never set up a proxy....

Can anyone shed any light on this? Is this mismatch possibly the problem? And how do I fix it?

Any help would be appreciated!

FYI I spoke with my cable provider tech support, and they are at a loss as well, and plan on sending someone over to check if the modem is broken.
posted by helios410 to Technology (24 answers total) 3 users marked this as a favorite
 
Check your neighbor's wifi signals if you manage to catch any. If theirs is down as well or is as slow as yours, likely it's the ISP's fault. Make sure to mention that to them if that holds to be true.
posted by antgly at 8:28 PM on August 18, 2010


Have you checked to see what speed you are getting. Check speedtest.net and let us know what it's saying.
posted by TheBones at 8:29 PM on August 18, 2010


Do you encrypt your WiFi?
posted by yoyo_nyc at 8:30 PM on August 18, 2010


Reboot cable modem, router and laptop in that order.
posted by k8t at 8:33 PM on August 18, 2010


Try uninstalling OpenDNS.
posted by 6550 at 8:41 PM on August 18, 2010


- Speedtest is giving a DL speed of .58 Mb/s and UL speed of .49 Mb/s

- Yes, I do encrypt my WiFi.

- I have reboot and reset my cable modem and router many of times.

- In regards to OpenDNS, I did solve the mismatched IPs, but I still have a slow speed. Additionally I set up OpenDNS to work specifically on the router. This makes sense, because as I said, when directly connected to the cable modem itself I still experience slow speeds. So that knocks OpenDNS off the list of problem sources...
posted by helios410 at 9:26 PM on August 18, 2010


Have you called your ISP?

When I first got AT&T U-Verse I had a similar problem. It took 4 service visits but they finally found the problem in the box down the street.
posted by chris p at 9:32 PM on August 18, 2010


There are many possible reasons as to why your connection is slow.
- as 6550, un install OpenDNS. make sure you change the DNS settings to use
your service provider's DNS addresses. You should change thin in your moden and laptop.
Sometimes, a particular DNS server's response may be very slow, and thus slow down
your overall experience.

Does this happen all the time?
if you find that this happens at certain hours, it could point to peak traffic in
your area, i.e. this would point fingers to your ISP.

A good suggestion is to measure your donwload speeds at different times of day,
(see link above to speedtest or similar) and then do it a couple of days. This could
help you understand if it is indeed related to time of day.

Does it happen with all websites?
When you are trying to watch a video, open another tab and browse some
website you know is not popular at all, and has very little graphics. Again,
this test would aim to find if this is related to particular websites...

If you are more techie oriented, open a terminal, and ping your default gateway,
and your dns adresses, again at different times of days.
the response time, measures in "ms" (miliseconds) could give you clues
as to whether the slowness is inside the ISP network or outside....

good luck. have patience, t-shooting this requires it, and make sure you do it
in a logical way, so that you may start discarding variables.
posted by theKik at 9:34 PM on August 18, 2010


Thanks for the suggestions so far everyone.

- Uninstalling OpenDNS, well...it's just manually entering OpenDNS's DNS server address on the Airport router. once I delete those, they automatically change to my ISP's DNS servers.

- Yes, this problem is at all times of day/night, and happens to all websites.
posted by helios410 at 9:42 PM on August 18, 2010


.6 down is pretty slow, I am guessing that is most likely the cause.
posted by TheBones at 10:20 PM on August 18, 2010


You might try running namebench, a DNS benchmark utility to see what kind of results you get from other servers. This is a free, open source utility that is very easy to use. You simply download , install and launch the program and let it run to check your speed on several public nameservers. My test returned results in about 20 minutes; it could take you more or less time. In the resulting report page (pops up automatically following completion of tests), you will be given the IPs of a primary, secondary and tertiary servers that will provide you with your best (fastest) results. You can also run tests based on server health. Once you have the IPs, you can then plug them into your DNS settings in Network preferences. Then, recheck your connection speed. It made a world of difference for me. Good luck, I know this is a PIA.

Instructions and info are on the download page. If you want more info, there is a link to FAQs on the right side of the page.
posted by konig at 10:21 PM on August 18, 2010 [1 favorite]


One possibility is that your computer has been taken over, and the reason you're not getting very good throughput is that a lot of your bandwidth is being consumed by a hidden zombie in your machine.

When you're sitting idle, doing nothing, do the activity lights on your computer and router how significant activity?
posted by Chocolate Pickle at 10:44 PM on August 18, 2010


Try running the UC Berkeley Netalyzer java/web app. It's designed to diagnose last-mile network issues. Unlike the generic speedtest pages, it will check DNS weirdness, packet fragmentation weirdness, proxy weirdness, and all sorts of other weirdness and give you a link you can send to your ISP.
posted by zengargoyle at 1:43 AM on August 19, 2010


Yeah, I you can, borrow a friend's notebook. Then you can isolate whether the problem is your machine or modem/ISP. Your ISP will probably blame your machine until you have concrete proof otherwise.
posted by sockpup at 2:03 AM on August 19, 2010


Any other computers on the network? Running torrents, maybe?
posted by beerbajay at 2:46 AM on August 19, 2010


Does yr isp have a bandwidth limit?
posted by hal_c_on at 2:50 AM on August 19, 2010


Who is your ISP? I only ask because, I am on Comcast, but use OpenDNS. Until recently, this has worked just fine. I now seem to get a whole lot of "Waiting for..." in FF's status bar, with slow loading of sites. There are times where everything becomes so unresponsive that I actually have to reboot the Mac.
posted by Thorzdad at 5:36 AM on August 19, 2010


I'm a little confused by these statements:

Coincidently when this started happening I updated OpenDNS to 3.0 for Mac, and the updater has been warning me that I have a "DNS IP address and HTTP IP address mismatch"

- Uninstalling OpenDNS, well...it's just manually entering OpenDNS's DNS server address on the Airport router. once I delete those, they automatically change to my ISP's DNS servers.

Did you install any OpenDNS software on your Mac Pro or are you just using the OpenDNS server address(es) on your router? Did the problem start before updating to OpenDNS 3.0 for Mac or only start after? Do you have another computer you can test, both wirelessly through your router and plugged directly into the modem? Preferably one without any OpenDNS software.

I don't want to keep hammering at OpenDNS but it's unclear to me what, if anything, you installed or updated and if it's related to when the problem started.
posted by 6550 at 6:08 AM on August 19, 2010


Try using 4.2.2.2 and 4.2.2.1 as the DNS server addresses in TCP/IP settings on your Mac (make sure you make that change in whatever interface you're using to connect), not on the router. Quit and relaunch your browser. See if that helps.

I have dealt with this exact issue frequently on many Mac OS versions and various router combinations. Sometimes OSX just doesn't get the right DNS information from the router or somehow bungles it.
posted by MonsieurBon at 10:14 AM on August 19, 2010


Does this occur when you use a different web browser, like Firefox?

How about doing a traceroute? Open up Terminal (Applications -> Utilities -> Terminal) and run a few traceroutes.

http://www.exit109.com/~jeremy/news/providers/traceroute.html

Might be nice to see where things are hanging up.
Other steps:
* If you have a friend with a laptop or something, have them give it a shot.
* Change out the ethernet cable that you're using. (Taking the Airport Extreme out of the mix was a smart idea for troubleshooting too!)
* Try Google Public DNS too - http://code.google.com/speed/public-dns/

I use OPenDNS at several locations and have never had a problem, but it's always a possibility.
posted by drstein at 1:30 PM on August 19, 2010 [1 favorite]


From beerbajay: Any other computers on the network? Running torrents, maybe?

From drstein: How about doing a traceroute? Open up Terminal (Applications -> Utilities -> Terminal) and run a few traceroutes.

I'd definitely investigate these two routes. Heavy traffic could be a culprit from your neighbors as cable isn't a direct run to your modem like DSL would be, but rather the pipeline is shared by other subscribers...usually around a block.

Traceroutes should give you an idea, like drstein said, on where the issue could be happening. If you see low latency on the first few hops outside your modem, then its likely not an issue with neighbors bogarting the stream, but rather an issue with the cable company itself.

I doubt the issue is DNS related, as that would only cause name resolution to slow down, not thoroughput. You can test this by connecting or pinging the website's IP address instead of its name. If you have any other internet capable devices, definitely try those on your modem as well...just to rule out the Mac (doubt its a problem with your PC however). I'd honestly wait for a cable tech to arrive however, as it's likely the modem or the local cable bus.
posted by samsara at 8:10 PM on August 19, 2010


No torrents are running - I have turned all bit torrent clients off since this started.

Thanks for the traceroute suggestion, but where do I run the traceroute to to find out of I have a problem?
posted by helios410 at 6:21 PM on August 24, 2010


Also, using Google's DNS now - still no difference in performance.
posted by helios410 at 6:22 PM on August 24, 2010


You'd run traceroute to several different hosts. Here's a few ISPs in California that are always reachable:

www.cwo.com
www.calweb.com

Both up in Sacramento, CA.

Try things like VisualRoute as well. Run traceroutes to university web servers like mit.edu, vt.edu, cmu.edu, etc.
posted by drstein at 9:39 AM on September 9, 2010


« Older Mathematical sequences challen...   |  How much weight can a Pterodac... Newer »
This thread is closed to new comments.


Post