Join 3,572 readers in helping fund MetaFilter (Hide)


Nokia 5800 will surf, but none of the other apps will connect.
August 4, 2010 10:16 AM   Subscribe

My Nokia 5800 will surf the internet, but none of the other apps will connect.

The first thing I tried was to update the software version, but I get connection error with that.

I had an iphone contract on 02 UK and switched to using this phone...they sent a configuration message with new settings, and that's when the browser started working.

The native maps, google maps, email etc don't work though.

What's going on?
posted by Not Supplied to Technology (8 answers total)
 
Did you try to update firmware OTA (over the air) or with Ovi Software Updater on your desktop? I just did a firmware update for my N97 Mini (a lot newer than the 5800 but also a S60v5 touch device) and couldn't get the update OTA; I did manage with the desktop updater.

When you start Ovi Maps or the email client, is it asking you for permission to access the network and then asking which source to use (Wi-Fi, HSPA, etc)? If it's not, try going into "settings" for each app and selecting connection prefs there.

Also, you should try configuring connection settings globally by going into settings-connectivity-destinations where you should be able to find and decide on settings prefs (eg to prioritize wi-fi over HSPA, etc).

As well-you can find lots of assistance at the Nokia (Europe) user forums.
posted by ethnomethodologist at 10:59 AM on August 4, 2010


Some apps don't bring up the network selection dialogue and just try to use the primary connection.

So, as ethnomethodologist says, you need to set your connection that works for the browser to be the default connection.
posted by Gomez_in_the_South at 12:18 PM on August 4, 2010


Thanks both of you. The browser connects by 'O2 Postpay WAP' but this connection is not available in 'Destinations'

Also, if it's WAP is that a 3g connection?

Thanks.
posted by Not Supplied at 12:27 PM on August 4, 2010


Yes, WAP should include your 3G connection.

If I remember correctly from when I set this for my Ovi maps, it was under Destinations -> Internet where you need to switch the priorities. Can you not see the 'O2 Postpay WAP' connection here?

Once you've found them, it can be a bit fiddly getting the priorities changed, but it can be done by going to Options -> Organise -> Change Priority and then with some strategic finger presses.

You also need to allow some apps to connect if you've denied them access previously. In Ovi Maps for instance, this is at Tools -> Go Online.
posted by Gomez_in_the_South at 12:50 PM on August 4, 2010


Nah, there's no connection of that name only 'contract internet', and Ovi maps says 'no internet connection' when I select either 'Internet' or 'WAP services'.

I will update the software version and try, but I have a feeling it's something else.
posted by Not Supplied at 1:07 PM on August 4, 2010


Check the details of your plan; I'm thinking 'O2 Postpay WAP' is not your average no ports barred data plan. It seems it's mostly a walled garden approach, whereas your WWW, IMAP and IRC/ICQ/MSN/Jabber/AOL stuff is probably not 'supported'.
posted by pwnguin at 1:49 PM on August 4, 2010


I'll have to have a word with them. I have an iphone contract and used all kinds of apps, and they said it would be exactly the same. Pigdogs.
posted by Not Supplied at 1:53 PM on August 4, 2010


Does everything work right on WiFi? If so, you should be able to manually define an access point that will work.

Create a new one and put the settings from this post into the relevant fields and it should work.

I'd give you a specific sequence of buttons, but I'm not sure where it all is in S60v5.
posted by wierdo at 3:28 PM on August 4, 2010


« Older Help my partner and I give eac...   |  Are there any Cosmetology scho... Newer »
This thread is closed to new comments.