Skip

Please help me install a program with python and csound.
July 21, 2010 2:32 AM   Subscribe

Please help me install this music sequencer on windows XP. It requires python, so I've installed 2.5 as it may have issues with later versions. It also requires the 'csound python api' which I can't find on the net or in my installation of csound. I'm really keen on this app.

The requirements just say "requires Python 2.5 and the Csound Python API (installed as csnd.py). "

I've downloaded csound 5, reasoning that as this hasn't been developed for a while an older version will be best. I can't find anything about an API or csnd.py though.

The link to the sourceforge page for rationale here.

I would love to get this working as it's unique. I'll be around on the net for a while to try stuff out. Any help appreciated.
posted by Not Supplied to Computers & Internet (3 answers total) 1 user marked this as a favorite
 
You need the csnd python module, which is not installed by default. You need to run the csoudn installer again and select it in the "Choose components" screen, under "Csound interfaces".
posted by themel at 2:58 AM on July 21, 2010


Thanks, but there was no 'choose components' screen in the 5.08 installer. I'm going to try the new version and see if that works.
posted by Not Supplied at 4:06 AM on July 21, 2010


Oh right. It seems to be working with Csound 5.11 and Python 2.6, so perhaps the warnings on the web are not universal.

Thanks!
posted by Not Supplied at 4:34 AM on July 21, 2010


« Older My girlfriend and I are taking...   |  Would you share videos of any ... Newer »
This thread is closed to new comments.


Post