Join 3,557 readers in helping fund MetaFilter (Hide)


character hijack on keyboard
June 29, 2010 9:04 AM   Subscribe

Every once in a while my keyboard is only able to type weird symbols like this. Does anyone know what is hijacking my computer?

I imagine I am accidentally pressing some combination of keys which brings up this "feature" in which I can potentially type Asian characters (and other scripty things), but I have no idea what it is. I have experienced the problem in a text editor (see sample image) as well as in Firefox. The only solution I've found is to exit the program. Computer specs: Windows 7, ASUS UL20A.
posted by pjenks to Computers & Internet (5 answers total)
 
This looks to me like an IME (Input Method Editor) for Japanese. I believe that if you have it installed, the default key combination is something like ctrl-esc or ctrl-backspace or ctrl-insert, I can never remember (I reconfigure it, myself).

If you look at the bottom right, on your task bar, you should have a small icon that, when this happens, will likely read "JP". Just click on that and select english instead of Japanese and you should be back to normal.

You could also go to the control panel (start -> settings -> control panel), click on "change keyboard or other input method" under the "Clock, Language and Region" heading, click on "Change keyboards", and remove the entry for Japanese.
posted by splice at 9:08 AM on June 29, 2010


Probably crtl-space and you're hitting the space key while reaching for the shift key for the next letter and missing and hitting ctrl instead. But yeah, IME. Hit esc to cancel out what you've typed, then hit ctrl-space again to turn it off.
posted by zengargoyle at 9:12 AM on June 29, 2010


Toggle keys for Windows IME may help you.
posted by filthy light thief at 9:23 AM on June 29, 2010


Thanks everybody. Looking at my "Languages" preferences it seems that I had a chinese keyboard option enabled (who knows why). I must have been toggling into that by an erroneous keystroke. Hopefully removing that keyboard option has fixed the problem.
posted by pjenks at 9:45 AM on June 29, 2010


FWIW, that's zhuyin/bopomofo.
posted by wongcorgi at 1:22 PM on June 29, 2010


« Older Where can we find or who makes...   |  When do you find is a good age... Newer »
This thread is closed to new comments.