Join 3,501 readers in helping fund MetaFilter (Hide)


OS 4.0 = junk?
June 21, 2010 1:59 PM   Subscribe

New apple iPhone OS doesn't sync with Google Calendar any more?

So I updated the OS on my iPhone to 4.0.

Now my Google Calendar doesn't sync with the iPhone's calendar app. It used to sync fine.

Any ideas out there?

Gmail and my phone sync, though, so I'm not sure why the calendar doesn't.
posted by dfriedman to Computers & Internet (12 answers total) 2 users marked this as a favorite
 
(I have the iPhone 3GS if it matters.)
posted by dfriedman at 1:59 PM on June 21, 2010


The OS only came out a couple of hours ago. Give it a few hours to see if Google and Apple are on the same page with this.
posted by proj at 2:02 PM on June 21, 2010


Fair point. I was thinking that perhaps there was some announcement saying that Google calendar would no longer sync or something like that but I get the point that the OS is pretty much new to the world.
posted by dfriedman at 2:07 PM on June 21, 2010


I can't look at the old OS to be sure, so I might be wrong, but I noticed with iPhone OS 4, that the Google account I set up had switches (on/off) for separate services - Mail, Calendars, Notes. Just like the MobileMe account and Exchange account I have do.

Before, I had to set up my Google Calendar separately from Google Mail specifically as a WebDav account for just getting to my Google-hosted calendars.

Perhaps you did the same? Look in your "Mail, Contacts, Calendars" settings, see if such switches are available under the entry for your Gmail account and how they're set.

See if you still have a separate account for your Google Calendar (if you ever did, again, I don't trust my memory 100%... but I feel like I saw something similar to what you might be reporting, only I also saw another option that seemed to replace what I used to have).

I am on an iPhone 3G with iOS 4, so I don't have all the features you have - but I don't think that affects this particular area we're talking about.
posted by mjb at 2:07 PM on June 21, 2010


I haven't had a chance to install iOS4 yet on my 3GS so I'm not familiar with the updated menu system, but did you have manual, push or fetch selected?

Skimmed google, haven't seen any similar reports. Perhaps delete the Microsoft Exchange profile and recreate it?
posted by liquoredonlife at 2:18 PM on June 21, 2010


I had exactly this problem after updating earlier today. My solution:

1. Delete calendar account from phone;
2. Re-add account.
3. Power cycle phone.

(This may not be optimal, but it worked for me.)
posted by buxtonbluecat at 2:28 PM on June 21, 2010 [1 favorite]


I had this problem too, for my work mail (Google Apps Premier), they instruct you to set it up as an Exchange account. This appears to work (even the "Cannot verify" certificate warning shows as it should), but I'm not getting any mail ... even with power cycling, adding deleting, etc.

Instead, I set it up as a Gmail account instead of Exchange and it works fine. I think before, there was some issue when setting up as Gmail and it expecting a Gmail.com domain name, which is why you had to use the Exchange settings, but I could be wrong.
posted by geoff. at 2:46 PM on June 21, 2010


The OS only came out a couple of hours ago. Give it a few hours to see if Google and Apple are on the same page with this.

The OS update was available to developers several months ago just so kinks like this can get worked out by developers prior to launch.
posted by bitdamaged at 2:48 PM on June 21, 2010


Yes, but that's not to say that the rare kinks DON'T get worked out. The deleting and readding trick above suggests something changed slightly in how the APIs interact in the final version, at least for some users.
posted by proj at 3:49 PM on June 21, 2010


Deleting and readding the account seems to be the trick.

Thanks.
posted by dfriedman at 4:00 PM on June 21, 2010


I didn't have to delete the whole account, personally. I just turned went into the google account setting and flicked the calendar option off and back on. After that it resynched just fine.

Just thought I'd mention that to save anyone else the aggravation of having to retype all those server settings in again.
posted by Aznable at 4:21 PM on June 21, 2010


Google's sync servers have been terribly slow today- slow to the point where it seems nothing gets sync'd up at all. My contacts are coming in 25 at a time, every couple of minutes or so.

http://www.google.com/support/forum/p/gmail/thread?tid=0aea7857b25a174f&hl=en
posted by liquoredonlife at 9:33 PM on June 21, 2010 [1 favorite]


« Older "Silicon based life"...   |  Should I pay out-of-pocket to ... Newer »
This thread is closed to new comments.