Join 3,421 readers in helping fund MetaFilter (Hide)


Help me get Netflix Instant Streaming Working in Internet Explorer
June 20, 2010 12:41 AM   Subscribe

Netflix Instant Streaming and Internet Explorer not working. Long post inside.

The Netflix Movie Viewer requires ActiveX to be enabled. Please verify in your Internet Explorer security settings that ActiveX is enabled, then reload this page to try again.

You may need to disable firewall or anti-virus software to enable ActiveX.



Is the error I receive whenever I try to stream movies with Netflix in Internet Explorer 8.

Heres what I've done to troubleshoot:

Netflix streaming works fine in Firefox.
I have uninstalled and reinstalled Silverlight, first uninstalling it through control panel, then after a reinstall of right clickling 'Sliverlight.exe' and choosing 'Run as Admin', still same error, also then ran Revo Uninstaller to completely remove Silverlight, and reinstalled same as above, still no fix.

If I disable 'Silverlight Addon' in Internet Explorer I'm prompted to enable it on the netflix site, but then I receive the above error.
I've added netflix to 'trusted sites' and also set the internet zone to 'medium' and enabled all activex settings just for troubleshooting, still nothing.

Netflix support has punted to Silverlight support. I've also went to the advanced tab and 'Reset' all Internet Explorer settings to default and still no resolution.

I've went to sites like
http://www.vdat.com/techsupport/PRNwindowstest.asp
And
http://www.bubblemark.com/

In internet explorer and they work fine, it is only Netflix Movie Viewer seems to have the issue.

Thoughts?
posted by dolemite01 to Technology (11 answers total) 1 user marked this as a favorite
 
I turned on 'prompting' for all activex controls in Internet Explorer, I am prompted to allow ActiveX controls to run when trying to stream a movie, yet still receive the same error.
posted by dolemite01 at 12:47 AM on June 20, 2010


With your IE security settings at the default levels try adding netflix.com to your trusted sites.
posted by cp7 at 6:15 AM on June 20, 2010


Yeah, I tried that with no resolve
"I've added netflix to 'trusted sites' and also set the internet zone to 'medium' and enabled all activex settings just for troubleshooting, still nothing"
posted by dolemite01 at 7:36 AM on June 20, 2010


I'm sorry if this is missing the point, but why is it preferable to stream through IE when it works fine in Firefox?
posted by solipsophistocracy at 7:39 AM on June 20, 2010


Are you behind a firewall or filter of any kind? I'm just thinking that it could be blocking something there.
posted by msbutah at 7:50 AM on June 20, 2010


Not behind a firewall or filter, also looking to stream through IE because that's what windows media center uses as back end and would like to use the WMC interface for streaming once I get IE working.
posted by dolemite01 at 8:02 AM on June 20, 2010


Have you tried going into WMC and trying to view Netflix VOD in there? I haven't tried setting it up for Netflix yet, but most of the WMC stuff is pretty plug-and-play. When I setup my xbox to use it it was just a couple of clicks.
posted by fiercekitten at 11:37 AM on June 20, 2010


Yes I have, I get the same error as in IE.
posted by dolemite01 at 2:22 PM on June 20, 2010


Are you on a 64bit OS? I tried using the 64bit IE8 that comes with Windows 7 and have had numerous problems with plugins (flash, etc). If you're using the 64bit IE8 try the non-64bit.
posted by msbutah at 2:33 PM on June 20, 2010


Have you tried reinstalling IE? Standard Microsoft fix!
posted by KathrynT at 3:09 PM on June 20, 2010


I am using 32-Bit for giggles I tried the 64-Bit, it actually tried to install silverlight, but then of course said it can't in a 64-Bit browser.
posted by dolemite01 at 3:32 PM on June 20, 2010


« Older Yet another Itunes Library que...   |  How to react to possible, but ... Newer »
This thread is closed to new comments.