Skip

WiFi Poltergeist
May 28, 2010 5:16 PM   Subscribe

My laptop can only connect to my girlfriend's wireless with Ubuntu, not Windows and it's driving me crazy. Tech problem or ghosts?

As near as I can figure, my girlfriends house is haunted by a Linux geek. I say this because no matter what I've tried I cannot connect to her wireless router with XP on my dear old Dell D400 with an intel 2200 wifi card. Some things I've tried have led me into a log in to device (the router I presume) screen asking for a device specific password. When I drop back to the Window's interface I just get unable to connect.

This is really irritating. I can log in fine with Ubuntu using the exact same wep key copied and pasted from the same text file. I've tried making profiles in both the intel interface and the native windows interface. Same results.

This is the only location where this happens, thus the posing of the possibility of a spiritual nature. Her daughter has been able to get into the network fine with Vista (a real sour point for me) ever since I switched the security to wep 128.

So I hear there are people to ask here who know things. Should I be looking for some herb like sage or something to burn around my laptop of the Linsys router? Is their some incantation with some odd number of candles that will cast this spirit out of her house while I am here? Or do I risk only angering him to the point where he shuts down my linux connection?
posted by quietfire to Computers & Internet (12 answers total)
 
The same laptop, just booted into Ubuntu instead of Windows, or a different machine?
posted by TeatimeGrommit at 5:23 PM on May 28, 2010


Dual boot Dell D400.
posted by quietfire at 5:25 PM on May 28, 2010


My guess is that XP is trying the wrong encryption protocol. It's an older OS, maybe it's not as smart at figuring out how to encode the password and so on. There are a lot of options to play with and something might be set wrong.

If you are able to log in to the router -- try turning off the password (opening it up) so that anyone can jump on. If you're able to connect, it means the encryption was the problem. If it still doesn't work, there's something weird going on with Windows.
posted by PercussivePaul at 5:31 PM on May 28, 2010


I've had to install this manually for XP in the past. Without it, XP just doesn't know about the current generation of wireless key algorithms. And by current, I mean anything out in 2005 when this patch was released.
posted by TeatimeGrommit at 5:41 PM on May 28, 2010


nthing making sure that the XP is fully patched, as well as having the latest drivers for the wifi card.

I was beating my head about the same issue just earlier this week (except with a Lenovo laptop) and the newest wireless driver said "make sure you have the latest service pack for Windows, then install this driver". Worked like a charm!
posted by cathoo at 6:50 PM on May 28, 2010


I think drivers are probably to blame, but if you want to try something else first... try converting the password into Hex and using that for windows. it might not be smart enough to do the conversion itself.
posted by jrishel at 7:03 PM on May 28, 2010


an ex-gf of mine had a laptop with an Intel 2200 wireless chipset and one day it started BSOD'ing unexpectedly. But only when she came to my apartment. Where it had worked flawlessly previously.

Come to find out after some serious Google searching... her specific wireless card was not compatible with 802.11n wireless routers. "Not compatible" = if it sensed an N router anywhere nearby, it would BSOD and crash the laptop. It was a bug in the wireless card drivers.

I removed the wireless card.. and used a wireless PC-Card instead... everything worked perfectly.

Moral to the story:.. maybe there is something funky with the XP drivers and your router?.... Tried upgrading the firmware on the router ?
posted by jmnugent at 7:21 PM on May 28, 2010


Best not to use WEP unless you have legacy devices that can't handle WPA. Any kid with a linux box can hack WEP within a few minutes. Nth updating Windows, drivers, and firmware.
posted by sockpup at 7:55 PM on May 28, 2010


Of course
Check to make sure the wireless card is enabled in device manager in Windows.
Dumber things have happened.
posted by will wait 4 tanjents at 8:58 PM on May 28, 2010


Update your network card driver. The linux kernel includes many hardware drivers and Ubuntu identifies and downloads those that are not in the kernel. XP drivers must be manually updated.
posted by ferdinand.bardamu at 12:03 AM on May 29, 2010


Try changing the password to one exactly 13 characters long. I couldn't tell you why this works, but when I set up my last network this was suggested for maximum cross platform compatibility.
posted by clockwork at 7:11 AM on May 29, 2010


There is an option in the Windows Control Panel, Administrative Tools, Services, Wireless Zero configuration that has to be started for XP to pick up Wireless connectivity. This is after you've updated the drivers.
posted by ptm at 6:56 AM on May 30, 2010


« Older I work for a small (<40 peo...   |  Back to school filter: Looking... Newer »
This thread is closed to new comments.


Post