Join 3,562 readers in helping fund MetaFilter (Hide)


How to listen to music from PC to home theater while utilizing sub woofer?
April 13, 2010 6:45 PM   Subscribe

How can I listen to music from my PC on a home theater while utilizing my sub woofer? I have my PC in a different room, hooked up with an optical cable to my home theater receiver. When I play music from iTunes on my PC, the sound only comes out of my main floor speakers and not my sub woofer. Is this possible with regular music tracks?

The sub woofer will come on for movies played off of my Xbox. The receiver is an ONKYO TX-SR607 7.2 Receiver, and my sound card on my PC is an Intel Motherboard DG33TL with 7.1 Audio, S/PDIF Optical.

I have tried all of the different settings on the receiver for audio modes(DTS,Dolby,Stereo,Mono,Surround Sensing, etc). I have tried streaming the audio from my xbox using windows media center.
posted by dpollitt to Technology (11 answers total) 1 user marked this as a favorite
 
When I play music from a plain old audio source pumped into my cheap sony receiver, it uses the subwoofer if I stick it in the right mode..... all I can say is there must be some combination of the format you are streaming and the receiver that will accomplish it.
posted by TravellingDen at 6:50 PM on April 13, 2010


It was under my impression (and in my instance, the case with my audio set-up) that the only way to get 5.1 or 7.1 (i.e. surrounds, subs) to work is if the audio source is coded in 5.1 or 7.1 Since you're listening from your computer (re: iTunes), that won't be anything more than your fronts or floor speakers. Hopefully this is helpful.

Dan
posted by dtpollitt at 7:30 PM on April 13, 2010


Have you tried audio settings on the pc? On mine you have to tell it you want 5 channels output through the little audio manager doohickie. (your doohickie may vary)

Also mp3s/music aren't surround sound by design if I remember, but in 2ch. Winamp for can output to 5.1 with the correct plugin though.
posted by Big_B at 7:50 PM on April 13, 2010


I think the solution to your problem might be on page 70 of the English manual on this page. For music, see if setting the Front speakers crossover frequency to 120 Hz does something (most pop music doesn't have anything below 40 Hz), or try enabling "double bass", which would output the LF from both your front speakers and your sub.
posted by Monday, stony Monday at 8:00 PM on April 13, 2010


I expect the problem is that when you play an itunes song, the sound card is sending a discrete 2.0 signal through the optical, so the receiver is sending that 2.0 signal to the speakers.

There might be a setting to tell the receiver to send sound below some frequency, on any channel, to the sub.
posted by ROU_Xenophobe at 8:01 PM on April 13, 2010 [1 favorite]


This is fairly common with HT receivers.
In the case of my Pioneer Elite receiver, the subwoofer output is dependent upon the Xover settings when listening to 2 channel music.
Basically, if the Xover is set high enough, like 80hz or higher, then the subwoofer receives signal from the receiver. If the Xover is set to 50hz or lower (or off) the receiver does not send signal to the subwoofer.
It's possible that instead of Xover options your receiver has speaker size options; small, large, etc. Large speakers are generally capable of reproducing the full range of frequencies, including the range that a subwoofer would reproduce. Small speakers typically can't reproduce frequencies below 80hz, necessitating the need for a subwoofer.

If you have large speakers, and want your subwoofer to play right along with them, you could try hooking it up differently to your receiver:

Option 1) if the sub has speaker wire inputs, you could run wire from the "B" output on the receiver and use the sub's Xover to cutoff frequencies above a certain point. Somewhere between 50 and 80hz is ideal.
Option 2) if your amp has an RCA audio out for the front channels, use a 2 channel audio cable to send signal to your sub. You will need to use the sub's Xover in this configuration as well.
posted by nickthetourist at 8:09 PM on April 13, 2010


One option would be to upmix the stereo sound to 5.1 on your pc and send via optical to the amp. Your motherboard supports Dolby Home Theatre, which also includes Dolby Digital Live - so your soundcard should be able to upmix the sound to Dolby 5.1 before it puts it through the optical output. (It won't be absolute perfect fidelity, but since you're listening to itunes you shouldn't notice it)

If the option is not available under your sound control panel (it's under the SPDIF speaker properties on vista and 7) to enable Dolby Digital Live, you might need to install the Dolby control panel, which should have the option in there if I remember correctly.
posted by ArkhanJG at 11:25 PM on April 13, 2010


Ok, your fundamental problem is this: your S/PDIF optical cable can carry only two channels, left and right. There are chipsets on the PC that will compress multichannel sound down to Dolby Digital or DTS, letting you get up to 7.1 channel sound on a digital connection, but they usually don't sound very good. And most soundcards/chipsets will just send the L+R signal and drop everything else.

So, you most likely have one of two problems. Your computer is sending a L+R signal, but you're not getting bass. Two scenarios that would cause that:

1) The computer is sending the full normal left and right signals, but the Onkyo is set to 'large' speaker mode. Expecting the front speakers to handle everything, it sends no bass to the subwoofer, and you don't hear it. To fix this, verify in the Onkyo setup menus that the front speakers are set to 'small'. If that's the problem, you should immediately get bass.

2) Alternately, the computer may be doing an internal crossover and not actually sending the bass signal. This will mean you'll have to fiddle around in your control panel. You don't say what operating system you're using. If you're in Win7, go into the Sound control panel, and set your speakers to stereo, LARGE mode. It has to be large mode, so that all the bass is sent to the receiver over the S/PDIF... the Onkyo needs to do your crossover, not the computer.

You may also have to explore the sound control panel for whatever chipset you're running... most will have a custom audio tray icon with special settings. My Realtek driver, for instance, has checkboxes for 'full range speakers', and I have all the options unchecked, so it does my crossover. You DON'T want that, you want to tell it you have large speakers. My X-Fi under XP called it 'bass management mode', I believe, and you'd want to turn that off. You need to defeat any attempt at intelligence by the computer... you need to set it into the simplest possible mode so it just sends the L+R channels without changing them in any way.

If you're on XP, all of the functionality will be in the driver. XP itself has no concept of crossover. It knows about multichannel sound, but it doesn't do crossover at the OS level.

You should check both those solutions (Onkyo set to do crossover via 'small' speaker settings, Win7 set to NOT do crossover via 'large' speaker settings), because you could have both of those problems at once.

That'll most likely fix you right up.
posted by Malor at 12:25 AM on April 14, 2010


Thank you all for the excellent responses. I went down the easiest route first, and switched the crossover for my front floor standing speakers. They were set as "full range" before, since they are large floor standing speakers and can handle the "full range" of frequencies. I dropped it down to 120hz and found that any setting(120hz-50hz) besides the "full range" setting allowed my sub woofer to be active.
I also changed a setting on my S/PDIF output that let me switch the default format from 2 channel to Dolby Digital. This seemed to improve the sound considerably, adding a much fuller more surround sound like feeling. Image of setting here. Windows 7.

Conclusion- Adjusting my front speakers crossover from full range to a value such as 120hz, allowed my sub to get the lower frequencies pushed to it, and now my wife is going to hate me and my bass!
posted by dpollitt at 8:47 AM on April 14, 2010


Ok, with that extra info: the reason you seeing those exact symptoms, where the 360 drove the sub but the PC didn't, was because a 5.1 signal has a dedicated subwoofer channel, the .1. So, when you fired up a movie, your sub did its thing, because there's a dedicated channel just for that.

Your PC is sending just a L+R signal, so with the receiver in Large speaker mode, the Onkyo sent everything to the front pair. You'd told it that they could handle the bass, so that's where it was going. If you noticed that bass was missing, then you don't actually have full range speakers.

Full range is normally defined as 20Hz-20Khz. It's hard to find speakers that can do that anymore, and yours probably won't. However, you'll get slightly better bass if you get as much out of your L+R speaker pair as you can. A crossover to sub is inferior to emitting the full frequency range from the front speakers, because you get a phase error from the crossover process, and get another phase error from the physical placement of the sub, which is typically separated from the L+R pair by some distance. This typically isn't terribly offensive, but it'll usually sound better if you avoid that whenever possible. A coherent signal from a L+R pair is essentially always better than split reproduction.

For music, I'd suggest looking up what the actual frequency range is for your speakers, and set the crossover at that level. That way, anything that CAN come out of them will, while lower frequencies are crossed over. When you're sending a 5.1 signal, the .1 will go to the sub, along with all the bass from the other speakers that's too low.

If you don't want to fiddle with it, it's usually considered best to set crossover at 80Hz. When you go higher, you're asking the sub to reproduce frequencies it isn't well-suited for. Nearly all subs will handle up to 80Hz just fine, by design, but many don't do well above that.
posted by Malor at 6:36 PM on April 14, 2010


I have found on some receivers setting them to a mode such as Stereo/Music causes them to use the sub-woofer. When getting discrete Left and Right channel signals. As oppose to leaving it in Dolby Digital / DTS mode.
posted by OwlBoy at 3:12 PM on August 4, 2010


« Older Does anyone know of a quick hi...   |  What's the best way cache and ... Newer »
This thread is closed to new comments.