Join 3,512 readers in helping fund MetaFilter (Hide)


Why isn't LaTeX displaying a divider line between the body and footnotes?
April 2, 2010 1:51 PM   Subscribe

Why isn't LaTeX displaying a divider line between the body and footnotes?

I've searched and searched but can't figure out what I'm doing wrong. I want a separator/divider line to set the footnotes off from the body of my text. I'm apparently canceling out the standard line but don't want to be.

--

%!TEX TS-program = xelatex
%!TEX encoding = UTF-8 Unicode

\documentclass[12pt,letterpaper]{article}

% DOCUMENT LAYOUT
\usepackage[latin1]{inputenc}
\usepackage{fullpage,}
\usepackage{setspace}
\doublespacing
\usepackage{fancyhdr}

% FONTS
\usepackage{fontspec}
\defaultfontfeatures{Mapping=tex-text} % converts LaTeX specials (``quotes’’ --- dashes etc.) to unicode
\setromanfont [Ligatures={Common},Numbers={OldStyle}]{SabonNext LT Regular}

% ---- CUSTOM AMPERSAND
\newcommand{\amper}{{\fontspec{Arno Pro}\selectfont\itshape\&}}

% Header/Footer Style Options

\pagestyle{fancy} % Sets fancy header and footer

\setlength{\skip\footins}{1cm}

\lhead{}
\chead{}
\rhead{}
\lfoot{}
\cfoot{}
\rfoot{\thepage}
\renewcommand{\headrulewidth}{0pt}

\widowpenalty=10000
posted by Outis to Computers & Internet (3 answers total)
 
Divide and conquer is usually the best strategy for solving this kind of problem. Try commenting out parts of your header to find out what is breaking things.
posted by Dr Dracator at 1:57 PM on April 2, 2010


FWIW I can't reproduce this; the only thing I'm doing differently is not using the font, because I don't seem to have it installed. Are you sure all your packages (fancyhdr especially) up to date? Have you tried compiling this with only a test body, to make sure it isn't something later in the document? As Dr Dracator says, at this point commenting out various pieces of your header is the way to go.

Also, you will save yourself many headaches of this kind if you switch to using the memoir class, for all these page formatting things you are currently doing with separate packages.
posted by advil at 2:31 PM on April 2, 2010


Well, it didn't have to do with the general document layout I was using, instead it was a command within my bibliography layout that was causing the problem. Thanks you both. I feel pretty stupid now.
posted by Outis at 2:46 PM on April 2, 2010


« Older Tell me, a prospective residen...   |  Can I buy self-heating soup ca... Newer »
This thread is closed to new comments.