Join 3,512 readers in helping fund MetaFilter (Hide)


Page numbers in Word 2007. AAARRRGGG!!!!
February 24, 2010 2:12 PM   Subscribe

Page numbers in Word 2007. AAARRRGGG!!!!

I have a 44 page document. Once upon a time, it had some sections which were landscape and other sections which were portrait. Now the whole thing is landscape. When I turn on page numbering, at page 16, it starts over again. No matter what I do! With formatting symbols on, there is no section break (or anything else suspicious) at the offending location in my document (although there may have been at some point in the past).
posted by goethean to Computers & Internet (16 answers total) 3 users marked this as a favorite
 
If you double click on the header/footer (where ever the page numbers are) and then hit the "Header & Footer Tools". Then look at the Navigation section. Press "Next Section" to see if you still have sections present (I'm guessing you do). Anyway, to get rid of the problem make sure that "Link to Previous" is on. Does that work?
posted by hydrobatidae at 2:23 PM on February 24, 2010


Yeah, I "linked to previous" at the offending section. Didn't help.
posted by goethean at 2:26 PM on February 24, 2010


Oh, the other place to check is under "Header" or "Footer" (still in the Header & Footer Tools, Design ribbon or whatever it's called). Click on the little arrow pointing down, then Edit Header/Footer and a box should pop up titled "Page Number Format"; make sure the Continue from previous section circle is selected.
posted by hydrobatidae at 2:27 PM on February 24, 2010


Try removing the page numbers. (In fact, remove the entire header or footer if it doesn't have anything else in it.) Then save your doc. Open it up again, and put the page numbers back in. See what happens.
posted by SuperSquirrel at 2:29 PM on February 24, 2010


One last-ditch thing you may want to try is to purge your template. I listed the steps in this previous thread where someone was having weird formatting issues with their embedded JPGs. If you have customized Word a lot, purging your template may cost you some time and convenience, but it has a way of clearing up inexplicable formatting snafus. I would particularly recommend this if you frequently deal with others' Word documents sent to your computer, since these have in the past forced me to delete my default template multiple times.
posted by AugieAugustus at 2:31 PM on February 24, 2010 [1 favorite]


I fixed the problem at p 16 and had another at p 23.

I followed SuperSquirrel's advice, but it didnt work.

I did a workaround by "starting the numbering" at 23 on page 23.
posted by goethean at 2:43 PM on February 24, 2010


Have you tried repairing the document? It fixed a really weird sections + numbering error I was having in my thesis (which is way too long and convoluted by now to purge the template).
posted by shelleycat at 2:48 PM on February 24, 2010


Try saving a copy as an RTF file, then re-opening that. If it looks acceptably close to your original, quit Word and re-open the RTF using Notepad. You will find a massive and intimidating mess of curly brackets and weird words with backslashes in front. Don't panic. Instead, search for \sect and when you find it, delete it along with everything up to the next whitespace (space or newline) character.

For example, using a simple text editor to open an RTF file created by OpenOffice.org Writer containing a section break, I searched for /sect, found

...\par \sect\sectd\sbknone\pgwsxn11905\pghsxn16837\marglsxn1134\margrsxn1134\margtsxn1134\margbsxn1134
\pard\plain \ltrpar\s1\cf0{\*\hyphen2...

and deleted the part shown in bold. Repeat this process until you can't find any more occurrences of /sect, then save the file, close Notepad and open the RTF up again with Word. You should find that it now really doesn't contain any more section breaks,
posted by flabdablet at 3:28 PM on February 24, 2010 [1 favorite]


For what it's worth, I just spent 30 minutes at work dealing with a 28 page Word 2003 document in the exact same scenario. It switched from landscape to portrait at around Page 16 and the pages started over again at #1. Here's what I did. I removed all page numbers from all footers, saved the document, opened it back up again and then entered the page numbers back in. Still, it restarted the numbering at the point where it switched to Portrait. So, I highlighted the 2nd "#1" (on Page 16) and then went into into the Page Number Format option in the 'Header & Footer' menu, and chose 'Continue From Previous Section." Fixed it right up, and now all page numbers look nifty. Yay.
posted by Rewind at 3:29 PM on February 24, 2010


Oops, slash dyslexia. Everywhere I say /sect, I mean \sect.
posted by flabdablet at 3:30 PM on February 24, 2010


Turn on the view that shows all formatting marks. Look for section breaks, which are indicated by a dashed lined. Section breaks can be used to control numbering, and can hold incorrect numbering data.
posted by theora55 at 3:40 PM on February 24, 2010 [1 favorite]


theora55, see this part of the question: With formatting symbols on, there is no section break (or anything else suspicious) at the offending location in my document
posted by flabdablet at 4:54 PM on February 24, 2010


I'd bet the error comes from section breaks. Find them, remove them, and all will be well.
posted by Classic Diner at 5:33 AM on February 25, 2010


One other thing that can really screw up page numbers: in the Page Setup options (Page Layout tab, click the little square on the right-hand corner of the grey "Page Setup" title), on the Layout tab, make sure under Headers and footers that you don't have either option checked that says "different odd and even" or "different first page".

Sometimes that "different first page" will continue to reformat numbering if it remembers a section break.
posted by Eicats at 7:07 AM on February 25, 2010


Seconding Classic Diner. Section breaks, especially the multiple ones required to make part portrait and part landscape, will wonk a document. Remove them all and re-apply.
posted by Sheppagus at 1:31 PM on February 25, 2010


this is a bug--the new Word version does not play well with others, as in templates or files in other Word versions. I don't know a workaround. Even MS doesn't have a fix or acknowledge there is a problem on its blogs.

I don't know why they turned out this horrible buggy version. They're like the DMV big enough to do whatever they want.
posted by PJSibling at 4:05 PM on August 9, 2010


« Older Help me decorate a multi-faith...   |  Couples daily devotional/bible... Newer »
This thread is closed to new comments.