Join 3,436 readers in helping fund MetaFilter (Hide)


ターンバック: "I think that says keep going, but who can tell with those crazy boxes?"
February 17, 2010 5:21 PM   Subscribe

How do you avoid the "undisplayable character boxes" you see when encountering a new or unknown language script?

For example, this page should display music notes. Instead, I just see characters like this:

01D
100

in boxes. Browsing the web on my iPhone, it doesn't seem to have any problems properly displaying Chinese, Russian, or Greek characters for example. Is there any way to provide my firefox browser the same capability? Is there a 'Unicode font pack' that I can install?

Even though I can't understand any of those languages, it's just ugly.
posted by bouchacha to Computers & Internet (9 answers total) 8 users marked this as a favorite
 
"undisplayable character boxes" = mojibake
posted by ripley_ at 5:38 PM on February 17, 2010


Unicode Font Resource. These tools can help you figure out which fonts are missing, or which font pack would hold the magic font to make a particular page not show the unicode boxes.
posted by idiopath at 7:38 PM on February 17, 2010 [1 favorite]


I'm really quite interested in any answers you get to this as well, but I can add this little nugget: what you're seeing is called a fallback font.
posted by WCityMike at 8:54 PM on February 17, 2010


Have you tried another browser on the same computer? If they show up in Safari/Internet Explorer/Opera, then you eliminate the possibility/likelihood that it's a font problem.

I've had the same problem for years (on Linux): older versions of Firefox used to render these things perfectly, and all versions of Opera do so (though I don't like Opera nearly as much), but any recent version of Firefox has been a dud. So it doesn't seem a font problem for me (and I installed a lot of new fonts), but a browser problem.
posted by astrochimp at 10:07 PM on February 17, 2010


If the fault is with Firefox, the configuration I posted in my answer to this thread will help (and also, if doing what I suggest there fixes the problem immediately, then yeah the problem was firefox's and not your fonts).

I am not sure though, because more often encoding error's with Firefox tend to display random western characters instead of the proper unicode rendering.
posted by idiopath at 10:28 PM on February 17, 2010


Internet Explorer has the same problem, except it displays blank boxes and questions marks instead. I looked at the Unicode slide rules linked by idiopath, but they seem to be more appropriate as references for particular characters.

I tried all the different character encoding options under Firefox and I still get the boxes (or everything turns into boxes if I pick UTF-16). Now that I know it's not a browser issue, is there a font pack available?
posted by bouchacha at 4:32 AM on February 18, 2010


My first link had a whole bunch of fonts. The slide rules help you figure out which of those are missing.
posted by idiopath at 8:54 AM on February 18, 2010


Is it possible to install most of the common ones instead of hunting each font one by one?
posted by bouchacha at 9:13 AM on February 18, 2010


By the way, that says "turn back".
posted by WCityMike at 3:18 PM on February 20, 2010


« Older Certified Translator? I'm in M...   |  My SO loves rice pudding, and ... Newer »
This thread is closed to new comments.