Join 3,562 readers in helping fund MetaFilter (Hide)


Help playing audio on Japanese BDs?
February 10, 2010 6:18 PM   Subscribe

Where do I find a codec for the audio on Japanese BDs?

I have the following player programs installed on my Win7-64 system: PowerDVD version 7.3(Ultra), Media Player Classic version 6.4.9.1, and Zoom Player Home Professional v7.0. I also have CCCP version 2009-09-09 installed, and the 64-bit version of MediaInfo 0.7.27.

Mostly what I play here is North American releases of DVDs and BDs, but I have ordered a couple of BDs from Japan.

Those play fine under PowerDVD, but I don't really like PowerDVD. I'd prefer to use MediaPlayer or Zoom Player. When I try playing Japanese BDs with those programs, I get no sound.

MediaInfo says that the sound tracks on the Japanse BDs are "PCM (Blu-ray) (Big / Signed)". PowerDVD seems to understand that particular audio format, but whatever codec it's using doesn't seem to be available to anything else on the system.

To solve this problem, it seems to me that there are three possibilities:

1. Find and install an appropriate codec which MediaPlayer and/or Zoom Player can use.
2. Figure out how to make PowerDVD's codec available to other programs.
3. Figure out that CCCP really does know how to do this but I've got it set up wrong, and make miracle changes to make it work.
(4. VLC is not the answer. Please, no one mention VLC.)

Can anyone help me with any of #1-3?
posted by Chocolate Pickle to Computers & Internet (21 answers total)
 
Blu-ray audio is one of the following: AC3 (and EX, etc. variants), EAC3, TrueHD, DTS (and ES, etc. variants), DTS-HD MA, DTS-HD HR, LPCM. PowerDVD 9 Ultimate should handle all of the above without issue; a lesser version (particularly a crippled OEM version that comes with a PC or optical drive) may not.

You do not need CCCP. Codec packs cause more headaches than they solve. Try to start fresh by uninstalling it and deleting any relevant registry entries (e.g., for the internal ffdshow). You should be able to play anything with the latest builds of Media Player Classic or Media Player Classic Home Cinema, Haali Media Splitter, and the latest ffdshow-tryouts. You want 32-bit for all of these even on an x64 system for stability and feature set reasons.

Here's the major problem: the Blu-ray disc is encrypted, meaning you can't access most or all of its features outside of PowerDVD and other HDCP/etc. compliant software. However:

One workaround is to use AnyDVD HD as an on-the-fly decryption layer and open the M2TS files that make up the BD content in Media Player Classic or MPC-HC (MPC-HC can even parse Blu-ray playlists so playing titles separated into more than one M2TS file is not a pain in the ass).

Another is to rip with AnyDVD HD or MakeMKV to your hard drive; the former will give you a disc folder output, while the latter will give you the title(s) of your choosing in Matroska format (N.B.: No software currently handles BDSUP-in-MKV subtitles, though MPC-HC will do non-animated BDSUP-in-M2TS without issue).

You can also rip with the free decrypter built into the (otherwise payware) DVDFab. Finally, for the sake of completeness, you can use an undocumented feature of MakeMKV for possibly free (for now) on-the-fly decryption.


Now that we've laid the groundwork, on to the meat of your question.

1. There are no extant freeware decoders for any of the DTS-HD formats, though ffdshow-tryouts can bitstream them using a compatible soundcard to a compatible receiver. ffdshow-tryouts will decode AC3 and variants, DTS and non-HD variants, and LPCM without a problem. For playing from the disc without bitstreaming, you will get the DTS core of the DTS-HD formats using ffdshow playing from your PC's speakers. Mostly this will sound great.
2. PowerDVD detects the loading of some of its filters into your DirectShow filter chain and will crash your other players. Even for some filters without this blocking capability, such filters will not accept input except from PDVD's internal splitters, meaning they won't work externally. There are workarounds, but they're not consistent and are a huge pain. So give up on those for now, IMO.
3. Just nuke CCCP.

The quickest way to decide on a resolution here is for you to use BDInfo or the MediaInfo you already have to figure out what sort of audio you have. Note that both require a decryption layer such as AnyDVD HD to be present before they can parse the content. If you can get that info, post it here and from there we can arrive at a workaround. It would also help to know the branding and version number of your PowerDVD installation so we can definitively rule out other problems.

I'll keep an eye on this thread until it is resolved, because I too have been vexed by the "fuck the consumer" commercial attitude surrounding hi-def content.
posted by Inspector.Gadget at 7:14 PM on February 10, 2010 [1 favorite]


Almost forgot: you can probably get more info about the relevant audio tracks from the packaging, too, if the box follows the convention I've seen in US BD commercial releases.
posted by Inspector.Gadget at 7:16 PM on February 10, 2010


Looks like neither CCCP nor VLC support TrueHD or DTS-MA decoding. Try ffdshow. (it's a pain to configure, you might try googling some setup guides.)
posted by wongcorgi at 7:16 PM on February 10, 2010


I suppose I should have mentioned that I have anyDVD HD version 6.6.0.9 installed. So encryption isn't an issue. Both MediaPlayer and Zoom Player V7 understand the M2TS format if it's decrypted, and they can play the video from them fine. (That is how I play using those programs; I don't bother with the BD menu at all.)

Also, I need CCCP for my fansubs. (You didn't read that.)

I was doing some research and it looks like the format I'm having trouble with is linear PCM, and I think the reason I'm having trouble is that it's big-endian and I'm running an Intel-based computer.

I have been known to do rips to MKV, and for that I use HandBrake 0.93. But it doesn't handle the audio on the Japanese BD's either. All my American BDs have AC-3 soundtracks, and that works beautifully with every tool I own. (And video on every BD is fine.)

"PowerDVD detects the loading of some of its filters into your DirectShow filter chain and will crash your other players." Ah; I ran into this a couple of days ago when I set up Zoom Player to use PowerDVD's audio and video decoders, and my system blue-screened.

Wrongcorgi, FFDShow is included as part of the CCCP. I already have it installed and configured and it works fine -- for everything except this.

Here is the full MediaInfo dump on one typical track from a Japanese BD:

General
ID : 0
Complete name : E:\BDMV\STREAM\00002.m2ts
Format : BDAV
Format/Info : Blu-ray Video
File size : 7.93 GiB
Duration : 26mn 52s
Overall bit rate : 42.2 Mbps
Maximum Overall bit rate : 48.0 Mbps

Video
ID : 4113 (0x1011)
Menu ID : 1 (0x1)
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4.1
Format settings, CABAC : Yes
Format settings, ReFrames : 4 frames
Duration : 26mn 52s
Bit rate : 37.5 Mbps
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate : 23.976 fps
Resolution : 8 bits
Colorimetry : 4:2:0
Scan type : Progressive
Bits/(Pixel*Frame) : 0.754
Stream size : 7.04 GiB (89%)
Color primaries : BT.709-5, BT.1361, IEC 61966-2-4, SMPTE RP177
Transfer characteristics : BT.709-5, BT.1361
Matrix coefficients : BT.709-5, BT.1361, IEC 61966-2-4 709, SMPTE RP177

Audio #1
ID : 4352 (0x1100)
Menu ID : 1 (0x1)
Format : PCM
Format settings, Endianness : Big
Format settings, Sign : Signed
Muxing mode : Blu-ray
Duration : 26mn 52s
Bit rate mode : Constant
Bit rate : 1 536 Kbps
Channel(s) : 2 channels
Channel positions : Front: L R
Sampling rate : 48.0 KHz
Resolution : 16 bits
Stream size : 295 MiB (4%)

Audio #2
ID : 4353 (0x1101)
Menu ID : 1 (0x1)
Format : PCM
Format settings, Endianness : Big
Format settings, Sign : Signed
Muxing mode : Blu-ray
Duration : 26mn 52s
Bit rate mode : Constant
Bit rate : 1 536 Kbps
Channel(s) : 2 channels
Channel positions : Front: L R
Sampling rate : 48.0 KHz
Resolution : 16 bits
Stream size : 295 MiB (4%)

Video on that track plays fine with MediaPlayer and Zoom Player. But I get no sound.
posted by Chocolate Pickle at 7:51 PM on February 10, 2010


The version of PowerDVD 7 (not 9) that I have is a full commercial version, not a crippleware included with a BD drive. (I've got the crippleware version of PDVD8, but it's caused me too much grief.)

I'd be willling to (pay money to) upgrade to PDVD 9 if it would solve this problem, but I don't think it will.
posted by Chocolate Pickle at 7:54 PM on February 10, 2010


This is what MediaInfo says about the audio on one of my American BDs, which work perfectly:

Audio #1
ID : 4352 (0x1100)
Menu ID : 1 (0x1)
Format : AC-3
Format/Info : Audio Coding 3
Format profile : TrueHD / Core
Muxing mode : Stream extension
Duration : 47mn 45s
Bit rate mode : Variable / Constant
Bit rate : Variable / 640 Kbps
Maximum bit rate : 2 376 Kbps / 640 Kbps
Channel(s) : 6 channels
Channel positions : Front: L C R, Surround: L R, LFE
Sampling rate : 48.0 KHz
posted by Chocolate Pickle at 7:57 PM on February 10, 2010


When you open the M2TS file in MPC, do you get a prompt that you're missing a decoder for one of the streams (pin error)? If not, is ffdshow doing the LPCM decoding? If not, what's currently doing the decoding? DVD Audio LPCM (identical to the audio at issue here) is big endian, and I've never hit any problems with it here on an Intel-based PC.
posted by Inspector.Gadget at 8:04 PM on February 10, 2010


Also, on a whim, try using the MPC internal MPEG-TS splitter if you're currently using Haali thru CCCP; older versions of Haali have some PCM issues, IIRC.
posted by Inspector.Gadget at 8:06 PM on February 10, 2010


When you open the M2TS file in MPC, do you get a prompt that you're missing a decoder for one of the streams (pin error)? No.

If not, is ffdshow doing the LPCM decoding? FFv is running. FFa is not. In the "Play" menu of MPC, the audio choices are grayed out. I think that MPC doesn't think there's an audio track at all.

try using the MPC internal MPEG-TS splitter if you're currently using Haali thru CCCP Where do I control that? In MPC's options under "Audio Switcher" I currently have enabled the "built-in audio switcher filter", but Haali is still running so I assume that's not right.
posted by Chocolate Pickle at 8:29 PM on February 10, 2010


In the CCCP main setup menu, on the second page there's a section for Haali. I tried unchecking "Enable MPEG-TS" and it didn't change anything. MPC still acts like it doesn't think there's an audio track.

Zoom Player is the same. When the M2TS file is playing, its menus look as if there is no audio at all.
posted by Chocolate Pickle at 8:34 PM on February 10, 2010


When I right-click the Haali icon in the tray, it doesn't show any audio track either.
posted by Chocolate Pickle at 8:35 PM on February 10, 2010


In MPC, go to View -> Options -> Internal Filters and check "MPEG PS/TS/ PVA" in the left column. This will enable the internal M2TS splitter, which has a higher priority than Haali. For simplicity's sake, disable the internal audio switcher (which ought to be redundant in most cases).

If you don't see the ffdshow audio icon in the tray, that's not necessarily determinative because the icon can be switched off and on. Open ffdshow audio config (directly if you can, rather than thru CCCP) and set LPCM to "enabled" after selecting the "Codecs" panel. You will need to click "OK" and also close and re-open any player connected to ffdshow for this to work.

In the "Play" menu of MPC, the audio choices are grayed out.

This is normal when using a splitter that doesn't feed MPC the transport stream metadata, though Haali does do this, so there's another issue somewhere.

I have just opened an M2TS sample with a Bd-sourced big endian signed LPCM stream in an M2TS file using MPC-HC (a recent revision) and its internal TS splitter feeding the audio ffdshow-tryouts with LPCM enabled as the audio decoder (again a recent version) and had perfect playback.
posted by Inspector.Gadget at 8:42 PM on February 10, 2010


In MPC, go to View -> Options -> Internal Filters and check "MPEG PS/TS/ PVA" in the left column. This will enable the internal M2TS splitter, which has a higher priority than Haali. For simplicity's sake, disable the internal audio switcher (which ought to be redundant in most cases). Done. No effect.

Open ffdshow audio config (directly if you can, rather than thru CCCP) and set LPCM to "enabled" after selecting the "Codecs" panel. It was already enabled.

I have just opened an M2TS sample with a Bd-sourced big endian signed LPCM stream in an M2TS file using MPC-HC (a recent revision) and its internal TS splitter feeding the audio ffdshow-tryouts with LPCM enabled as the audio decoder (again a recent version) and had perfect playback. OK, I'll have to find and install MPC-HC and FFDShow-tryouts.
posted by Chocolate Pickle at 8:54 PM on February 10, 2010


OK, I'll have to find and install MPC-HC and FFDShow-tryouts.

Ditch CCCP if you can, it's messing things up. Try to get rid of it completely. For fansub stuff, you can download and register VSFilter (which is what CCCP uses anyway) and it's straightforward to config manually from clicking it in the MPC filters list for currently playing content. (And register it as a preferred external filter within MPC to force calling it; Haali has its own option under "Compatibility" to force loading VSFilter).

I suspect that the issue lies in something with DS priority for Haali, but that doesn't explain why you're not getting the translated metadata in the MPC nav panel when using Haali.

A clean install of MPC or MPC-HC, Haali (without elevating the priority through a reg hack or similar, as CCCP apparently does), and ffdshow-tryouts should handle this type of LPCM audio without issue.
posted by Inspector.Gadget at 9:02 PM on February 10, 2010


Interesting. When I installed both of those, I got audio playing that M2TS file. However, Zoom Player still doesn't, and the old version of MPC doesn't.

I'm going to try Handbrake now to see if that gets audio when I rip to an MKV.
posted by Chocolate Pickle at 9:12 PM on February 10, 2010


In my experience, Handbrake is a subpar solution for Blu-ray -> x264 on Windows for quality and flexibility reasons. I'd use

AnyDVD -> eac3to -> DGIndex or codec-appropriate variant -> Avisynth -> x264

, or something that wraps this process (minus AnyDVD) like MeGUI, Staxrip, Ripbot264, etc.

Handling BD PCM audio is a pain, but eac3to is simple and has been in development long enough that it deals well with all BD audio types:

eac3to somefile.pcm somefiles.wavs

eac3to somefile.pcm somefile.flac

eac3to somefile.pcm somefile.ac3 -b 448

eac3to somefile.dtshd somefile.dts -core

etc.
posted by Inspector.Gadget at 9:21 PM on February 10, 2010


Handbrake still doesn't work, and it's probably a lost cause. I'll look into those tools you've mentioned.

MPC-HC still isn't a totally satisfactory solution because the video is jerky on playback. (It's not a hardware issue; this is a quad-core machine with fancy graphics hardware.)
posted by Chocolate Pickle at 9:35 PM on February 10, 2010


Hmm...make sure the video renderer is set to EVR-Custom, make sure you have the latest driver updates for your video card, make sure you have the latest DirectX, make sure you're using either the MPC-HC internal (DXVA) H.264 decoder or ffmpeg-mt in ffdshow for H.264 content, and make sure your renderer settings (View -> Renderer Settings) are sane.

On certain 1080i content (H.264 or VC-1), anything libavcodec-based (including ffdshow, VLC, MPC-HC internal, etc.) decoders will jerk because ffmpeg hasn't implemented the relevant functions. Try using CoreAVC in any DirectShow player for H.264 and the WMVideo Decoder DMO for VC-1. I've found such content to be extremely rare, on the order of 2 low-budget productions out of >100 Blu-ray discs I've watched.

Jerky playback shouldn't happen on H.264, MPEG-4 ASP, MPEG-2, or MPEG-1 content. Windows Media Video and the ASF container are a horrible mess and even Microsoft can't ensure universal compatibility of the format, so I don't know about that. If you're having jerky playback of progressive hi-def content, look into other causes: disk thrashing, etc. On a Core 2 Duo Laptop with a 9650M GT here I can watch a full-length 1080p H.264 movie with no dropped frames, audio artifacts, or jerkiness for the duration of the film. Some people, for whatever reason, find that no DirectShow player performs well on their system (PEBKAC or undiagnosed hardware problem), and turn to ReClock as a work-around.
posted by Inspector.Gadget at 9:59 PM on February 10, 2010


The playback in MPC-HC is jerky even though my system only shows about 11% CPU loading. This is a quad core machine.

Also, that same exact file plays smoothly in MPC, Zoom Player, and PDVD. And MPC and Zoom Player were using EVR-9 renderless, which is what MPC-HC was set to. (In fact, when MPC-HC was installed, it borrowed all the settings used by MPC.)

I tried setting MPC-HC to EVR-Custom and it made no difference.

Anyway, it's late and I'm going to bed. Thanks very much for your help.
posted by Chocolate Pickle at 11:03 PM on February 10, 2010


Sorry, "VMR-9 renderless".
posted by Chocolate Pickle at 11:04 PM on February 10, 2010


Try KMPlayer.
posted by Gyan at 12:41 AM on February 11, 2010


« Older Japan in 6 days hahaha...need ...   |  I'm about to ask a potentially... Newer »
This thread is closed to new comments.