Join 3,501 readers in helping fund MetaFilter (Hide)


Nothing "Karmic"al about my slow computer
January 28, 2010 12:02 PM   Subscribe

Ubuntu 9.10 is running INCREDIBLY slow after a recent reboot. Any suggestions?

The system is fairly old (Dell PowerEdge 1300, dual 500 mhz Intel PII, less than 512 mb RAM). It doesn't do much heavy lifting and has always been fairly reliable. Until today, when I rebooted it to do a kernel update.

The machine took a long time to boot. As in, 20 minutes before I had anything on screen. It's supposed to be running Xubuntu, and (when I finally got a CLI) I noticed a ton of Gnome things running. I removed gdm from my rc.d and restarted. Still slow as hell. Still got the Xubuntu splash and startup. I'd be happy to have it boot straight to CLI as I don't do anything with it directly, all my interactions are via SSH (but I do want XFCE installed, as I occasionally run programs via X11 forwarding).

I am back at a command line now (it took a full 10 minutes to go from password entry to command prompt!). I am limited by the extremely small screen resolution (Mach64 video, no way to bump up resolution, so most directory commands, etc. scroll off the screen with no way to see what I am missing). I can't log in remotely - it is possible to do it, but the lag between any command I issue and the response is so damn long that I end up timing out before the system does anything.

Occasionally it works fine. Then I log out, and I'm back to the same thing - insanely long waits just to get a login prompt, to have it respond to the prompt, and half the time it boots me even at the terminal because the password response times out before the damn machine even gives me the option to input a password. I'm at a loss here. Any suggestions? I didn't do anything to the system since the 9.10 upgrade except run Aptitude and then reboot after I noticed one of the updates was a new kernel. This is not the first time the machine has rebooted since the 9.10 update, either.

(If it matters at all, the system itself is working, for the most part. It acts as a firewall between my laptop and the network. I am successfully getting DNS from the machine, and have no networking issues once it finally boots. I just can't log in to it either remotely or at the command line.)
posted by caution live frogs to Computers & Internet (11 answers total)
 
Have you checked the logs? (If you're having problems with things scrolling off the screen, try using more or less.)

more /var/log/boot
more /var/log/messages
more /var/log/xorg.0.log
posted by zamboni at 12:15 PM on January 28, 2010


Have you tried rolling back to a previous kernel on startup to see if it works better?
posted by PhoBWanKenobi at 12:17 PM on January 28, 2010


Is there a lot of disk activity? You might be thrashing. Look for memory hogs. (I usually just use top to check for this, press M to sort by memory use)

Or it's possible that the hard drive is failing; I've seen that cause massive slowdowns. Do commands like ls or basic operations like reading or writing small files take a really long time?

As for those commands scrolling off screen, try piping them through |less
posted by qxntpqbbbqxl at 12:27 PM on January 28, 2010


I'd try running from a LiveCD for a while to see if it's simply a problem of a dying hard drive. Rule that out before tearing your hair out looking for broken config files or whatnot.
posted by advicepig at 12:34 PM on January 28, 2010


My guess is that something big is loading at startup, causing you to run out of memory and start swapping. Get to a command line and use top to see what's eating all your CPU and/or memory. If you have questions, paste some top output here (inside <code> tags) and we'll try to help you decipher it.
posted by chrisamiller at 12:43 PM on January 28, 2010


Boot and go to the Grub menu (you'll have to hit a key quickly, Escape I think) and choose safe mode. See if that makes a difference. If it doesn't, try the previous instance of the kernel, as well as that instance in safe mode, which should both still be available and listed in the menu. Do you get different results in any of these cases?

(And you don't need an X server, let alone a desktop environment, running to do X11 forwarding. just the appropriate X libs. You don't need to worry about which ones -- just install a command-line only system from an Ubuntu Alternate Install CD, and then install whatever X apps you want, and you'll get the libs you need.)
posted by Zed at 1:01 PM on January 28, 2010


I didn't notice if you managed to remove the GNOME stuff, but this totally helped me when my system was sluggo last week.
Kudos to you for using Xubuntu :D

http://www.psychocats.net/ubuntu/purexfce
posted by The Biggest Dreamer at 2:02 PM on January 28, 2010


After a forced reboot it seems to be working. Not sure what is going on here at all. I can SSH in to it again, and the Gnome stuff appears to be gone. The only thing I can think of is that is has something to do with ureadahead, which is throwing an error on start. Some of the forums I read said that rebooting repeatedly might fix this.

Nothing really obvious seemed to be taking up much memory, and aside from the disk thrashing (which has stopped, reinforcing my thought that something was indexing some data somewhere) I couldn't find any obvious issues.

Nothing in the logs jumps out at me, either. Thanks for the suggestions - with a working login prompt I was actually able to check some of them.

(I never installed any of the Gnome stuff. In fact the system was CLI only for a long time, and I only threw Xfce4 on it because I wanted a lightweight window system for the few times my networking breaks and I need a working web browser for troubleshooting. Why Gnome was there at all is beyond me. Now, if I could just get the system to realize that my ancient Mach64GT actually has 16 rather than 2 mb of video memory, I might be happy...)
posted by caution live frogs at 2:50 PM on January 28, 2010


in terminal "top" will give you a list of all running processes sorted by CPU time, might point out you in the right direction "culprit"wise
posted by oblio_one at 4:26 PM on January 28, 2010


caution live frogs: Nothing really obvious seemed to be taking up much memory, and aside from the disk thrashing (which has stopped, reinforcing my thought that something was indexing some data somewhere) I couldn't find any obvious issues.

Ah, this might be something that I'm annoyed at for taking up some disk space on one of my machines. I had a tracker running to index files. ~/.cache/tracker was taking up all the remaining space, making the indexer hang due to a "corrupted file." Look under System / Preferences / Search & Indexing for its options. I didn't have "Enable Indexing" checked, but I've just gone through the options, trying to disable stuff. This is too recent to say it won't happen again, unfortunately.
posted by Pronoiac at 4:00 PM on January 30, 2010


Think it's a drive indexing thing. One of the updates pushed ureadahead onto the Ubuntu systems, and the first two or three reboots following the update are insanely slow thanks to a drive indexing service. On my system it's apparently slow enough to about stall the box; it's working better now and appears to be back to normal.
posted by caution live frogs at 11:08 AM on February 28, 2010


« Older I'm getting interested in work...   |  I'm going to a brunch next wee... Newer »
This thread is closed to new comments.