Join 3,494 readers in helping fund MetaFilter (Hide)


Unscrewing an Access d/b permissions
January 28, 2010 10:36 AM   Subscribe

How do I regain write permissions for an Access database.

I am just starting to use a workstation at a new position. The OS is XP w/ service pack 3. The PC is not secured by the IT staff. I have login access to the admin user and am logging in as another user (sales). The IT guy here is a Linux guru, and doesn't know how to fix the problem.
I've been using an Access database located on the C drive. I switched the sales user to being a regular/limited user from having admin rights in order to better lock down the machine.
Now I cannot launch the Access d/b. The folder it is in (access) is read-only. I've tried setting the sales user back to having admin rights, and also tried logging in as the admin user and changing the read-only setting on the Access folder.
The admin user can launch the d/b now. When I try as the sales user, I get an error that the d/b is read-only. I'm totally set up to use the sales login and don't want to have to redo stuff as the admin user.
What can I do to unscrew this pooch? I'm looking for the permissions but cannot find them. The properties for the access folder only shows the Read-only setting. When I unclick the read-only button as the admin user, they revert to read-only next time I look at them.
posted by diode to Computers & Internet (6 answers total)
 
It's not clear from your question, are you talking about the folder containing the database itself (a .mdb file) or the Access installation directory?
posted by teraflop at 10:40 AM on January 28, 2010


If you're looking at the "read only" checkbox on the general tab (in the file properties dialog), that tends to confuse everybody. It always looks like it's checked but greyed out, and you can either clear it or set it to a normal black check mark.

What's happening there is that a folder cannot be "read only". That checkmark is just there so you can set all the contained files to read-only (or clear that flag on all files at once). If you check the properties of the MDB file itself, you should see it's not marked as read-only.

For the actual folder security settings, you want to look on the "security" tab. If there's no such tab there, you're probably using a FAT filesystem instead of NTFS, and it doesn't support any file or folder security.
posted by FishBike at 11:49 AM on January 28, 2010


Login as the Admin user, create a brand new folder on the C drive - you will be the 'owner' of this so you should have full control. In the folder properties grant full control to the sales user.

Copy (don't move) the database into the new folder, then login as sales.
posted by Lanark at 2:43 PM on January 28, 2010


Okay.

The file system is NTFS. There is no security tab on the properties window for the folder containing the access file I'm trying to run, nor is there one on the properties for the file itself.

The read-only attribute box has a green fill. I can uncheck it as the admin user, apply, and ok, then if I check the properties it's green again.

The only thing I've done that might affect this is to make the sales user into a limited user. Becoming an admin did not fix the problem. The admin user launches the d/b no problem, the sales user still cannot.

I tried running an 'attrib' command in a terminal window to remove the read-only attribution on the folder after reading an MS support doc but that changed nothing
posted by diode at 3:33 PM on January 28, 2010


That green "read only" box is the same as the greyed-out one -- it's not telling you the status of anything, just giving you a place to reset all files to "read only" in that folder (or clear that flag on all of them at once).

If you've got NTFS and you're not seeing a security tab, you might have "simple file sharing" turned on. In the explorer window where you're looking at this folder:

- Go into the "Tools" menu
- Click on "Folder Options"
- Click on the "View" tab
- Scroll right down to the bottom of the advanced settings list, and remove the checkmark beside simple file sharing
- Click OK

You should get the security tab back, where you can manage folder and file access rights (the Admin user should be able to change these and grant access to other users).
posted by FishBike at 3:48 PM on January 28, 2010


Okay, cool. That's done it.

I went in and gave the sales user full control permissions over the containing folder and now can run the d/b successfully.
Simple sharing was indeed turned on.

Thanks a bunch.
posted by diode at 3:59 PM on January 28, 2010


« Older [Family Vacation Filter] What ...   |  Asking for a friend: I'm int... Newer »
This thread is closed to new comments.