Join 3,433 readers in helping fund MetaFilter (Hide)


How do I connect my home theatre PC to my receiver?
January 7, 2010 2:21 PM   Subscribe

Please help me understand audio configurations. I have an HTPC with Media Center connected to a Denon receiver. The TV and speakers also connect to this receiver. Everything works fine, except for in the rare case when I am playing an .avi file that is encoded with audio in six (6) channels. In this one specifc case, I can hear sound effects, music, but no dialogue. I think I know why, but I don't know what to do about it.

For most of my video files, if you right click on the file, go to properties --> details --> under the "audio" section, "channels" is listed as 2 (stereo). These video files play normally.

Sometimes, "channels" has the value set to "6". For these files, when played in my home theatre setup, I can hear sound effects and music, but no dialogue.

I am connecting the sound card on the computer to the receiver using a 3.5mm-to-RCA (red and white) cable. Does that setup have a max of 2 channels that it can transmit? That would make sense, I guess.

So. What should I do? The sound card, apart from the main "audio out" 3.5mm jack has a few more 3.5mm jacks -- maybe I need to utilize these? However, where do they go on the other end? The receiver only has a red/white audio input RCA jacks. (Which is weird because the receiver has the ability to connect to 7 speakers plus a sub, but it can only input 1 red and 1 white set of connections?)

The other option is to force Media Center (or my codecs, or my computer) to take this 6 channel audio of the .avi file and treat it as 2 channel stereo sound so I get all the sound properly. If I play the exact same .avi file on my laptop with the same set of codecs, the video plays fine. But I don't know how to force it to do that on my Media Center.

Any ideas? Thank you.
posted by omair to Computers & Internet (4 answers total) 1 user marked this as a favorite
 
The dialogue is probably being output to the center channel (that's what it's for), and you only have left and right connected. So that makes sense.

The right solution is to use a digital audio connection between the computer and the receiver, assuming the computer has it (a 7.1 receiver is definitely digital). It would probably be labeled SPDIF on the computer side. My advice is a little vague at this point because this is really dependent on your particular computer and receiver, but there are two types of SPDIF connections: coax and optical. The coax one would look like any of the other RCA jacks, and you can use one line of the red/white cable you are using now. The optical is a little square box that might have a red light pulsing, and you probably don't have the cable to hook that up. If you hook up the one digital audio line, you'll get all 5.1 channels.
posted by smackfu at 2:39 PM on January 7, 2010


Agree that your receiver is likely losing the center channel from the compressed file and only outputting stereo to the left and right channel. I'm guessing that any surround sound media (the avi, DVD w 5.1, etc.) played on your computer will do the same if sent through your current RCA inputs. You really should be using optical/spdif or hdmi connections to your receiver for surround audio. I would be surprised if it doesn't at least support the former. If you lack spdif or hdmi input/output you're either going to need new hardware or you'll have to get your htpc to somehow convert the 5.1 to stereo first.
posted by drpynchon at 4:07 PM on January 7, 2010


Also, media players (and possibly the media itself) should be smart enough to mix itself down to two channels when it only has to channels to work with. Might want to check and see if there isn't a setting that's messed up somewhere.
posted by gjc at 4:18 PM on January 7, 2010


Your receiver might have a "speaker setup" feature that will need to be set, telling the receiver that you are working in stereo only. Try looking in the manual under "speaker arrangement" or something similar. You can then turn off "surrounds," the LFE (sub), and the center channel, leaving L and R.

But the RCAs are containing only the stereo sound information delivered from the software to that particular output. If you've got 3-4 multicolored jacks on your soundcard, you managed to plug into the stereo output. Switching the 3.5-y-adapter to a different output will give you surround, sub, and center-isolated audio. To fix this, you might need to investigate your soundcard or computer settings (You may want to set your computer for "headphones" or "stereo speakers" instead of "surround sound" or "5.1") and then test the outputs. This can be done through the Sounds/Audio Devices in control panel, then going to the Audio tab, selecting "Advanced..." under Sound Playback device, then selecting from the dropdown box.

Another option is to purchase an audio card that has RCA output in stereo.
posted by Khazk at 12:32 AM on January 8, 2010


« Older Air Canada WTF? On Tuesday I t...   |  Designers, can you suggest a s... Newer »
This thread is closed to new comments.