Join 3,556 readers in helping fund MetaFilter (Hide)


Slow typing in Excel 2008 and unexplained network traffic
November 27, 2009 1:06 AM   Subscribe

Why would Excel 2008 cause a lot of network traffic while typing in a cell?

After using Excel 2008 for a few months, recently I've experienced sluggishness when typing in cells. These are really serious slowdowns, the display can take 5 seconds to catch up to my typing. It comes and goes; haven't been able to discern a pattern here.

However I use MenuMeters and during slowdowns, I've noticed that network traffic spikes when I'm typing in Excel - say 150KB down, 33KB up.

I'm not editing a document on a network drive, or even an external drive. Happens whether or not I have any external drives connected.

I'm connected to a local network via wifi, and through that to the Internet - but our external connection tops out around 25KB down.

Any ideas?

Using Excel 2008 SP1 on 10.5.8.
posted by lbergstr to Computers & Internet (10 answers total) 4 users marked this as a favorite
 
Are you on a Mac? It's not very clear from your question, maybe you should point it out.

Your problem sounds really weird, my first guess would be a horribly implemented keylogger, but it sounds unlikely. You need to find a reproducible scenario, otherwise you'll never be able to figure out what is happening. Two things you could try out to further debug this are to disconnect your wifi and see if the problem goes away, and use your firewall logs or a packet sniffer to figure out who your computer is talking to when you're typing.
posted by Dr Dracator at 3:37 AM on November 27, 2009


The last line says Mac - Leopard.
posted by megatherium at 5:06 AM on November 27, 2009


the network traffic might just be a coinc-y dink, it just sounds weird. i assume the problem is gone or reduced when you turn off airport?

excel is a notorious resource hog, so maybe there's a nasty memory-eating process running that's contributing to the lag. did you install anything around the time this started happening? if so (or in any case), check login items in accounts within system preferences to make sure you're happy with what starts up automatically. perhaps download onyx and give your system a little tune-up if you don't already do that.

do you by any chance have an hp printer on your network? i know there are issues with certain hp drivers/mac excel for snow leopard, maybe 10.5.8 as well...

good luck, and let us know what happens!
posted by xiaolongbao at 5:18 AM on November 27, 2009


You could try using a packet sniffer like Wireshark. Shut down everything else that uses your network card, start the Wireshark capture, then type in Excel, and see what pops up.
posted by Salvor Hardin at 5:43 AM on November 27, 2009


I don't know what's going on here, but here's how I'd debug it. If you want to see what programs are currently using the network, run the following command in a Terminal window:
sudo lsof -i +c 0
That will give you a list of open network connections, though if the app in question isn't keep a connection open, you might have to time things just right to see it. You can run lsof in a loop using the -r switch, for instance every two seconds:
sudo lsof -i +c 0 -r 2
Another approach is just to watch all network activity and see what apps show up when. For this, use fs_usage:
sudo fs_usage -f network
You can leave that running in the background while you use Excel or whatever, and hit Control+C when you're done (or just close the Terminal window). You can also narrow it down to just Excel by specifying the Process ID (look it up using Activity Monitor). So if Excel's pid is say 212, run:
sudo fs_usage -f network 212

posted by serathen at 5:46 AM on November 27, 2009 [2 favorites]


You could install the demo for Little Snitch, which will tell you precisely which outbound connection is occurring when you edit a cell in Excel. It's possible that it's not Excel but some other process. Little Snitch will tell you.

I'm very curious about what you find. I've never seen or heard of MSO 2008 behaving this way.
posted by mrbarrett.com at 6:02 AM on November 27, 2009 [1 favorite]


I would investigate whether you have the cause and effect backwards- maybe a burst of high network usage is causing Excel to slow down?
posted by gjc at 8:12 AM on November 27, 2009 [1 favorite]


gjc's comment reminds me that a friend has similar inexplicable slowdowns from time to time. Turns out it was a virus scanner (required by her school) which would wake up periodically and decide to scan the whole disk, probably after downloading updated patterns. This would bring the machine to a crawl.
posted by hattifattener at 1:05 PM on November 27, 2009


Ok, problem seems to be solved. I tried serathen's fs_usage tip (very cool!) but oddly, I couldn't see additional network activity that way. Turns out that's because the extra activity was considered filesystem activity - Excel was hitting our network share. MenuMeters just saw stuff going over the Airport card and, reasonably, considered it network traffic.

Unmount my network share. Typing no longer slow, no more network/filesystem activity. Re-mount network share and the problem comes back.

Thanks everyone.
posted by lbergstr at 2:38 AM on November 29, 2009


And Google says there's another way to avoid the problem: go to Preferences / General and uncheck "Show this number of recent documents". Not sure which solution is more annoying, to be honest.
posted by lbergstr at 2:40 AM on November 29, 2009


« Older Can anyone please help me reme...   |  How can I make periodic, space... Newer »
This thread is closed to new comments.