Join 3,561 readers in helping fund MetaFilter (Hide)


External USB drive, Linux machine, POST/mount woes!
November 21, 2009 11:11 AM   Subscribe

Please hope me: my Linux machine cannot boot when my external drive is connected: it can't get past POST tests when USB legacy is enabled, but it also can't mount the drive when USB legacy is _not_ enabled. :(

So if USB legacy is enabled and external drive is connected, the machine sits at pre-POST testing forever. It won't get past it. If USB legacy is turned off, it boots, but Linux (ubuntu 9) cannot mount the drive. So what I have to do is keep USB legacy off, and when the machine boots, unplug/replug the drive- then run mount manually.

This situation sucks cos the external drive is my backup. I don't want the machine to boot w/o it connected, and don't want to have to manually intervene.

Is this more an issue w/ the machine, or the drive? It's a Buffalo 1TB external USB drive - this dude.

Any tips? Thanks!
posted by xmutex to Computers & Internet (12 answers total) 1 user marked this as a favorite
 
Is your BIOS trying to boot from the USB drive? Check your drive boot order, make sure the USB drive isn't set as a bootable device.
posted by AzraelBrown at 11:13 AM on November 21, 2009


Seconding AzraelBrown's advice. Also have a look if there's a BIOS update available for your motherboard.
posted by krilli at 11:47 AM on November 21, 2009


I "solved" a similar issue with USB ALSA MIDI devices becoming the "default sound card" for poorly written apps that just try to open the first ALSA card without even checking if it handles audio, by waiting until the machine is partially booted before plugging the MIDI devices in. Plugging in the external HD after booting has started but before the filesystems in /etc/fstab are mounted should work fine (you have the device listed in /etc/fstab, right?).
posted by idiopath at 1:04 PM on November 21, 2009


As I think about this, I see the smarts in AzraelBrown's deduction more clearly. Cat can play.

Just to add some how-to tips to it: A very quick and easy way to test it is to enter the BIOS boot volume selector, usually it's on F12 at bootup. If the USB thing is at the top there, try selecting the primary hard disk instead and boot. If this works, you'll just have to find the boot ordering menu in the BIOS and change it and problem solved.
posted by krilli at 1:39 PM on November 21, 2009


This isn't as likely as AzraelBrown's suggestion, but it is possible.

Have you permanently mounted the external to a specific location? That might solve your problem. I have a similar problem with Ubuntu. When I boot my computer with an external it mounts my hard drives in different locations than normal.
posted by thekiltedwonder at 2:50 PM on November 21, 2009


thekiltedwonder: "This isn't as likely as AzraelBrown's suggestion, but it is possible.

Have you permanently mounted the external to a specific location? That might solve your problem. I have a similar problem with Ubuntu. When I boot my computer with an external it mounts my hard drives in different locations than normal.
"

On the contrary, it is much more likely. The bios would skip the drive if it was the first in boot order but was not bootable, and just move to the next device to check if it was bootable.

Yeah, this almost definitely the issue - in your fstab, try specifying not /dev/sda /dev/sdb or /dev/hda or /dev/hdb or whatever, but rather by uuid. This is exactly analogous to the sound card issue I was having - the drives are given devices in the order they are detected, and USB is always detected first. Sadly, this does not help my situation, as sound cards do not have anything like a uuid.
posted by idiopath at 2:57 PM on November 21, 2009


No suggestions here but I have a very similar problem with my Ubuntu fileserver (MSI 865PE Neo2 mobo) and a WD external drive. With the drive connected, the machine won't boot past the initial BIOS screen, and I've tried every possible permutation of the BIOS USB settings (one difference here: mine won't boot regardless of the "Legacy USB" option) and quintuple-checked that it's not set up to boot from USB ever. I spent hours trying to diagnose it when I first got the drive, found a few forum posts where people seemed to be having the same issue but nothing with a resolution. Eventually I just gave up and have been living with the situation, which isn't terrible in my case since the machine is very rarely shut down.

In my case, at least, the OS never seems to enter the picture, the system locks up right after the memory test. I don't want to hijack your question, xmutex, but does all this sound familiar? Maybe we can compare notes and figure out what our systems have in common that might be causing this issue, if in fact it is the same thing.
posted by contraption at 3:10 PM on November 21, 2009


Check your grub config in /boot/grub/grub.list

Does grub check for a particular device number (hd 0,0)?
Or but uuid?

grub is the first thing that should load after the bios post check runs, if you are not getting a grub menu, your problem is likely in grub.

Sadly, it looks like uuid in grub is not mainstream yet (ie. not present in the ubuntu version of grub, at the very least).
posted by idiopath at 3:24 PM on November 21, 2009


Also, posting faster than I am thinking here :)

Try editing /boot/grub/menu.list and making a duplicate entry to your default boot, but changing (hd 0,.0) to (hd 1,0)
posted by idiopath at 3:27 PM on November 21, 2009


I have a similar problem on my computer with an ASUS M2N4-SLI motherboard when my cell phone (Android device) is plugged in. It has nothing to do with grub, as it never even makes it through the BIOS boot screen. It freezes the BIOS even before the memory check. In fact, I just did a test, and it will freeze the bios even in the setup menu if you wait until then to plug it in. Strangely, it works fine with my regular external drive.

Sadly, I haven't figure out what causes the problem. I just have to remember not to boot with my cell phone plugged into the machine.
posted by dirigibleman at 6:21 AM on November 22, 2009


dirigibleman, that's pretty interesting. Have you btw checked to see if there's a BIOS update? Sounds like a motherboard firmware bug.
posted by krilli at 7:56 AM on November 22, 2009


Yeah, it's running the latest firmware.
posted by dirigibleman at 8:47 AM on November 22, 2009


« Older Suggestions for places to stay...   |  I'm looking for recommendation... Newer »
This thread is closed to new comments.