Skip

Why can't I access my self-hosted site anymore?
October 18, 2009 10:16 PM   Subscribe

Switched ISPs and now not able to access my own websites which I host myself by TLD.

Before I switched ISPs I was able to type in the TLD of my website to view it, eg: ki6ils.com. Now I am not able to. I have to go into the server properties and tell it to accept connections on the internal IP address and wait for the service to restart and call it by 192.168.0.2. That makes it hard when I want to update more than one site.

How can I get it working again to go to www.ki6ils.com and actually see that site, or any other site I want to work on? What changed to cause this to happen?

Oh, I updated the domain name with the new IP address.
posted by KI6ILS to Computers & Internet (13 answers total)
 
It takes a while (usually no more than 72 hours) for DNS changes to finish propagating to all the caches of all the DNS servers in the world. How long ago did you update your DNS info? It's likely that your new ISP's DNS server simply hasn't seen the new A record yet.
posted by flabdablet at 10:26 PM on October 18, 2009


The change was made back in July. The sites are up and running. I can view it on my cell phone. As long as I am outside of my own network, where the sites are hosted, I can view them.
posted by KI6ILS at 10:50 PM on October 18, 2009


What OS is running on the computer(s) you're unable to connect from?

Is the site hosted on that same computer, or on another one inside your network?

When I do nslookup ki6ils.com I get 99.36.113.200 - what do you get?
posted by flabdablet at 12:04 AM on October 19, 2009


Did this switch involve a new router? Whats probably happening is that you are trying to visit 99.36.113.200 and the router sends it off to the gateway, which just sends it back, which just ends up confusing your router. Some routers understand what is going on and allow this. I bet whatever equipment they have given you doesnt understand what to do.

You can use your hosts file to tell it to vist the 192.x.x.x address as a workaround.
posted by damn dirty ape at 1:07 AM on October 19, 2009


Sounds like the ape has it. If it only affect you locally, a HOSTS hack will be fine.

As an aside, ki6ils.com is not a TLD. The TLD is com. www.ki6ils.com is not a TLD either - again, the TLD is com, ki6ils is a subdomain of com and www is a subdomain of ki6ils.com.
posted by turkeyphant at 2:51 AM on October 19, 2009


I am running Windows Server 2003 to host the sites. All the other computers are OSX.

They did switch my router. It was a cable modem going into a Linksys router but the new ISP uses a 2-Wire router gateway thing.

If I do end up using host files does that mean I will have to set one up on every computer?
posted by KI6ILS at 5:15 PM on October 19, 2009


Well I just tried the hosts file and no joy. But not sure if I did it correctly.

##
# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting. Do not change this entry.
##
127.0.0.1 localhost
255.255.255.255 broadcasthost
::1 localhost
fe80::1%lo0 localhost
ki6ils.com 192.168.0.106
www.ki6ils.com 192.168.0.106
posted by KI6ILS at 5:56 PM on October 19, 2009


The ki6ils.com entries are the wrong way around - should be IP address first, domain name second.
posted by flabdablet at 5:59 PM on October 19, 2009


By the way: if your new router didn't completely suck, this would Just Work without needing hosts file hackery. Do you still have the Linksys? Because it ought to be possible to turn off the 2-Wire's routing brains and operate it as a straight modem, put your PPPoE settings inside the Linksys instead of the 2-Wire, and let the Linksys do the routing the same way it did before the ISP cutover.
posted by flabdablet at 6:03 PM on October 19, 2009


Weird. I corrected it and now I am getting Bad Host Name.
posted by KI6ILS at 6:03 PM on October 19, 2009


If I do end up using host files does that mean I will have to set one up on every computer?

Yeah. It's a pain. Your other option is to set up your own DNS server somewhere on your LAN, make it authoritative for all your ki6ils.com addresses, make it forward queries for all other addresses to your ISP-provided DNS server, and make your router's DHCP server hand out your own local DNS server's IP instead of the ISP-provided one. That way, hosts inside your LAN will get LAN addresses for the ki6ils.com domains without you having to fool with their hosts files, while hosts outside your LAN (which can't see your local DNS server) will get the public IP address instead.

You can use the same box to run your DNS server as you use to host your websites; Windows 2003 DNS server setup is fairly painless. While you're at it, you may as well make the Windows 2003 box do DHCP as well, and turn it off in your router. That way, you can make Windows create DNS entries for all your LAN machines automagically as they acquire their DHCP addresses. Post back here for instructions if you can't make sense of the Windows 2003 help stuff.
posted by flabdablet at 6:13 PM on October 19, 2009


Try combining both host names for 192.168.0.106 onto a single line, like this:

##
# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting. Do not change this entry.
##
127.0.0.1 localhost
255.255.255.255 broadcasthost
::1 localhost
fe80::1%lo0 localhost
192.168.0.106 ki6ils.com www.ki6ils.com

posted by flabdablet at 6:16 PM on October 19, 2009


Thank you flabdablet. That was painless and got all my computers and STBs pointing to my server for DNS. Also acting as DHCP server.

Now I can finally update my blog.
posted by KI6ILS at 9:14 PM on October 19, 2009


« Older Any engineers or physicists wh...   |  I'm married and we want to liv... Newer »
This thread is closed to new comments.


Post