Join 3,494 readers in helping fund MetaFilter (Hide)


Help my Mac Mini work with my TV!
September 23, 2009 6:16 PM   Subscribe

Mac Mini filter: when using a Mini like an AppleTV, it makes the TV screen flicker horizontally. When we switch it to a regular monitor, it is fine. Any ideas on how to fix this?

I will give as much technical information as I can. We have a 2005 Mini (no Intel). It has the Leopard OS on it; when we hooked it up to the TV, it worked great! (old tv-had to get the cable with yellow, red, and white outputs, etc.). We were able to see everything, view hulu, it was awesome. My better half thought we could change the screen resolution for a better picture. After we did that, the picture turned to B/W, and flickers horizontally. We have tried every other resolution, unplugging/replugging, turn off/on, and the TV remains the same. The computer monitor is fine, the TV isn't. Can anyone help? Thanks in advance-
posted by Mrs. Green to Computers & Internet (9 answers total)
 
Sounds like a CRT television, not a flatscreen one, right?

They really can't handle much resolution, or hold it for long: 800 x 600 is probably the highest you should shoot for. I manage to use 1024 x 768 on an old 30" CRT, but even then I wouldn't try to read much text: it works well for Front Row and movies and such. To make sure this is right, set the Mac all the way down to, say, 640x480, restart it so it's ALWAYS in that resolution, and then reconnect to TV and try again.

Dropping to black and white is also a common bug with some s-video cables (the all-in-one yellow version with five pins in a circle), where two pins aren't connecting properly. I have not heard of that with RCA cables (the single yellow nipple for video) but maybe it's possible. Can you try another cable?
posted by rokusan at 6:22 PM on September 23, 2009


Sounds like the TV out is putting out a PAL signal instead of NTSC. I'm not sure how to get the Mac to put out NTSC again, though.
posted by zsazsa at 6:32 PM on September 23, 2009


Oh, totally could be a PAL signal, good thought.

Reset the Mac's PRAM when connected to a monitor (not the TV) as well as setting the resolution low and restarting. If you can have both the monitor and TV connected at the same time, you can change the PAL-NTSC and refresh settings while looking at the (good) monitor.
posted by rokusan at 6:59 PM on September 23, 2009


The mac is trying to put out svideo on a composite line. Uncheck svideo.

Or vice versa.
posted by gjc at 7:12 PM on September 23, 2009


This forum

AVS Mac Home Theater

has lots of people who use MacMinis for their home theater.

Notice the sticky called "SwitchRes X Tutorial" about an app which might solve your problem.
posted by conrad53 at 7:42 PM on September 23, 2009


I did the same exact thing when I first hooked up my Mac Mini to my TV. I changed the resolution and it made everything all crazy. Since I couldn't see what I was doing on the screen (because it was all flickery) I couldn't set it back. Like you, I hooked it up to a monitor where it worked fine, but the damn Mac Mini seems to know what it is hooked up to, monitor-wise ... so even though I changed the settings from the monitor, they reverted back to the unwatchable settings once it got hooked to the TV.

I'm no expert on this stuff so my solution was probably a lot more complicated then what someone else will possibly eventually come up with below mine. I have a laptop as well, so when I hooked it up to the monitor where I could see what I was doing I enabled the Mini for remote screen sharing (I don't have it all in front of me right now so I can't really give you a step-by-step). Once this was enabled I hooked the Mini back to the TV. Then, from the laptop, I accessed the Mini via the network and started screen sharing so I could remotely control the Mini from my laptop (what you should be seeing on the TV screen, if it wasn't going crazy, is now on your laptop). At this point, from the laptop, I changed the resolution back in the Mini and all was solved.

It's late here and I'm work fatigued, so my apologies if I explained this in a way that makes no sense. i'll check back here later if you need me to elaborate on anything (of course, if you don't have another Mac to do screen sharing with then this method isn't possible for you).
posted by General Zubon at 8:26 PM on September 23, 2009


These are all awesome suggestions! I have two little ones so I can't try these out now, but will try them later. Thanks again!
posted by Mrs. Green at 6:55 AM on September 24, 2009


If your tv is a tube, it's likely Standard Definition.

Switch it to 640x480, 60hz and it'll be rock solid.

If it's a HD tv, you have to find a match for what the video card is outputting, and your set.
posted by filmgeek at 8:34 AM on September 24, 2009


rokusan & filmgeek: Our TV isn't a flat screen, nor is it HD. We don't have another cable, so we will lower the resolution and see what happens.

conrad53: I will check out that forum.

General Zubon: We have another monitor that we use with our new mini, but we were hooking it up to the mini to check the resolution and then unhooking the mini and hooking it up to the TV. We haven't ever done remote screen sharing, but we will try that.

Unfortunately, we tried to delete some information off the old mini and locked it up so we will have to try all this stuff tomorrow. Thank you again for your help!
posted by Mrs. Green at 6:19 PM on September 24, 2009


« Older Is He Just Not That Into Me: P...   |  How can I transition from a pu... Newer »
This thread is closed to new comments.