Join 3,427 readers in helping fund MetaFilter (Hide)


Help me help my browser to go back to completing missing URL endings even though my ISP is jerky
June 5, 2009 7:39 AM   Subscribe

My ISP's new "feature" of rerouting incomplete URLs to their own custom (awful) search page is hijacking my normal browser behavior of completing URLs with .com. Anything I can do to reassert normalcy?

My ISP is T-Online, which like a few other ISPs has started to hijack malformed URLs and send me to an awful "did you mean...?" page, which coincidentally happens to contain advertisements.

Until this started happening a week ago, if I typed "something" into my Safari 3.2.1 (OS X 10.5.x) location field, Safari would complete the URL as "something.com" and go there, but no longer (at least, I was under the impression that this was a Safari thing and not a DNS thing, since Internet Explorer always manifested the re-route-to-a-search-page behavior).

T-Online claims that it is possible to opt out from their new "Navigationshilfe" ("Navigation Help") program, but when I followed their instructions to opt out, nothing changed. Is there a technical solution for this? My router runs dd-wrt so if there is anything I can do there or on my local machine with DNS or hosts settings, that would be ideal.

T-Online's customer support is pretty dumb, so I will consider calling them if there is no workaround, but it is improbable that they will a) know what I'm talking about, b) know if it is possible to turn it off, c) take the correct steps to turn it off, d) not somehow find a way to increase the cost of my plan in the process, so that is definitely a last resort.

Thanks for any advice!
posted by Your Time Machine Sucks to Computers & Internet (14 answers total) 8 users marked this as a favorite
 
Change your DNS servers in your router. Start with 4.2.2.2 -- if that solves the problem, find a closer DNS server (OpenDNS?) that works well for you.

The forwarding usually works via DNS.. so disabling T-Online's DNS servers (or atleast not using them) will fix the issue.

Since your machine is told about DNS through the router; changing them in the router will fix it for all.
posted by SirStan at 7:48 AM on June 5, 2009


" Is there a technical solution for this?"

Yes. Don't use your ISP's DNS servers. Pick something else.

If your router is configured for dnsmasq and that's what the attached clients use, you'll want to change the DNS server values it uses. Otherwise you'll want to change the configuration on the clients directly or change the value that is handed out by your DHCP server.
posted by majick at 7:48 AM on June 5, 2009


Your router is reponsible for telling your computer what DNS server(s) to use when the computer asks for stuff via DHCP. I don't know DD-WRT well enough to know whether it can run a proper DNS server inside itself; if it can, turn that on, tell it to hand out its own address as the DNS server via DHCP, and have it use 4.2.2.1 and 4.2.2.2 as its upstream forwarders instead of whatever crap your ISP is handing you. If the router can't be a DNS server, just have it hand 4.2.2.1 and 4.2.2.2 to its DHCP clients.
posted by flabdablet at 7:50 AM on June 5, 2009 [1 favorite]


Also, I realize that the simplest workaround is to type the full URL, but I'm working against about a decade's worth of muscle memory here, so it would be great to find an actual fix.
posted by Your Time Machine Sucks at 7:54 AM on June 5, 2009


When my ISP implemented the same service foolishness, I ended up installing a DNS server on my laptop, to provide my own DNS service from now on. In my case it was because it broke my VPN connectivity, which relies on DNS lookups for private host names failing, and thanks to their advertising engine, these were all successful instead.

Safari probably does a similar thing, e.g. tries to look up the exact name you typed first, and if that doesn't work, try appending .com, .net, and so on until it finds one that does. And now that your ISP makes every lookup "work", it can no longer detect that the first thing you typed isn't a valid name.

I'm sure there is a free DNS server you can install on OS X, and then you just modify your network settings to tell it to use 'localhost' or equivalent as the DNS server, instead of your ISP's DNS servers. I know little about OS X though, so I couldn't tell you how. But as long as your ISP hasn't actually tried to block DNS requests to servers other than their own, this should work.
posted by FishBike at 7:54 AM on June 5, 2009


Awesome, thanks for such fast and good answers, folks. Opening up the router config right now and will report back.
posted by Your Time Machine Sucks at 7:55 AM on June 5, 2009


You should also notify your ISP of their anti-customer stupidity.
posted by nathan_teske at 8:07 AM on June 5, 2009


No specific fix, but just chiming in that I'm with Charter, and they do the same thing. Even after I opt-out, they still manage to hijack and display the old IE "server not found" error when I get a bad URL. And I use OpenDNS on my dd-wrt router.
posted by jmd82 at 8:17 AM on June 5, 2009


OpenDNS. OpenDNS. OpenDNS.
posted by jaythebull at 8:20 AM on June 5, 2009


Non-technical, but something simple that I've used for years:

I assume you're typing something like "google" in the address box, then pressing enter and hoping for http://www.google.com/. In most modern browsers, Firefox and Safari included, if you type "google" and press Control + Enter, it will form the "http://www." and ".com" parts of the address, then send you to the correct address. On a Mac, I believe the command key does the same thing.
posted by uaudio at 8:54 AM on June 5, 2009


OpenDNS in the router config did the trick! Thank you all, much happier now.

Addendum for other folks prone to the same mistake I made: after changing the DNS server in the router, it may still be necessary to reboot the local machine or enter whatever the command is for a network reboot on your system in order to get the local machine to stop caching the old DNS server IP address and confusing the hell out of you.
posted by Your Time Machine Sucks at 9:02 AM on June 5, 2009


OpenDNS. OpenDNS. OpenDNS.

OpenDNS does the same thing, though.
posted by odinsdream at 9:07 AM on June 5, 2009 [1 favorite]


OpenDNS is fixing the issue mentioned in the question.
posted by Your Time Machine Sucks at 9:17 AM on June 5, 2009


OpenDNS is great, we use it at work and love it. While it technically does sort of the same thing your ISP did to you (in that all DNS lookups now succeed, even ones that "shouldn't"), they try to be more helpful than just redirecting you to an advertising page in all cases. If their system can figure out where you were trying to go, then you'll still end up there. Otherwise you'll get an advertising-supported search page. If you set up an account, you can even exclude certain domains (which are supposed to fail) so that VPN stuff works correctly again.

So you're getting the same functionality (actually better -- OpenDNS seems to do a better job of correcting things than browsers do), just implemented in a different place. Folks who didn't suggest OpenDNS (well, me, anyway) may just have interpreted the part of the question that said "Anything I can do to reassert normalcy?" to mean "How do I make this browser feature work exactly like it used to?"
posted by FishBike at 10:22 AM on June 5, 2009


« Older How can I use non-breaking 2-e...   |  Attraction detection: what mak... Newer »
This thread is closed to new comments.