Help! My CD-ROM device and (apparently) drivers have disappeared
November 23, 2004 8:17 PM   Subscribe

Help! My CD-ROM device and (apparently) drivers have disappeared. Caveat: I'm running Red Hat 9.

The /dev/cdrom virtual device is gone. I believe it pointed to /dev/hdb (or possibly /dev/scd0), but I can't mount those either -- mount tells me 'not a block device.' kudzu -p reveals the following:

-
class: OTHER
bus: IDE
detached: 0
device: hdc
driver: ignore
desc: "UJLá74x¡DVL¯CDZ÷ h¡ h¡ h¡ h¡ h¡ h¡"
-


...which I believe might be the drive. But obviously something's gotten majorly fucked up. The only thing I can think of which might have caused this was trying to play a DVD which MPlayer couldn't read. I tried several times and finally the OS crashed and I had to reboot.

This is on a Toshiba Satellite 1130 or 1135 (don't know for sure). I have no idea what kind of chipset the drive is running.

I would try re-installing Red Hat, or upgrading to Fedora, which I've been meaning to do anyway, but I can't burn the necessary CDs.
posted by IshmaelGraves to Computers & Internet (10 answers total)
 
The output of 'dmesg' may give you more information.
posted by Galvatron at 9:11 PM on November 23, 2004


Galvatron, I get the same nonsense string:

hdc: UJLá74x¡DVL¯CDZ÷ h¡ h¡ h¡ h¡ h¡ h¡, ATAPI UNKNOWN (type 13) drive
posted by IshmaelGraves at 9:21 PM on November 23, 2004


And before you delve too far into driver debugging, consider the possibility that you just have a poor connection to the drive. Maybe you can eject the drive and reseat it?
posted by Galvatron at 9:23 PM on November 23, 2004


Your CD-ROM drive is /dev/hdc. 'dmesg | grep hdc' (that's a pipe symbol, shift-\) will tell you specific info about the drive. However, the fact that kudzu put gibberish where it says "desc" is not promising. It should be at least intelligable - usually, you can see the model number and sometimes the make of the drive. (Mine says "SAMSUNG DVD-ROM SD-616T".) Usually, when you get that, the drive or the IDE controller it's hooked to is having problems. Your best bet would be to replace the drive. Use froogle to search for slimline dvd or whatever it was you had - you can probably replace it with a combo drive for about $70. You will need to do a little bit of surgery - the drive you have probably fits into a caddy with a special front panel and a board at the end. I would recommend buying a similar make drive if you go that route, since sometimes the little hooks and such that make the faceplate snap onto the front of the drive won't match up if it's a different make drive.

I would fault the cable if it weren't a laptop. Hopefully, it's not the IDE controller on the board, in which case you're pretty well hosed.

On preview, Galvatron has a good suggestion.
posted by mrg at 9:24 PM on November 23, 2004


Yeah, it sounds like a hardware problem to me. The device description ought to at least mention something like "ATAPI CD/DVD-ROM drive".
posted by Galvatron at 9:26 PM on November 23, 2004


FWIW, the surgery I mentioned is pretty easy if you havta do it.. I've done it with laptops as old as a Toshiba P90 and a Dell Latitude LM (P133, about 6/7-yo at the time) and as new as a pretty much brand-new Thinkpad R41 and Latitude D600 and the basic method (eject tray, remove drive, replace drive w/ board if there is one, and then transplant faceplate) was the same for all of 'em.
posted by mrg at 9:40 PM on November 23, 2004


Boot into your BIOS and look where the drive is connected.

IDE0 - Master = /dev/hda
IDE0 - Slave = /dev/hdb
IDE1 - Master = /dev/hdc
IDE2 - Slave = /dev/hdd

(Also, if you have a hard drive with multiple partitions, say /dev/hda , you'll see those as /dev/hda0, /dev/hda1, etc.)

Then try to see if you can boot from a CDROM (any bootable CDROM will do). If you can, the drive is probably in working order.

Next, try setting the drive in the BIOS to CDROM (instead of auto-detect). This can cause problems sometimes, although its rare with newer BIOSes.

If everything appears fine with the drive/BIOS, next take a look at your fstab. (probably /etc/fstab).

Look for a line that looks like either one of these:

/dev/cdrom /mountpoint/cdrom auto ro,auto,user,exec 0 0

/dev/hdc /mountpoint/cdrom auto ro,auto,user,exec 0 0


If it points to hdb, but your BIOS thinks its the MASTER onthe secondary IDE controller, then just make the appropriate change.

If the section "ro,auto,user,exec" doesn't say auto (says noauto) then it will not automatically mount this device on bootup. Its possible that this file was overwritten, causing your problems.

Check these out, and let us know what's happening.
posted by stovenator at 10:04 PM on November 23, 2004


Thanks for the quick responses, everyone. The suggestion that it was a hardware problem led me to reboot into Windows, where the drive worked fine, and then, voila, I rebooted back into Linux and it's working again.

I swear I tried rebooting, to no effect, before posting this question -- though not into Windows. Perhaps XP was able to re-initialize something in an EEPROM somewhere? Or maybe I should just blame cosmic rays.
posted by IshmaelGraves at 10:08 PM on November 23, 2004


Cosmic rays, definitely.
posted by Galvatron at 10:12 PM on November 23, 2004


The techie answer might be that mplayer just confused the hell out of the drive.. not as fun as cosmic rays though.
posted by mrg at 7:48 AM on November 24, 2004


« Older Removing cloudy film from pots and pans?   |   Sisal Rug Maintenance Newer »
This thread is closed to new comments.