Join 3,438 readers in helping fund MetaFilter (Hide)


Help me get the Wordpress audio player plugin to work? Please?
March 23, 2009 8:19 AM   Subscribe

I'm having trouble implementing the Wordpress audio player plugin on my website. Please help a baffled man.

I've installed the Wordpress audio player plugin on my website, but for the life of me I can't figure out what I'm doing wrong -- it's not showing up on the page.

I'm writing the page using the "html" setting on the wordpress control panel, and I'm following the instructions listed under "usage" in the 1pixelout link above. The file I'm trying to play is definitely in the folder I'm directing the player to (I'm hosted, it's not just a WP blog); I can link to it conventionally (as in, without the player).

The only change I made was to change the audio files directory path from "/audio" to "/uploads." I've even tried checking the box (in the audio player controls on my WP control panel) that replaces all links to mp3 files with a player instance. Didn't work.

Can someone help me out here? I have a feeling there's some extremely minor thing I'm doing wrong, so don't think I'm too foolish. Thanks.
posted by hifiparasol to Computers & Internet (11 answers total) 1 user marked this as a favorite
 
If you can link to it "conventionally," try using that full URL in the code:

[audio:http://www.yourdomain.com/path/to/name_of_mp3_file.mp3]

Also, you might try another browser or another computer to make sure it's not a flash issue on the box you are testing it out on.

If it's not a flash issue, maybe it's not installed correctly?
posted by Otis at 8:41 AM on March 23, 2009


[audio:http://www.yourdomain.com/path/to/name_of_mp3_file.mp3]

My problem might be more basic than this; it might be a problem with my knowledge of html.

I've tried what you suggest and I've tried the conventional way. My problem is that the code snippet, as used above, keeps showing up as-is on the final page. Like, with the square brackets and everything.
posted by hifiparasol at 8:56 AM on March 23, 2009


if you're posting using the basic editor (not the visual editor), and you have it set to replace the [audio] syntax, it should work. If it still doesn't, we'll need some more info.
posted by daboo at 9:45 AM on March 23, 2009


you have it set to replace the [audio] syntax

I don't really know what you mean here. Sometimes talking to me like I'm a four-year-old helps.
posted by hifiparasol at 9:59 AM on March 23, 2009


Oh yeah, I dimly remember that this plugin is finickey and some minor thing may cause your player not to show up. I wish I could remember what it was. File type?
posted by Kirklander at 10:19 AM on March 23, 2009


There are two kind of editors in Wordpress. Standard is a WYSIWYG one, also named 'visual rich', in which you see directly how your post will look on the weblog. The problem with the visual rich editor is that you can't add code to your text, since everything is text for this, whereas you want to add code to your text to call the audio player.

There are two answers to this. It is possible to toggle the visual editor for the basic code editor. In the upper right corner of the text field on the 'add new post'-page you see HTML mentioned next to visual. So click HTML, and than add the code.

You could change your choice of editor in your profile [under users], as well.
posted by ijsbrand at 10:25 AM on March 23, 2009


Thanks, ljsbrand. I found this, which worked like a charm, but I have a feeling it may be unpredictable.

I've been working in the HTML editor -- I know enough HTML to order lunch, but I'm not a designer, you know? I've finally figured out what I'm doing wrong that's making the naked code show up on the page, but now I'm not getting anything at all. Right now I'm using this bit of code:

[audio:http://hifiparasol.com/wp-content/uploads/three_hours_in_la.mp3]

Which isn't giving results. Is there more code I need to be using? Something I'm not putting in there that I should be?

Kirklander, the player is limited to .mp3 files, but that's no problem for me.
posted by hifiparasol at 10:35 AM on March 23, 2009


Also: Checking the source for the page, I notice that the code for the player definitely IS in there -- so there must be something somewhere holding it up.
posted by hifiparasol at 10:40 AM on March 23, 2009


I remember, from several years ago, one needed a javascript to call a flash file, like an audio or video player, to show up in Wordpress.

I reckon the plugins used today come with such a javascript, or know how to call it correctly. Yet, you may not have it on your server, or may need a line to call this script in the header of your page template.

But, this is clutching at straws.
posted by ijsbrand at 11:56 AM on March 23, 2009


the js is on his site. What I was referring to earlier as '[audio] syntax' can be found on the options page, a little above where you set the directory.
I couldn't find where on your site you are testing the plugin - is it where you have the google players now?
posted by daboo at 1:28 PM on March 23, 2009


Yeah, no worries -- thanks for the help. I hit so many walls that I gave up on that specific player. Found a better one.

(daboo, for the time being I'm sticking with the Google players. Thanks. And yeah, that was the right page. Cheers.)
posted by hifiparasol at 2:22 PM on March 23, 2009


« Older How soon to travel after major...   |  What is the best light OS for ... Newer »
This thread is closed to new comments.