Mac/Windows file copying through RDC: FAIL
February 26, 2009 9:07 PM   Subscribe

Copy-pasting isn't working between my Mac and a remote Windows machine through RDC. Help?

So I have RDC on my Mac Leopard, connecting to a remote Windows XP Pro machine. I've followed the instructions here to enable copy-pasting files from my Mac to the Windows machine, choosing my Documents folder.

All said and done, I connected to the Windows machine, and.... I don't see my Documents folder. Not anywhere in Windows Explorer.

Am I missing something? Google is returning results on how to enable file sharing, which is NOT what I'm looking for. Supposedly RDC can do copy-pasting of files without going through the whole file-sharing setup
posted by curagea to Computers & Internet (8 answers total) 1 user marked this as a favorite
 
I think you are missing something. The article you've linked to simply instructs you to use file-sharing. I am unaware of any method to drag files through RDC.
posted by pompomtom at 9:25 PM on February 26, 2009


You cannot drag a file from the Mac to the Windows-based computer.

That's from your own link.
posted by tiamat at 10:10 PM on February 26, 2009


Poster never mentioned dragging files, the problem is that he/she cannot see the Mac folder when connected through RDC. Assuming you are looking in the right place (My Computer, where all the other drives show up), try sharing another folder or disk.
posted by sophist at 11:57 PM on February 26, 2009


Umm.. from your link:

Step 1: Make a Mac disk or folder available to the Windows-based computer

That is the same thing as turning on file sharing.

What you can do is take advantage of the fact that Windows automatically creates hidden shares (that require admin access). On your Mac, connect to smb://windowsbox/c$ (or whatever drive letter) and authenticate as an admin user.
posted by wongcorgi at 12:04 AM on February 27, 2009


Nevermind, I didn't click thru. When you enable disk sharing thru the RDC client, you'll see the shared volume/folder when you click My Computer on the windows machine.
posted by wongcorgi at 12:12 AM on February 27, 2009


Hmm. When I RDC to a Windows Server 2003 box from my Leopard laptop, the Leopard HD mounts and shows up in Windows Explorer; I can copy-paste files inside of Windows Explorer just fine. Sadly, I can't tell you what fancy configurations I did to be able to do this; it just worked out of the box.
posted by COBRA! at 7:14 AM on February 27, 2009


All said and done, I connected to the Windows machine, and.... I don't see my Documents folder. Not anywhere in Windows Explorer.Look in My Network Places for the shared folder. Map it to a drive letter and it should show up as a device in Explorer. Do your file dragging on the Windows side. It might be necessary to refresh Explorer's view from time to time (F5) if you're making changes from the Mac side and Explorer doesn't notice them.
posted by TruncatedTiller at 11:22 AM on February 27, 2009


Not anywhere in My Computer or My Network Places; I've already looked in those places. Do I actually have to share a folder on the Windows machine? As it stands, file sharing on the Windows box is enabled, but I don't have the privileges to choose which folders to share.

I tried making a new folder on my Mac and using that instead, to see if there's any difference. Nope.
posted by curagea at 12:28 PM on February 27, 2009


« Older Recommend me some kickass fight scenes please!   |   rainjacket Newer »
This thread is closed to new comments.