Join 3,497 readers in helping fund MetaFilter (Hide)


Lousy connectivity on my new DSL
February 23, 2009 11:13 AM   Subscribe

Diagnose my wifi difficulties, please! New DSL installation with intermittent, slow connectivity and occasional weird pings/notifications.

I'm somewhat computer savvy, but I'm definitely missing something basic, so assume I'm a beginner with all this!

I just got DSL (with SBC Global) and an inherited modem and linksys router. I followed the instructions on the SBC Global installation cd, installed the phone filters, etc. Connectivity is intermittent (and extremely slow), even though the signal always appears strong, and roommates also have the same problems. I'm usually able to connect to the router (though not reliably). Pings return occasionally weird results (posted below), and every once in a while this error will pop up:
"192.168.1.64 in use by 00:90:4b:b4:ef:dc, DHCP Server 192.168.1.254"

The intermittent connection also seems to happen when I'm connected directly to the modem via an ethernet cable, but I don't think it's a problem with the physical lines: I've already checked the phone box outdoors, and there's no corrosion (plus, I'm pretty sure the previous tenants have had wireless here without complaint).

Here's the last minute-or-so of a ping:

64 bytes from 69.13.72.249: icmp_seq=8227 ttl=55 time=64.149 ms
64 bytes from 69.13.72.249: icmp_seq=8228 ttl=55 time=72.922 ms
64 bytes from 69.13.72.249: icmp_seq=8230 ttl=55 time=72.530 ms
64 bytes from 69.13.72.249: icmp_seq=8233 ttl=55 time=62.075 ms
60 bytes from se5-l0.pltnca.sbcglobal.net (151.164.186.133): Communication prohibited by filter
Vr HL TOS Len ID Flg off TTL Pro cks Src Dst
4 5 00 0054 2cc6 0 0000 3e 01 fff4 192.168.1.64 69.13.72.249

64 bytes from 69.13.72.249: icmp_seq=8612 ttl=55 time=81.776 ms
64 bytes from 69.13.72.249: icmp_seq=8613 ttl=55 time=61.918 ms
64 bytes from 69.13.72.249: icmp_seq=8614 ttl=55 time=61.946 ms


I don't think I've left anything important out, but I'm not sure what to do and ordinary fiddling hasn't seemed to fix anything. Help, metafilter! You're my only hope!
posted by soviet sleepover to Computers & Internet (5 answers total) 2 users marked this as a favorite
 
A couple of things to check:

Get into the modem's web interface (since we don't know what sort of modem you've got, no specific instructions here). There should be information about the connection configuration. Take note of things like the max MTU size, whether PPPoE is on the modem or the router, and whether the router is allowed to share the public IP address. Then, get into the router interface and check those same things. You'll want the max MTU size to match, you don't want both the modem and the router trying to handle PPPoE, and you may want to make sure that the router is set to get its IP address automatically from the ISP.

More details on the make and model of your modem and router would be helpful.
posted by sinfony at 11:30 AM on February 23, 2009


I've already checked the phone box outdoors, and there's no corrosion

Thats not how it works. What determines you line's quality is not anything you can see. These lines go for thousands of feet and terminate into very complex equipment. What you need to do is call your ISP and have them test your line. They should be able to determine the signal/noise ration and figure out what can be done. Sometimes the line needs service, sometimes the speed they sold you was too high and your DSL modem cannot handle it. Or the modem might be going bad.

It also sounds like your inherited modem is doing DHCP and your linksys is also doing DHCP, thus duplicate IP addresses. Some DSL modems are actually routers. So you might have two routers plugged into each other. This explains why youre getting identical IP addresses. You need to disable one of these DHCP servers. I would first try removing the linksys and seeing if the connection is stable (or if you even get an IP). If so then put the linksys back on, and disable its DHCP. If the problem continues at least youve isolated it to the linksys. If you cant get decent service using just the DSL modem then you should contact your ISP.

Oh, its also worth mentioning that if you inherited this modem and the previous owner put in his name and password for pppoe authentication then you'll need to change it to refect your own. You shouldnt be using any connection software on the computers. The router will authenticate you. Did you do a factory reset of this modem when you got it? You should have.
posted by damn dirty ape at 11:50 AM on February 23, 2009


The modem is a Motorola 2210-2, and according to it, the max MTU size is 1492; I enabled max MTU size (which was disabled) on the router, and set it for 1492 as well.

On the modem, under PPP Location, the setting is for "PPP is on the modem."

I'm fiddling a bit, and haven't been able to find where to set which handles PPPoE on the router yet.

Thank you, sinfony!
posted by soviet sleepover at 11:54 AM on February 23, 2009


Damn dirty ape, you may've nailed it--or nailed one problem, at least! I disabled DHCP on the router, and suddenly the connection speed is much improved.
posted by soviet sleepover at 12:01 PM on February 23, 2009


I'm going to go out on a limb and assume that the Linksys firmware is pretty similar across all of their products. Following damn dirty ape's advice, go into the Linksys firmware and the basic setup page should let you change the router's IP address. Your modem probably gave it 192.168.1.1. You'll want to change it to something out of the 192.168.1.* range, since that could lead to conflicts with the modem. Change it to 192.168.0.1, then apply the changes. Once you've done that, the router's DHCP will start assigning addresses in the 192.168.0.* range, which should avoid any conflict with the modem. For what it's worth, I have my modem set to "PPP on the modem, public IP for LAN device"; if you have it set to "Private IP for LAN device," this may not work.

You might also consider setting up static IPs for the devices on your network. This is done through the DHCP Reservation option on the Linksys interface. You'll be able to tell the router that a particular computer should always have a particular IP address, which is handy for port forwarding.
posted by sinfony at 12:06 PM on February 23, 2009


« Older Where can I find DVD's of Bene...   |  What is it like to dream?... Newer »
This thread is closed to new comments.