Join 3,501 readers in helping fund MetaFilter (Hide)


Quit signing me out, Google!
February 21, 2009 10:18 AM   Subscribe

Every time I close my browser (Firefox) Google signs me out. How can I stay signed in? It's very annoying. Googling has not returned an answer to the question.
posted by wsg to Computers & Internet (24 answers total) 1 user marked this as a favorite
 
Go to Edit|Preferences|Privacy and check the setting under Accept third-party cookies/Keep Until: - is it set to "I close Firefox"? If so change it to "they expire".
posted by Electric Dragon at 10:27 AM on February 21, 2009


Alternatively, when you sign in, do you have the "Remember me on this computer" box ticked?
posted by Electric Dragon at 10:35 AM on February 21, 2009


Electric Dragon has it.. make sure your cookies don't get erased.

Also, on Firefox 3.06 for OSX, if you go to preferences / privacy, at the bottom, make sure "always clear my private data when I close Firefox" is not checked (not sure if there is an equivalent on Windows, but I'm assuming there is).
posted by carpyful at 10:40 AM on February 21, 2009


Also, if you download the Google Toolbar for Firefox, it will force log you back in automatically, and it's cookie independent, since it's based on extension settings.

When you log yourself out manually from the site, however, it triggers the Extension to keep you logged out.

You can also hide the toolbar if you don't want it cluttering things up by right clicking and unselecting it, or by clicking Customize and dragging features back into the customize box.
posted by disillusioned at 10:46 AM on February 21, 2009


Go to Edit|Preferences|Privacy and check the setting under Accept third-party cookies/Keep Until: - is it set to "I close Firefox"? If so change it to "they expire".

Or, click on "exceptions" and add the url to the dialogue box that pops up instead of changing a more global rule.
posted by squeak at 10:54 AM on February 21, 2009


I've already checked my cookies settings and it was already set to accept cookies and stay logged in until they expires. That hasn't changed.

Checking the "remember me on this computer" box doesn't help.

"Always clear my private data when I close Firefox" is not checked.

I like the google toolbar and don't want to hide it. I only use it for search.
posted by wsg at 10:57 AM on February 21, 2009


I am pretty sure that third-party cookie settings shouldn't affect this since it's a first-party cookie. It's supposed to do what you want it do to if you check "Remember me on this computer", but it's not clear from your question if you're doing that or not.
posted by sergent at 10:57 AM on February 21, 2009


Oops, sorry. That's baffling. Can you see if the problem goes away by temporarily disabling the toolbar?
posted by sergent at 10:59 AM on February 21, 2009


If you're using the official Google Toolbar, you can disable it and use the search engine box that comes with Firefox, which supports Google.

If it's not already there, you can go to View->Toolbars->Customize and drag the search box wherever you like onto your toolbar.
posted by alligatorman at 11:15 AM on February 21, 2009


I'm having the same problem. Will be keeping my eye (just one) on this thread.
posted by FusiveResonance at 11:31 AM on February 21, 2009


I was wrong. It's not the official google tool bar. It's just the customizable search bar that comes with firefox. B)
posted by wsg at 11:45 AM on February 21, 2009


That's odd. I use the customizable search bar, and I've never had this problem.
posted by alligatorman at 11:47 AM on February 21, 2009


Disable all your add-ons and see if the problem persists. It's always a good idea to rule out add-ons right away - some of them have strange and unexpected side-effects.
posted by chrisamiller at 11:58 AM on February 21, 2009


I'm looking for add-ons, but don't see any. What am I looking for and where? Thanks.
posted by wsg at 12:05 PM on February 21, 2009


Tools -> Add-ons
posted by alligatorman at 12:17 PM on February 21, 2009


Um. I think you're missing the point. The in-built Firefox Google Search Bar will NOT keep you logged in. Download the Google Toolbar as I linked it, and it will have a grey button with options to log in to your Google account. Do that and you'll remain logged in.

Then you can hide THAT toolbar if you don't want it cluttering up things and just want to use the search box built into Firefox.
posted by disillusioned at 12:25 PM on February 21, 2009


I have this problem too, and not just with Google. regardless of the Firefox settings and whether or not I check the "remember me" checkbox, quitting and restarting Firefox causes me to log out. It's weird because not all sites do this.
posted by ArgentCorvid at 12:30 PM on February 21, 2009


By any chance, are you running Linux and using Checkgmail? The current version has a tendency to log you out of iGoogle.
posted by pravit at 12:57 PM on February 21, 2009


I have this problem too, and not just with Google. regardless of the Firefox settings and whether or not I check the "remember me" checkbox, quitting and restarting Firefox causes me to log out. It's weird because not all sites do this.

I have the same problem with a number of sites. Some NEVER remember anything I tell them, some forget stuff after a short amount of time. It seemed to start with Firefox3. I even went in and checked the cookies- the expire time on many of them seems to be getting changed. Cookies that should last (effectively) forever have expire dates of a day or few. I suspect it's a bug.

I just set network.cookie.lifetimepolicy to 3 and network.cookie.lifetime.days to 360 as an experiment. Maybe that will help.
posted by gjc at 8:34 AM on February 22, 2009


I use the Gmail Manager add-on, and have it log in to my accounts automatically. I recommend it highly, especially if you have multiple Gmail accounts (although some minor bugginess has appeared in the last few versions).
posted by stavrosthewonderchicken at 5:30 PM on February 22, 2009


My experiment didn't work. However, I noticed that I had "never accept cookies from third party sites" enabled. After I disabled that option, it seems to be behaving better. That setting may be overly sensitive- not allowing cookies from someothername.website.com when you are on www.website.com.
posted by gjc at 4:58 AM on February 23, 2009


I tried installing the google toolbar and the gmail manager. Nothing has changed. I also checked my add ons and there wasn't anything there. Thanks, all, for your help.
posted by wsg at 9:18 AM on February 23, 2009


Awhile ago I ran into this problem with del.icio.us but gave up trying to get it to work like it used to (they revamped the site and I figured whatever they did on their end was the reason) . Anyhoo ... I fiddled a bunch/did a few searches and, I think I might have found the solution. From the mozilla support forums:

The file that stores cookies may be corrupt. To test this close Firefox, go to your profile folder and rename cookies.sqlite to cookies.tmp. Restart Firefox, log into those sites and then see if it remembers the logins.

Hope it helps.
posted by squeak at 12:42 AM on February 24, 2009


Hallelujah! It worked. Thank you, squeak!
posted by wsg at 8:54 PM on February 24, 2009


« Older There was a Olympic slalom eve...   |  Help me find just the right bo... Newer »
This thread is closed to new comments.