Vista network, local access only?
January 29, 2009 4:55 AM   Subscribe

Vista wont connect to internet, local access only.

I've been given a friends computer to fix and not being familier with Vista I am unable to fix it. Using either wired or wireless connection to my router it will say its connected to 'Unidentified network' with only local access. I know that the router works as there are 10 other computers connected to it and I've tried various cables. Help!
posted by john_son to Computers & Internet (8 answers total) 1 user marked this as a favorite
 
First off, is the Vista box plugged into the same switch and port as another computer you know can access the Internet? When plugged in, do lights on your computer's Ethernet jack and the appropriate switch port light up? They should be.

Then see if the computer is getting an IP address- go to command prompt and type "ipconfig /all"
You should see an IP address other than 169.x.x.x (prob 192.168.x.x) and a default gateway address on the same subnet as your IP address. If so, try pinging your default gateway. If not, I suggest manually assigning an IP address to that box and seeing if it works. However, beforehand, you can try getting a new network configuration from your router. Type "ipconfig /release" ENTER. When that's finished, "ipconfig /renew" ENTER. If you get different numbers than before, that's a good sign. If not...

To manually assign an IP address, check out your other machines and get their subnet mask, default gateway, and DNS servers through the ipconfig /all command (they should all be the same). Now, check out your computers' IP addresses and assign the Vista box an IP on the same subnet, but with a different last octet.
For instance, if the computers have 192.168.1.[100-->110], assign the Vista box 192.168.1.111
I forget where to go in Vista to actually assign IP addresses...it's different than XP IIRC.
posted by jmd82 at 7:05 AM on January 29, 2009


I had the exact same problem with Vista the other day. I was in a rush so I simply re imaged and problem solved.

I know that doesn't really give you an answer though so someone may be able to narrow it down for ya
posted by moochoo at 7:25 AM on January 29, 2009


I often face the same issue with my vista desktop ( vista on a laptop seems to work fine).

I switch between wired and wireless when that happens and it usually fixes the problem. ( if it's local access only on wired then i go wireless and if it happens on wireless than i switch back to wired). Sometimes the internet comes back on its own after an hr or so.

As jmd82 said, renewing your network configuration can also fix the problem but it didn't help me in this case.

If all else fails, try rebooting your modem and router. (Turn the modem back on first and then the router)
posted by Danniman at 10:15 AM on January 29, 2009


Also try disabling all connections except the one you are using - I've had a similar problem when I had two NICs on the motherboard, despite one being connected OK the fact that the second wasn't caused the pc connection to enter local only mode.
posted by xla76 at 12:38 PM on January 29, 2009


If you're getting a self-assigned IP, it is HIGHLY UNLIKELY that manually assigning an IP will allow the computer to connect. The only circumstance I've seen that work is when there's a problem with the computer's TCP/IP stack, and the majority of problems that cause a self-assigned IP are outside of the computer.

You could also try checking whether the router's DHCP range is more than 10 digits. If the DHCP range is only 10, the router will only hand out 10 IPs and the 11th computer's address will be self assigned. Contrary to what I've just said, this is one circumstance where a manual IP WOULD work, but I don't come across it because I tend to be troubleshooting networks with no more than 3 or 4 computers.
posted by fearnothing at 12:42 PM on January 29, 2009


So, the computer was given to you because of this problem specifically, right? If not, definitely look at your own network. Fearnothing may be on to something, so check your router's settings.

There's a chance the computer has a problem with DCHP, so I think it's worth it to try assigning it a manual IP. It may not be entirely likely, but I think it's worth a shot. Just copy another computer's settings and change the IP to one that isn't being used (Try changing the last group of digits in the IP and keep the others the same, because that's least likely to cause problems). Sorry if you already knew that, I just figured I'd explain in case you didn't know.
posted by mccarty.tim at 1:47 PM on January 29, 2009


One other thought:
If it's a fresh install, make sure the drivers (specifically NIC- Network Interface Card) drivers are properly installed.
posted by jmd82 at 2:18 PM on January 29, 2009


I ended up having to re image having tried every thing I could think of and everything listed here.....still no idea what the problem was, it works now though.
posted by john_son at 5:16 AM on February 9, 2009


« Older How do you read vividly?   |   My Wii Fit talks too much! Newer »
This thread is closed to new comments.