Wireless Networking Dramas
January 23, 2009 9:55 PM   Subscribe

WiFiFilter: My computer can see and connect to my wireless access point. So can my PS3, Wii and iPhone. But unlike my PS3, Wii and iPhone, it can't browse the net. Ping requests are timing out. What am I doing wrong?

The Wireless connection can see and connect to my Access Point with no problems (so the connection does establish) but browsing the web, checking my e-mails or even browsing other files on the network dosen't work. Ping requests are timing out.

There is nothing wrong with my Access Point as far as I can tell. My other wireless devices (my PS3, my Wii and my iPhone) all connect to it without a hitch and have done for some time.

I've tried manually assigning IP addresses and that didn't work.

Although this computer is located at the other end of the house, signal strength is still classed as 'Very Good', likely due to the massive antenna I have to broadcast with. Infact, my iPhone works flawlessly over WiFi right next to the computer in question, so signal strength is probably not a factor here.

I've also tried turning off the firewall (I use Sygate) on the computer running the Access Point, but the other computer still won't let me use the web or browse the network.

The only reason I can think of for this not to work is that the computer that I'm trying to connect to my access point is using an older ASUS Wifi @ Home 802.11b Wireless LAN Card, while my Access Point is an 802.11g. However my Google searching suggests that while this was once a problem, newer drivers and updates to WinXP have ensured that it no longer is. That said, I'm using WinXP and have SP3 installed. Drivers for my LAN Card are all up to date. And still it connects to my Access Point but provides me no internet access.

I'm using the LAN Card's own software to configure the connection to my Access Point. Window's own connection manager has been pretty useless in connecting to my AP for some reason.

Help me Metafilter! You're my only hope. Please make connecting my two PCs as easy as it was to connect my other wireless devices!
posted by Effigy2000 to Technology (16 answers total)
 
Is your computer actually getting an IP address? Can you see any other machines on your network or load the configuration page for the wifi router?

If not, the most likely explanation is getting the password/network-key wrong.
posted by winston at 10:16 PM on January 23, 2009 [1 favorite]


winston: "Is your computer actually getting an IP address?"

If you mean "Does it get an IP address when I tell Windows to automatically obtain one", then yes, it does. Ping requests with an automatically obtained IP result in the message "Destination Host Unreachable." When I manually assign an IP, the ping response is "Request Timed Out." And either way, no, I can't see the other PC on my network.

winston: "If not, the most likely explanation is getting the password/network-key wrong."

Thanks, but that seems unlikely. I've entered and re-entered the WEP key a million times over just to ensure that's not the case. Plus as I say, a connection is established (or at least, the software says the two PCs are linked) so its not like the AP is refusing to let me join it.
posted by Effigy2000 at 10:32 PM on January 23, 2009


How's your DNS?

Try setting your DNS server to 4.2.2.1 (or google your ISP's DNS server address).
posted by pompomtom at 10:35 PM on January 23, 2009


pompomtom: "How's your DNS?

Try setting your DNS server to 4.2.2.1 (or google your ISP's DNS server address).
"

Tried out both 4.2.2.1 and my ISPs DNS address just now. Sadly, no luck.
posted by Effigy2000 at 11:03 PM on January 23, 2009


Is your Router set to "G only" by default? Sometimes it is to protect against the B+G slowdowns of the past.

Also, is MAC Address filtered enabled under the router security settings?
posted by sharkfu at 11:37 PM on January 23, 2009


I've had this issue pop up when multiple devices get the same IP (my Netgear router loves to do this with my PS3 and my roommate's Xbox 360). When you manually assign an IP address to your computer, are you assigning a "low" IP number such as 192.168.1.3 (or something similar)?

The best way to test this is to turn off all your devices except your computer. Then fire up the computer and see if it gets an IP and is able to connect to the internet. If it does, then you probably have an IP conflict.

My fix is to go into the wireless router settings and enter the MAC addresses for each of the devices and give them all different IPs. If your devices are connected, you can usually enter the "connected devices" screen and copy and paste your MAC addresses from there.
posted by plasticbugs at 11:39 PM on January 23, 2009


sharkfu: "Is your Router set to "G only" by default? Sometimes it is to protect against the B+G slowdowns of the past.

Also, is MAC Address filtered enabled under the router security settings?
"

I should probably point out that my AP is not a router. It's also a network adaptor (Realtek RTL8187 Wireless 802.11g 54Mbps USB 2.0 Network Adapter). It's set to b/g mode.

The way my set up works, for the record, is like this

Non wireless modem --> PC = Local Area Connection which shares net access with the Wireless Network Connection (the Realtek Adaptor).

As for the MAC address filtering, I'm not sure, sorry. I can't seem to find where it would tell me that. I can see what my MAC address is, but can't tell if it's filtered or not.

plasticbugs: "When you manually assign an IP address to your computer, are you assigning a "low" IP number such as 192.168.1.3 (or something similar)?"

I've tried assigning both high and low numbers. Neither has worked.
posted by Effigy2000 at 11:56 PM on January 23, 2009


I worked in an office where 20 machines were all working off of one Airport Base Station. It was a cheap solution that ultimately began failing within a month. One wireless router just wasn't meant to handle all those devices.

I'm going to say that your Realtek Adapter is also ill-equipped to handle the amount of wireless traffic you're throwing at it, albeit on a smaller scale.

Invest in an actual wireless router. You'll save yourself countless headaches. Plus, you won't have to rely on your other computer for "always-on" internet access via one of its USB ports.

I hate to say that throwing money at this problem will fix it, but in this case, you're probably better off.
posted by plasticbugs at 12:15 AM on January 24, 2009


I should add for the record (and as an Apple Fanboy), that I was working for a video podcasting company and our internet connections on all 20 machines were pegged all day, every day - uploading, downloading and moving gigs upon gigs of data. Otherwise, I bet that an Airport Base Station could probably have handled 20 Macs doing average tasks.
posted by plasticbugs at 12:22 AM on January 24, 2009


plasticbugs: "Invest in an actual wireless router. You'll save yourself countless headaches. Plus, you won't have to rely on your other computer for "always-on" internet access via one of its USB ports. I hate to say that throwing money at this problem will fix it, but in this case, you're probably better off."

I entirely agree with you, and that is my long-term plan. At the moment though this is my short term solution until I can afford the wireless router proper, so it'd be nice if it could play nice with all my devices until then.
posted by Effigy2000 at 12:22 AM on January 24, 2009


Is your computer set to associate to "ad-hoc" networks (not just "infrastructure")? I don't see why you'd get connected if it wasn't, but it's worth checking. I know the windows wireless manager makes a distinction, but I can't say anything about the program you're using.
posted by philomathoholic at 10:21 PM on January 24, 2009


What happens if you turn off WEP?
posted by filmgeek at 11:07 PM on January 24, 2009


Can you hit http://72.14.253.104/ ? This should be google, if you can see it it is a DNS issue.

Can you ping the other network machines?

I used to have a similar problem, turns out my ISPs modem/router (woosh) assigns a bunch of IPs on the network it doesn't tell you about and screws up the network when you share through a computer.

Try running the windows network set up wizard, it has a bunch of stuff you need, then you can turn it off and use your cards one (internet sharing is the main one you'll need).
posted by scodger at 11:45 PM on January 24, 2009


(What I was replying for in the first place, but then forgot)

Type in tracert http://72.14.253.104/ (or your other computer IPs) and you can see where it fails.
posted by scodger at 11:50 PM on January 24, 2009


I could be off my rocker, but I recall replying to this post just as it was taken offline, and was appearantly backed up to a time before my reply and some others.

IIRC, you had mentioned in one of the comments that you were assigned a 169.x.x.x IP address, and if so, therein lays your problem. When you computer boots, it looks for a DHCP server which assigns IP information. I would go to the command prompt (Start --> Run --> 'cmd') and type 'ipconfig /all' and see what you get. Pay particular attention to IP address, default gateway, and DNS servers. If the first two are blank or report 169.x.x.x, no amount of pinging and traceroutes will work.

When you go to manually assign an IP address, also be sure your default gateway is correct. Without this, you computer will now know how to get past it's own hop. It should be getting this information during the boot process, but it appears not here.

All that said, I've never dealt with Internet Connection Sharing (ICS- MS's fancy term for what you're doing) so I can't be specific on how to troubleshoot it. Two things to check though: try to find some information about DHCP on the AP. It should be somewhere, I'd assume. two: It's sounding like wireless b/g could be an issue. I know you said patches were supposed to take care of that, but it could still be causing problems.
posted by jmd82 at 7:41 AM on January 25, 2009


In the end, I just decided to say "fuck it", switched off the Wi-Fi card and went back to using the cable. Too much hassle for little gain. I'm gonna do what plasticbugs said and just buy a wireless router proper. This was, as I said earlier, the longer term goal anyway but I've moved it up into the near future as a purchase.

Thanks for your help one and all.
posted by Effigy2000 at 7:08 PM on February 4, 2009


« Older What are those blocky, meta-en...   |  Where can I refill compressed ... Newer »
This thread is closed to new comments.