Join 3,513 readers in helping fund MetaFilter (Hide)


MS Exchange and IMAP
January 8, 2009 9:21 AM   Subscribe

Help me communicate to my MS Exchange server admin: I want (full) IMAP access!

At my current gig they use Exchange as the corporate email standard. I've been using Outlook for a few months when I got wind that IMAP was activiated on our Exchange server and other folks were using clients like Thunderbird with no issues... needless to say I was excited.

When I tried to use IMAP I was able to authenicate but the server reported that it could not find my INBOX.

When I wrote a script to dump all the folder that I *could* see via IMAP all that came back were all the 'public' folders.

When I ask for help no one at our help desk knows what the heck I am talking about.

My question is this: what 'majik words' can I say to my Exchange admin or settings has be changed for my account in Exchange so I can see my private INBOX via IMAP?

thanks!
posted by tucsongal to Computers & Internet (9 answers total)
 
My first thought is to ask a coworker who is using Thunderbird what exactly they did to get things working. If that doesn't work, does your help desk have any escalation procedures or a public e-mail for THE tech guy you can e-mail?
posted by Nonce at 9:26 AM on January 8, 2009


Its definitely a server side configuration issue.. If I plug in my credentials into his client we get the same error.

I am working on getting to the 'right' person.. but I would like to know exactly what to say when I get to the person. If I knew the setting that needed to be twittled, they would be more inclided to do it.. but if they have to figure out what has to be set.. it prolly will not get done.
posted by tucsongal at 9:30 AM on January 8, 2009


Just say exactly what you've said above --let them figure out the rest. Don't close the call until you can do precisely what you need. Don't use a script you've written, create a test case that applies to a desktop user not an admin or programmer. My guess is this has something to do with the client not knowing the correct IMAP server directory. Perhaps they can turn up debugging to see the protocol exchange and see what you're client is doing?


The important thing to remember is that you become more of a priority when you're patient, cooperative, and grateful.
posted by ezekieldas at 9:42 AM on January 8, 2009


This could be enabled on a per-user basis, or per server, or per storage group. If you know the Exchange Admin, just ask her/him if you can have it enabled on your account, or be moved to a server where it is enabled. Helpdesk doesn't always know about this sort of thing, as you've seen.
posted by kellyblah at 9:49 AM on January 8, 2009


kellyblah: this is exactly what I am looking for... What is the attribute called that enables this? From my sampling around here... It looks like people are randomly able to use IMAP.
Actually the more I think about it it seems people in our Minneapolis office seem to have it enabled.
posted by tucsongal at 9:54 AM on January 8, 2009


This may be a client-side issue, especially if others can use it without permission. Depending on the client you may need explicityly tell it "Subscribe to these folders: inbox, sent, etc." What client are you using? Thunderbird? Thunderbird should automatically subscribe to inbox.

That said, I guess it could be disabled for you. Just ask them to enable IMAP for your account. You dont need to tell them anything else.
posted by damn dirty ape at 10:46 AM on January 8, 2009


Exchange 2003 Sample IMAP Session:

* OK Microsoft Exchange Server 2003 IMAP4rev1 server version 6.5.7638.1 (xxx.xxx.xxx.org) ready.

A1 LOGIN me mypassword
A1 OK LOGIN completed.
A2 select inbox
* 4971 EXISTS
* 4971 RECENT
* FLAGS (\Seen \Answered \Flagged \Deleted \Draft $MDNSent)
* OK [PERMANENTFLAGS (\Seen \Answered \Flagged \Deleted \Draft $MDNSent)] Perman
ent flags
* OK [UNSEEN 51] Is the first unseen message
* OK [UIDVALIDITY 81490] UIDVALIDITY value
A2 OK [READ-WRITE] SELECT completed.
A6 FETCH 1 BODY[HEADER]
* 1 FETCH (BODY[HEADER] {821}
X-MimeOLE: Produced By Microsoft Exchange V6.5
Received: by cmc1.corp.claramartin.org
id <0>; Mon, 11 Aug 2008 12:00
:35 -0500
MIME-Version: 1.0
Content-Type: multipart/alternative;
boundary="----_=_NextPart_001_01C8FBD3.C59018A3"
Content-class: urn:content-classes:message
Subject: RE: Sarah L's Voice Mail
Date: Mon, 11 Aug 2008 12:00:35 -0500
Message-ID: <3>
In-Reply-To: <3>
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
Thread-Topic: Sarah L's Voice Mail
Thread-Index: Acj70ufpmgPE2J7MRUCZE5z9j/iRtQAAAdyAAAAWL/AAAAzwgAAACY8Q
From: xxxxxx"
To: "xxxxxxxf"

)
A6 OK FETCH completed.

posted by SirStan at 12:04 PM on January 8, 2009


Assuming that IMAP access is already enabled on the server but is not enabled on your account, and if you want to creep the sysadmin out by mentioning the location it's actually configured in a plain English sentence, the appropriate question would be something like:

"In my Active Directory user properties, can you enable IMAP4 under the Exchange Features tab for me?"
posted by eschatfische at 12:21 PM on January 8, 2009


Sorry, just noticed the attrib name question. On an Ex2003 server/management, if I go into the AD Users management, and get the properties of your account, I would go to the Exchange Features tab, and make sure that IMAP4 is set to "Enabled".
posted by kellyblah at 2:04 PM on January 8, 2009


« Older (Pet harmony filter) A little ...   |  My wife and I would like to in... Newer »
This thread is closed to new comments.