www-wrong
January 7, 2009 5:56 AM   Subscribe

How do I prevent Firefox from adding 'www' and '.com' to local URLs?

I have a web server on my local network that I access via http://test/

Whenever I forget to turn on this server (or if it goes into standby or whatever), Firefox first tries the corrrect URL, then tries http://www.test.com. I find this more annoying that I probably should.

Any idea how I can prevent this second-guessing by Firefox? It's got to be in about:config somewhere, but I'm blessed if I can find it.

Failing that, how do I learn to be less anal?
posted by le morte de bea arthur to Computers & Internet (7 answers total) 2 users marked this as a favorite
 
Here you go. The about:config bit you're looking for is browser.fixup.*.*
posted by Happy Dave at 6:02 AM on January 7, 2009 [1 favorite]


Thanks Happy Dave. Your about:config-fu is truly excellent.
posted by le morte de bea arthur at 7:14 AM on January 7, 2009


How do you get it to stop going to Google?

If I type "metafilter" into the bar, instead of autofilling the www and .com bits, it goes to Google and gives me the "feeling lucky" result. Is there a way to stop it from making that extra trip to Google?
posted by bink at 8:09 AM on January 7, 2009


Yep, go to about:config, then type in 'browser.fixup'

There's a value there called 'browser.fixup.alternate.enabled'. Change that to false. That'll disable the www and .com autocompletes too.
posted by Happy Dave at 8:21 AM on January 7, 2009


bink, if you want to go to a URL directly using Firefox, type "metafilter" or whatever in the address bar and then press Ctrl+Enter instead of just Enter; Firefox will automatically add the "www." and ".com". I use this all the time, it's a great shortcut. Similarly, Shift+Enter adds ".net", and Shift+Ctrl+Enter adds ".org".
posted by oulipian at 9:05 AM on January 7, 2009 [1 favorite]


I use an addon called URL Suffix to do something similar to this. I use it to deal with subdomains. For example, I want to go to http://randomblog.blogger.com. I type randomblog.blogger into the address bar, press shift+enter, and I get there.
posted by Solomon at 9:21 AM on January 7, 2009


Thank you!
posted by bink at 9:59 AM on January 7, 2009


« Older Having absent-mindedly added t...   |  Started a low-carb diet. Anxi... Newer »
This thread is closed to new comments.