Skip

Publish a post and then keep it open
November 6, 2008 5:25 AM   Subscribe

Wordpress: After I hit Publish, a new blog posting is created, and eventually is saved as a draft. How can I change this behaviour so that the post I've just created is published, but that the post I just published is open, instead of a new post?

My methodology is this:
1] Create a new post. Because I use the WP Default Post Content plugin, certain parts of the post are already there.
2] Write the rest of the post.
3] Publish the post.

What happens then is that another new post is created, with the bits from the above plugin included. After 60 seconds, this is saved as a draft, because there is some content to the post (if there is no content, the post doesn't get saved as a draft). At the end of the month, I have 30 drafts, none of which will be used, which all contain exactly the same information. I do not want this to happen.

What I want is for the Publish button to publish the current post, while keeping it open and editable (instead of creating a new post). How can I achieve this?
posted by Solomon to Computers & Internet (6 answers total)
 
I may be missing something obvious, but why publish an incomplete post in the first place?

The non-hacking workaround would be to hit the Manage link once you publish. From there you can choose to edit the post you've just published (or start again based on one of those draft posts).
posted by Lionel d'Lion at 5:55 AM on November 6, 2008


I may be missing something obvious, but why publish an incomplete post in the first place?

I update the posts during the day with various bits of info. They're not "incomplete" so much as "waiting to be added to".

I want something more automatic than having another couple of clicks. I might edit a post half a dozen times a day, and several batches of clicking multiple times has gotten old very quickly (hence this question). :)
posted by Solomon at 5:59 AM on November 6, 2008


Wordpress recently added a feature that autosaves any post with content in it. Sounds like you need to disable this.
posted by gramcracker at 6:05 AM on November 6, 2008


That would help with the drafts issue, but it doesn't solve the problem of a new post being created. I want it to Publish the post and then keep it open.
posted by Solomon at 6:45 AM on November 6, 2008


IIRC, there used to be a "save and continue editing" button in the WP post interface, but that went away in the 2.6 admin redesign.
posted by misterbrandt at 12:33 PM on November 6, 2008


I've finally figured out how to do it, and it was staring me right in the face the whole time. Set the Publish Status to published, and then hit Save. Simple.
posted by Solomon at 1:51 PM on November 6, 2008


« Older Are there support groups for m...   |  Does anyone know of any life-s... Newer »
This thread is closed to new comments.


Post