Join 3,512 readers in helping fund MetaFilter (Hide)


How to fix a botched Wordpress database transfer?
October 14, 2008 10:18 PM   Subscribe

Why isn't my backed-up Wordpress blog appearing on my new website? I've moved domains, and I've copied my database from my old site to the new one. Trouble is, the page just draws a blank.

I followed these instructions to copy my old database to the new domain. Now when I manage my posts on the dashboard, the posts are all there, but the blog won't appear at all.

What did I do wrong? How should I be rectifying this?
posted by micketymoc to Computers & Internet (5 answers total)
 
There are a couple of things that could be killing it off. The first thing you should do is make sure to enter values corresponding to your new domain name in the "settings" section of your admin panel.
posted by wam at 10:41 PM on October 14, 2008


I checked, the settings seem to be pointing in the right direction. (i.e. urls that say "mchronicles" instead of "bluechronicles")
posted by micketymoc at 10:48 PM on October 14, 2008


In that case you should try switching to the default theme and then disabling all plugins (if you're using plugins and a theme other than the default theme) and see if that resolves the problem. Try the theme first, it's a likely culprit. If doing that fixes the problem, re-enable things one at a time while checking the front page to narrow it down.
posted by wam at 10:56 PM on October 14, 2008


Holy shit, that worked! Switched to the default theme and it appeared! You rock, WAM!
posted by micketymoc at 11:04 PM on October 14, 2008


Glad you got your site working! You'll probably want to check your wp-content/themes directory to make sure the files for the problematic theme survived the server transfer intact, check that the theme is compatible with your current version of Wordpress, etc.
posted by wam at 11:13 PM on October 14, 2008


« Older Trying to find the name of a b...   |  Please help me find video onli... Newer »
This thread is closed to new comments.