Join 3,413 readers in helping fund MetaFilter (Hide)


Hell is Facebook popups.
October 12, 2008 3:51 PM   Subscribe

Please help me with popups on my computer.

I have suddenly started to have a problem with popups on my computer. Except it only happens with Facebook. When I try to close Facebook (by clicking the "x" in the upper right hand corner), I suddenly am bombarded with dozens of new windows popping up with the Facebook home page. They come so quickly that I have to shut down my computer to make it stop (I've tried to go to Task Manager but they come too fast).

I generally do not have problems with popups otherwise. I've now downloaded Stopzilla and I have run a logfile with HijackThis. You've probably guessed by now that I know absolutely nothing about computers and have tried to fix the problem myself from using tips on websites, but I am totally bogged down in jargon and have no idea what I'm doing. Can anyone help me?

If it helps, I use Windows Vista and Internet Explorer. If you need to know anything else, ask me and hopefully I'll be able to answer. Also, should I post my logfile from HijackThis here? Would it help? Sorry but I'm totally clueless.
posted by triggerfinger to Computers & Internet (14 answers total)
 
Do you get the same problem in Firefox?
posted by Lycaste at 4:07 PM on October 12, 2008


I never use Firefox so I don't know. I just went into it and tried and it didn't happen but it doesn't happen every time in IE either, usually every 4 or 5 times for a very rough estimate.
posted by triggerfinger at 4:13 PM on October 12, 2008


You can try Ad-Aware. It's free and will probably find what is causing your pop-ups.
posted by lee at 4:19 PM on October 12, 2008


Here's a great page that simply explains how to deal with these kinds of spyware problems.
posted by Pants! at 4:26 PM on October 12, 2008


Also - use Firefox instead of IE. Just try it for two or three days - what can it hurt? You can download it for free here.
posted by ewingpatriarch at 4:40 PM on October 12, 2008


You may see some improvement by switching to firefox, but maybe not. Without knowing any particular details, it might be the Vundo trojan which is particularly nasty, particularly difficult to get rid of, and affects just about every browser except for Apple Safari. Ad-aware doesn't get rid of it. Wish I could offer some advice on how to get rid of it, but I spent a few weeks trying to banish it from my parents' computer with no success. They were using Firefox, by the way.
posted by msbrauer at 4:50 PM on October 12, 2008


What happens if you go to Facebook, then go to another site, then quit?

In general, though, Firefox. Always Firefox.
posted by mkultra at 4:51 PM on October 12, 2008


Okay I've switched over to Firefox and hopefully will get used to using it. I've always heard it's better but I have no idea why and as I never really seemed to have problems on IE, I never bothered to switch.

Usually I have lots of diferent windows open when I'm online, one of which will be Facebook. I can navigate in and out of Facebook to different sites with no problems. This only happens when I click on the "x" in the corner to close the window that currently has Facebook open. I will then be hammered with popups at a rate of about 5 or more per second, but they are all popping up into the Facebook home page - no ads or anything, which is why I'm puzzled. Like I said, I have a popup blocker so I generally don't have problems with ad popups on my computer. I have been in my control panel uninstalling programs that I don't need or recognise so maybe this will help as well.
posted by triggerfinger at 5:08 PM on October 12, 2008


I've always heard it's better but I have no idea why

Here's big reason why: Adblock.
posted by SPrintF at 5:50 PM on October 12, 2008


It's better because it easily solves problems such as being bombarded with pop ups.
posted by fire&wings at 6:11 PM on October 12, 2008


You should still be concerned about this infection. Post the HijackThis files on a site where they are regularly analyzed and you will get better help. Something is probably installed as a browser helper object and you still need to get rid of it because it could be a point of entry for something else.
posted by dhartung at 11:04 PM on October 12, 2008


I agree with dhartung. You still need to figure out the problem and get rid of it.

That said, here's my method of staying secure as possible -
  1. Only use Firefox
  2. Install the Firefox extension NoScript
  3. Disable Java
  4. In "Firefox Tools > Options > Applications" set every entry except Flash to "Always Ask"
NoScript requires you to explicitly allow javascript to run on sites. Changing the "Applications" settings will make it so that you don't expose yourself to vulnerabilities in third party programs such as Quicktime or Windows Media Player simply by browsing. It will get rid of your ability to play those formats inside the browser.

This may seem paranoid at first but it's really not that big of a deal once you get used to it. I've worked a bit with web app security and believe me when I say you want to take these steps. It makes you a lot less vulnerable.
posted by sipher at 11:37 AM on October 13, 2008


I never really seemed to have problems on IE

That you know of.

Seriously, Internet Explorer, along with any of the older versions of Outlook, may as well be called the Microsoft Virus Writers Toolkit™. Use Firefox. If you can handle it, add NoScipt. It starts out intrusive, because it blacklists every site and makes you whitelist those sites you trust, but really how many sites do you regularly visit?

You may also want to look at what Facebook applications you've authorized.
posted by JaredSeth at 1:07 PM on October 13, 2008


Thanks everyone for your help. I am now using (and getting used to) Firefox and I've added NoScript. Hopefully these along with Stopzilla will help to keep my computer safe.
posted by triggerfinger at 12:58 PM on October 15, 2008


« Older Where can I drink Harney &...   |  Today, I have an MS in sociolo... Newer »
This thread is closed to new comments.