Join 3,424 readers in helping fund MetaFilter (Hide)


How do I open PC volumes that my Mac can see on a Windows network but can't open.
September 29, 2008 10:03 AM   Subscribe

How do I open PC volumes that my Mac can see on a Windows network but can't open.

I'm in a windows environment with the sole Mac. We have a server with multiple computers networked. From the PC's connected to the network I can log in fine. I can see each of these volumes from my Mac. But when I try to open most of them I get a connection failure. When I log in from a PC I have to give my user name and password but when opening from the Mac it doesn't ask me to. I'm trying to open these computers from the Finder. Any suggestions for opening these computers from my mac? I am a beginner in working with networks and logging Mac's into PC's. Thanks for any help.
posted by jeffreyclong to Computers & Internet (4 answers total)
 
Try connecting using smb.

So in the "Go" menu select "connect to server." (command k from the finder).

Try entering in the PC address like this: smb://servenameorIP.

Alternatively, assuming a recent PC OS Apple File Services may need to be turned on.
posted by cjorgensen at 10:25 AM on September 29, 2008


Samba can do this. Find out the server name and share. Lets say your file server called FS01 and the share is called Stuff. In safari you would type:

smb://FS01/stuff

It should ask you for login credentials.

Macs may have trouble resolving WINS if they are not setup for it. In that case find the IP of FS01 and try it again. Assuming the IP is 192.168.1.10

smb://192.168.1.10/stuff

More at Apple:

http://support.apple.com/kb/HT1568
posted by damn dirty ape at 11:06 AM on September 29, 2008


When you click on the networked computers in the Finder, you should see a "Connect As..." button appear in the top right while your Mac tries to open the shared files*. Click this button. Enter a valid user name/password and you should be good to go. You may have to include the domain or computer name in with the user name ("computername/username") for this to work.

(*10.5.5; on 10.4.X you may have different options...)
posted by caution live frogs at 11:09 AM on September 29, 2008


Thanks! This did the trick.

If anyone has any suggestions for cases in which it gets cranky I'd appreciate it. More specialized cases. But so far, this is working as it's supposed to.
posted by jeffreyclong at 11:10 AM on September 29, 2008


« Older Low grade fever, intermittent ...   |  I'm creating a basic study gui... Newer »
This thread is closed to new comments.