Join 3,433 readers in helping fund MetaFilter (Hide)


I don't need no stinking scrollbars.
September 12, 2008 3:20 PM   Subscribe

Why can't I get rid of the Terminal's scrollbar in OS X 10.5?

I'm pretty sure I had this figured out in 10.4, but I just noticed today that the scrollbar is back and I can't get rid of it. None of the older tricks work, and the one Leopard-specific one I did find (downloading some App called Deeper) didn't work either.

Just to be clear, I want to get rid of the scrollbar itself, not the scrollback buffer. I understand one of the earliest ways to get rid of the scrollbar was to just set the buffer to 0 but that's not what I'd like to do.
posted by Venadium to Computers & Internet (9 answers total)
 
I think iTerm does this, FWIW.
posted by cmiller at 3:35 PM on September 12, 2008


If you google "os x terminal remove scrollbar", theres lots of solutions.

Here's a simple macosxhints.com solution
posted by wongcorgi at 3:39 PM on September 12, 2008


I know there's lots of Google results, but none that seem to work. That macosxhints.com solution is from 2003 and the menu items it refers to don't even exist in Terminal anymore.
posted by Venadium at 3:53 PM on September 12, 2008


Out of curiosity, I tried opening up some nib files for the Terminal app, to try to find a scroll view and flip its scrollbar switch. No luck on this end. Hope you find a non-iTerm answer!
posted by Blazecock Pileon at 4:14 PM on September 12, 2008


Ok, here goes. It's a bit tedious, but I just tried it out and it works.

1) Download PListEdit Pro and drag to your /Applications folder. Launch it.
2) Open up ~/Library/Preferences/com.Apple.Terminal.plist with this program
3) This is a binary file. You'll need to switch to XML mode using the Operations --> Change Format tool in the menubar
4) Once switched to XML view add the following line to the very top of section. Make it your first key / string

Scrollbar>
NO

5) Switch back to binary mode and save the file
6) Launch Terminal. It should be scrollbar-less.

I haven't tested it but am fairly sure that if you made a Preferences change in Terminal.app, it will overwrite these settings since it'd write down a new .plist file.

posted by mrbarrett.com at 4:30 PM on September 12, 2008


Hmm....formatting on those strings didn't come out well in the post...also this isn't as stable as I'd like. Let me play with this a bit more. I'll post back again with more info as I figure this out...

The string should be:
<key>Scrollbar</key><string>NO</string>

posted by mrbarrett.com at 4:45 PM on September 12, 2008


$ defaults read com.apple.Terminal | grep -i scrollbar
    Scrollbar = 1;
$ defaults write com.apple.Terminal Scrollbar -bool FALSE
works for me under Leopard. It takes effect on the next window you open.
posted by harmfulray at 4:50 PM on September 12, 2008


None of these things are working for me for some reason. I really don't get it.

defaults read com.apple.Terminal | grep -i scrollbar actually returns:

Scrollbar = 0;

And adding the key using PListEdit had no effect either.
posted by Venadium at 6:02 PM on September 12, 2008


I gave up and just copied the Terminal.app from my Tiger install disc and the scrollbar is gone. So if anyone comes across this post in the future, looks like that's the only solution that works at the moment.
posted by Venadium at 7:32 PM on September 12, 2008


« Older Piano lovers: please suggest m...   |  So, does cocaine have terroir?... Newer »
This thread is closed to new comments.