Why won't Firefox let me login anywhere?
September 9, 2008 10:20 AM   Subscribe

Firefox brings me back to any website's login screen, ad infinitum. Help me make it stop.

Three days ago Firefox stopped keeping me logged in and, more infuriatingly, refuses to log me in to any website that requires it, despite numerous correct attempts. Every attempt brings me right back to a login screen. It even pre-populates the username/password boxes with the correct info, but on Submit just brings me back to the login screen. I thought it was a plug-in I'd installed, so I uninstalled that. Nope. I rechecked my passwords to make sure they're correct (yes), searched the FF/Mozilla forums (couldn't find this particular issue), successfully used said passwords in Safari, and finally uninstalled and reinstalled FF. No luck - same behavior. I would just ditch FF and use Safari, but there are a few things I do that require FF. Help?

Further, maybe relevant, details:
- When some websites launch they do show me as logged in (e.g., Metafilter in the upper right) but when I do anything that requires login (e.g., post a question), then it brings me to the login page. Cue loop of login despair...
- I couldn't find my Firefox Profile in the logical place, nor anywhere on my computer.
- Using Terminal to try to create a new Profile wouldn't work (I always lose focus to type in Terminal and it instead types in the underlying application--in this case MSWord, which I had open to read the instructions on how to create a new Profile). Arg!!!
posted by cocoagirl to Computers & Internet (15 answers total)
 
What's the value of
network.http.sendRefererHeader
in about:config (type about:config into the address bar)?
posted by donut at 10:28 AM on September 9, 2008


Something is preventing cookies from being saved. Check Firefox cookie settings, any Firefox extensions relating to cookies, any proxies that may strip cookie data.
posted by orthogonality at 10:30 AM on September 9, 2008


donut:
Status: default
Type: Integer
Value: 2

orthogonality: "Accept cookies from sites" is unchecked but the Exceptions list has Allow for the sites I do want to Allow. "Keep until they expire" is the option I have set.
posted by cocoagirl at 10:43 AM on September 9, 2008


Ok. My wild guess was wrong. That option is ok.
posted by donut at 10:49 AM on September 9, 2008


Do you have the Stealther add-on installed?
posted by benzo8 at 10:56 AM on September 9, 2008


A spotlight search turns up nothing with Stealther or extension .xpi.
posted by cocoagirl at 11:00 AM on September 9, 2008


Weird, I'm having this problem as well and had just updated Firefox...I'll be watching to see if someone can fix this as it is making online bill paying excessively difficult!
posted by Bibliogeek at 11:03 AM on September 9, 2008


One problem I've run into -- especially with banking sites -- is that once in a while a router isn't configured properly. I accidentally set the NAT rule in PF once to NAT to the whole range of external addresses rather than a single one.

This means that instead of appearing to be making requests from a single IP address, I was making them from a different one each time, round-robin. Many websites do not like this very much and will not acknowledge your login attempt while not telling you why it's being rejected. Try taking your computer to another network and see if you have the same problem. If you do not, see if anyone else is having the same problem. If they are, definitely notify IT. I know it drove me batshit for months until I realized my simple mistake.
posted by cellphone at 11:25 AM on September 9, 2008


I'll be watching to see if someone can fix this as it is making online bill paying excessively difficult!

I specfically had to re-add the exception for the third party cookie for my bank after I upgraded Firefox once, no real idea why that happened. My bank's help page says this

1. From the Firefox menu, click Preferences.
2. From the Privacy tab, in the Cookies section, click the Exceptions button.
3. In the 'Address of web site' field, type pscufs.com and click the Allow button.
4. Click Close to close the Preferences window.
posted by jessamyn at 11:33 AM on September 9, 2008


I've rechecked all the exceptions and cookies and....still no joy.

cellphone: Try taking your computer to another network and see if you have the same problem. If you do not, see if anyone else is having the same problem. If they are, definitely notify IT.
It sounds like you're suggesting this solution from within a corporate environment. This is all on a home laptop and I have no IT support. Or do you mean contact the IT of each website I'm having the problem with? Anyway, I'm not sure what the "NAT rule in PF" is, but I'm willing to try if you can elaborate.
posted by cocoagirl at 11:50 AM on September 9, 2008


Standard mac troubleshooting.

Create a new user and try again. Also, remove all your Firefox preferences/plists (by hand or with a tool like AppZapper) and try again.
posted by wongcorgi at 12:27 PM on September 9, 2008


Create a new profile and start Firefox with it to see if using the default settings (and no extensions) makes a difference.
posted by Zed_Lopez at 12:45 PM on September 9, 2008


I've had this problem, but only with individual websites. You might try going to the Tools menu and selecting "Clear Private Data" (or just hit Ctrl-Shift-Del). Check everything, hit OK, and for good measure restart Firefox.
posted by dsword at 1:46 PM on September 9, 2008


Ok, something there worked. I used AppZapper, reinstalled FF, created a new user and it worked with that user, and now works with my existing user account. Thank you, thank you, thank you!
posted by cocoagirl at 6:43 PM on September 9, 2008


It sounds like your cookies file was corrupted. If it happens again, try deleting (or renaming first) "cookies.sqlite" under your Firefox profile.
posted by qvtqht at 12:20 AM on September 14, 2008


« Older I'm a recent transplant to NYC...   |  Interested in buying and then ... Newer »
This thread is closed to new comments.